diff options
author | Ting Liu <ting.liu@nxp.com> | 2021-10-15 11:04:27 +0800 |
---|---|---|
committer | Ting Liu <ting.liu@nxp.com> | 2021-10-15 22:11:36 +0800 |
commit | 3f6f4bd60f9497008deea11d3ca4f500200e5b30 (patch) | |
tree | 4cd7f902fcc2cea13761af109120939062a22a6f /recipes-dpaa2/management-complex | |
parent | 4b68cd3d29951a207a2743b4a50b8ae1c1a4f4b9 (diff) | |
download | meta-freescale-3f6f4bd60f9497008deea11d3ca4f500200e5b30.tar.gz |
management-complex: add recipe for 10.29.0
Signed-off-by: Ting Liu <ting.liu@nxp.com>
Diffstat (limited to 'recipes-dpaa2/management-complex')
-rw-r--r-- | recipes-dpaa2/management-complex/management-complex_10.29.0.bb | 41 |
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes-dpaa2/management-complex/management-complex_10.29.0.bb b/recipes-dpaa2/management-complex/management-complex_10.29.0.bb new file mode 100644 index 00000000..ba43b761 --- /dev/null +++ b/recipes-dpaa2/management-complex/management-complex_10.29.0.bb | |||
@@ -0,0 +1,41 @@ | |||
1 | SUMMARY = "DPAA2 Management Complex Firmware" | ||
2 | LICENSE = "NXP-Binary-EULA" | ||
3 | LIC_FILES_CHKSUM = "file://NXP-Binary-EULA.txt;md5=2cb2fee5d3558ee2a81331ed121647ad" | ||
4 | |||
5 | inherit deploy | ||
6 | |||
7 | INHIBIT_DEFAULT_DEPS = "1" | ||
8 | |||
9 | SRC_URI = "git://github.com/nxp/qoriq-mc-binary;nobranch=1" | ||
10 | SRCREV = "d21bc22000a14b0b6eeafc017fb93bc70499f74a" | ||
11 | |||
12 | S = "${WORKDIR}/git" | ||
13 | |||
14 | REGLEX:ls2088a = "ls2088a" | ||
15 | REGLEX:ls2080a = "ls2080a" | ||
16 | REGLEX:ls1088a = "ls1088a" | ||
17 | REGLEX:lx2160a = "lx216xa" | ||
18 | REGLEX:lx2162a = "lx216xa" | ||
19 | |||
20 | do_install () { | ||
21 | install -d ${D}/boot | ||
22 | install -m 755 ${S}/${REGLEX}/*.itb ${D}/boot | ||
23 | } | ||
24 | |||
25 | do_deploy () { | ||
26 | install -d ${DEPLOYDIR}/mc_app | ||
27 | install -m 755 ${S}/${REGLEX}/*.itb ${DEPLOYDIR}/mc_app | ||
28 | # make a symlink to the latest binary | ||
29 | for mc_binary in `find ${DEPLOYDIR}/mc_app -type f -printf "%f\n" |sort`;do | ||
30 | ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb | ||
31 | done | ||
32 | } | ||
33 | addtask deploy before do_build after do_install | ||
34 | |||
35 | PACKAGES += "${PN}-image" | ||
36 | FILES:${PN}-image += "/boot" | ||
37 | |||
38 | INHIBIT_PACKAGE_STRIP = "1" | ||
39 | |||
40 | COMPATIBLE_MACHINE = "(qoriq-arm64)" | ||
41 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||