summaryrefslogtreecommitdiffstats
path: root/recipes-dpaa2/management-complex/management-complex_10.29.0.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2021-10-15 12:02:01 -0300
committerGitHub <noreply@github.com>2021-10-15 12:02:01 -0300
commit9d05232d9a12a52d17039003f8d4b23ac001d378 (patch)
tree9eea3870c4a5af37b4b7613517008d050bda0738 /recipes-dpaa2/management-complex/management-complex_10.29.0.bb
parent2cdfab64a588c7570fe87c0fc3d05f061f2b692c (diff)
parent93d26c3d784f38b5629f31eb08ae7169c44ccb31 (diff)
downloadmeta-freescale-9d05232d9a12a52d17039003f8d4b23ac001d378.tar.gz
Merge pull request #888 from ting-liu/master
updates for Layerscape machines
Diffstat (limited to 'recipes-dpaa2/management-complex/management-complex_10.29.0.bb')
-rw-r--r--recipes-dpaa2/management-complex/management-complex_10.29.0.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes-dpaa2/management-complex/management-complex_10.29.0.bb b/recipes-dpaa2/management-complex/management-complex_10.29.0.bb
new file mode 100644
index 00000000..ba43b761
--- /dev/null
+++ b/recipes-dpaa2/management-complex/management-complex_10.29.0.bb
@@ -0,0 +1,41 @@
1SUMMARY = "DPAA2 Management Complex Firmware"
2LICENSE = "NXP-Binary-EULA"
3LIC_FILES_CHKSUM = "file://NXP-Binary-EULA.txt;md5=2cb2fee5d3558ee2a81331ed121647ad"
4
5inherit deploy
6
7INHIBIT_DEFAULT_DEPS = "1"
8
9SRC_URI = "git://github.com/nxp/qoriq-mc-binary;nobranch=1"
10SRCREV = "d21bc22000a14b0b6eeafc017fb93bc70499f74a"
11
12S = "${WORKDIR}/git"
13
14REGLEX:ls2088a = "ls2088a"
15REGLEX:ls2080a = "ls2080a"
16REGLEX:ls1088a = "ls1088a"
17REGLEX:lx2160a = "lx216xa"
18REGLEX:lx2162a = "lx216xa"
19
20do_install () {
21 install -d ${D}/boot
22 install -m 755 ${S}/${REGLEX}/*.itb ${D}/boot
23}
24
25do_deploy () {
26 install -d ${DEPLOYDIR}/mc_app
27 install -m 755 ${S}/${REGLEX}/*.itb ${DEPLOYDIR}/mc_app
28 # make a symlink to the latest binary
29 for mc_binary in `find ${DEPLOYDIR}/mc_app -type f -printf "%f\n" |sort`;do
30 ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb
31 done
32}
33addtask deploy before do_build after do_install
34
35PACKAGES += "${PN}-image"
36FILES:${PN}-image += "/boot"
37
38INHIBIT_PACKAGE_STRIP = "1"
39
40COMPATIBLE_MACHINE = "(qoriq-arm64)"
41PACKAGE_ARCH = "${MACHINE_ARCH}"