summaryrefslogtreecommitdiffstats
path: root/recipes-dpaa2/management-complex/management-complex_10.16.2.bb
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2019-07-05 11:27:14 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2019-07-12 17:18:34 -0300
commit64dac74a60d4c4f54a628fa14c9c59930b8db35f (patch)
tree410625a09abd1a5366860422e9486004c2783bfb /recipes-dpaa2/management-complex/management-complex_10.16.2.bb
parent9958a6545e6b62e2cdd0d574e3e3c06c2eccd9af (diff)
downloadmeta-freescale-64dac74a60d4c4f54a628fa14c9c59930b8db35f.tar.gz
mc: update to f72b978
*update to lsdk 1906 tag include the following changes: f72b978 - Add the prebuilt binaries of mc 10.16.2 release a7d982e - Update the license file *Upgrade version to 10.16.2 Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
Diffstat (limited to 'recipes-dpaa2/management-complex/management-complex_10.16.2.bb')
-rw-r--r--recipes-dpaa2/management-complex/management-complex_10.16.2.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes-dpaa2/management-complex/management-complex_10.16.2.bb b/recipes-dpaa2/management-complex/management-complex_10.16.2.bb
new file mode 100644
index 00000000..435544ad
--- /dev/null
+++ b/recipes-dpaa2/management-complex/management-complex_10.16.2.bb
@@ -0,0 +1,40 @@
1SUMMARY = "DPAA2 Management Complex Firmware"
2LICENSE = "NXP-Binary-EULA"
3LIC_FILES_CHKSUM = "file://NXP-Binary-EULA.txt;md5=73d4b970c18882e229e4bf1ada5bb8d6"
4
5inherit deploy fsl-eula-unpack
6
7INHIBIT_DEFAULT_DEPS = "1"
8
9SRC_URI = "git://github.com/nxp/qoriq-mc-binary;fsl-eula=true;nobranch=1"
10SRCREV = "f72b978873af6c7cd0fd92b793363506411c102c"
11
12S = "${WORKDIR}/git"
13
14REGLEX_ls2088a = "ls2088a"
15REGLEX_ls1088a = "ls1088a"
16REGLEX_lx2160a = "lx2160a"
17
18do_install () {
19 install -d ${D}/boot
20 install -m 755 ${S}/${REGLEX}/*.itb ${D}/boot
21}
22
23do_deploy () {
24 install -d ${DEPLOYDIR}/mc_app
25 install -m 755 ${S}/${REGLEX}/*.itb ${DEPLOYDIR}/mc_app
26 # make a symlink to the latest binary
27 for mc_binary in `ls ${DEPLOYDIR}/mc_app |sort`;do
28 ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb
29 done
30}
31addtask deploy before do_build after do_install
32
33PACKAGES += "${PN}-image"
34FILES_${PN}-image += "/boot"
35
36INHIBIT_PACKAGE_STRIP = "1"
37
38COMPATIBLE_MACHINE = "(qoriq-arm64)"
39PACKAGE_ARCH = "${MACHINE_ARCH}"
40