diff options
author | Chunrong Guo <chunrong.guo@nxp.com> | 2017-07-28 15:44:12 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2017-08-07 11:42:29 -0300 |
commit | 0593c5372e532834b77c0ff90c5cde7264c127c8 (patch) | |
tree | b5986b94a448fba183c78a8bf658112a1d493dc0 /recipes-dpaa2/dpl-examples/dpl-examples_git.bb | |
parent | 15bf9e750c3bb22c3b3401f09e2bff4246dc2789 (diff) | |
download | meta-freescale-0593c5372e532834b77c0ff90c5cde7264c127c8.tar.gz |
dpl-examples: update to 592fc2f
This includes the following changes:
592fc2f - Merge pull request #130 in DPAA2/dpl-examples from ~B55220/dpl-examples:master to master
da9c04b - Merge pull request #129 in DPAA2/dpl-examples from lx2160a to master
85a5ea5 - Merge pull request #128 in DPAA2/dpl-examples from ls2088a to master
05b5a68 - Merge pull request #127 in DPAA2/dpl-examples from ls2085a to master
afcab55 - Merge pull request #126 in DPAA2/dpl-examples from ls2081a to master
eb6535c - Merge pull request #125 in DPAA2/dpl-examples from ls2080a to master
bb49641 - Merge pull request #124 in DPAA2/dpl-examples from ls1088a to master
4d810a4 - Merge pull request #123 in DPAA2/dpl-examples from la1575a to master
78c84e4 - add root LICENSE file
69a77c6 - lx2160a: remove GPL license
3308c02 - la1575a: remove GPL license
45ee132 - ls2088a: remove GPL license
9657382 - ls2085a: remove GPL license
c68be77 - ls2081a: remove GPL license
3947c69 - ls2080a: remove GPL license
c2d2753 - ls1088a: remove GPL license
1af1a34 - Merge pull request #113 in DPAA2/dpl-examples from lx2160a to master
8291912 - Merge pull request #114 in DPAA2/dpl-examples from ls2081a to master
9765d6c - Merge pull request #115 in DPAA2/dpl-examples from la1575a to master
9d40fe7 - Merge pull request #112 in DPAA2/dpl-examples from ls1088a to master
33367cd - ls1088a: connect dpni.0 to dpmac.5 rather than dpmac.2
d40e534 - lx2160: Enable DPNI flow steering support
7a46bed - ls2081a: add bootstrap dpl and dpc
b217437 - la1575a: enable hashing and flow steering on all DPNIs
925f9a1 - la1575a: add DPC and DPL for LA1575ARDB
efb5211 - Merge pull request #107 in DPAA2/dpl-examples from lx2160a to master
7b93d0d - lx2160a: updated dtb file
bd13206 - lx2160a: use 8 receive queues for all DPNIs
Signed-off-by: Chunrong Guo <B40290@freescale.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-dpaa2/dpl-examples/dpl-examples_git.bb')
-rw-r--r-- | recipes-dpaa2/dpl-examples/dpl-examples_git.bb | 15 |
1 files changed, 9 insertions, 6 deletions
diff --git a/recipes-dpaa2/dpl-examples/dpl-examples_git.bb b/recipes-dpaa2/dpl-examples/dpl-examples_git.bb index 17946b3f..d6d668ba 100644 --- a/recipes-dpaa2/dpl-examples/dpl-examples_git.bb +++ b/recipes-dpaa2/dpl-examples/dpl-examples_git.bb | |||
@@ -1,30 +1,33 @@ | |||
1 | SUMMARY = "Datapath layout examples" | 1 | SUMMARY = "Datapath layout examples" |
2 | LICENSE = "Freescale-EULA" | 2 | LICENSE = "Freescale-EULA" |
3 | LIC_FILES_CHKSUM = "file://EULA;md5=c9ae442cf1f9dd6c13dfad64b0ffe73f" | 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=386a6287daa6504b7e7e5014ddfb3987" |
4 | 4 | ||
5 | DEPENDS = "dtc-native" | 5 | DEPENDS = "dtc-native" |
6 | 6 | ||
7 | inherit deploy | 7 | inherit deploy |
8 | 8 | ||
9 | SRC_URI = "git://git.freescale.com/ppc/sdk/dpl-examples.git;nobranch=1" | 9 | SRC_URI = "git://github.com/qoriq-open-source/dpl-examples.git;nobranch=1" |
10 | SRCREV = "cea280fd06b9c43fa73f3d9ef629b171cccd0fcd" | 10 | SRCREV = "592fc2fd1f13107c8a4ae8070fed11a5f8d10471" |
11 | 11 | ||
12 | S = "${WORKDIR}/git" | 12 | S = "${WORKDIR}/git" |
13 | 13 | ||
14 | REGLEX_ls2088a = "ls2088a" | ||
15 | REGLEX_ls1088a = "ls1088a" | ||
16 | |||
14 | do_install () { | 17 | do_install () { |
15 | install -d ${D}/boot | 18 | install -d ${D}/boot |
16 | install -m 644 ${S}/ls2080a/RDB/*.dtb ${D}/boot | 19 | install -m 644 ${S}/${REGLEX}/RDB/*.dtb ${D}/boot |
17 | } | 20 | } |
18 | 21 | ||
19 | do_deploy () { | 22 | do_deploy () { |
20 | install -d ${DEPLOYDIR}/dpl-examples | 23 | install -d ${DEPLOYDIR}/dpl-examples |
21 | install -m 644 ${S}/ls2080a/RDB/*.dtb ${DEPLOYDIR}/dpl-examples | 24 | install -m 644 ${S}/${REGLEX}/RDB/*.dtb ${DEPLOYDIR}/dpl-examples |
22 | } | 25 | } |
23 | addtask deploy before do_build after do_install | 26 | addtask deploy before do_build after do_install |
24 | 27 | ||
25 | PACKAGES += "${PN}-image" | 28 | PACKAGES += "${PN}-image" |
26 | FILES_${PN}-image += "/boot" | 29 | FILES_${PN}-image += "/boot" |
27 | 30 | ||
28 | COMPATIBLE_MACHINE = "(ls2080ardb|ls2088a)" | 31 | COMPATIBLE_MACHINE = "(ls2080ardb|ls2088a|ls1088a)" |
29 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 32 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
30 | 33 | ||