summaryrefslogtreecommitdiffstats
path: root/recipes-dpaa/usdpaa
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-07-23 16:02:25 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-07-28 23:26:59 -0300
commit6a868a671472d454b407a165fc31c5f7dfe783c6 (patch)
tree7bd2ab13a04d14215264cc992501970cacfb20ef /recipes-dpaa/usdpaa
parent62e212fe4812a6c726df4ac8e77d4a77e0e54247 (diff)
downloadmeta-freescale-6a868a671472d454b407a165fc31c5f7dfe783c6.tar.gz
Move meta-fsl-ppc content to layer root
This commit is just a rename of all contents of meta-fsl-ppc subdirectory to this layer's root, merging the contents of common files, subsequent changes are based on top of that. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-dpaa/usdpaa')
-rw-r--r--recipes-dpaa/usdpaa/usdpaa_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-dpaa/usdpaa/usdpaa_git.bb b/recipes-dpaa/usdpaa/usdpaa_git.bb
new file mode 100644
index 00000000..32cad124
--- /dev/null
+++ b/recipes-dpaa/usdpaa/usdpaa_git.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "User-Space Data-Path Acceleration Architecture Drivers"
2LICENSE = "BSD & GPLv2"
3LIC_FILES_CHKSUM = "file://Makefile;endline=30;md5=39e58bedc879163c9338596e52df5b1f"
4PR = "r4"
5
6inherit pkgconfig
7
8PACKAGE_ARCH = "${MACHINE_ARCH}"
9
10DEPENDS += "flib"
11
12SRC_URI = "git://git.freescale.com/ppc/sdk/usdpaa.git;nobranch=1"
13SRCREV = "3b0717952400577608a548fc4c4858a9efd1bd96"
14
15S = "${WORKDIR}/git"
16
17EXTRA_OEMAKE = 'CC="${CC}" LD="${LD}" AR="${AR}"'
18export ARCH="${TARGET_ARCH}"
19
20do_install () {
21 oe_runmake install DESTDIR=${D}
22}
23
24PARALLEL_MAKE_pn-${PN} = ""
25
26COMPATIBLE_HOST_qoriq-ppc = ".*"
27COMPATIBLE_HOST ?= "(none)"