summaryrefslogtreecommitdiffstats
path: root/recipes-dpaa/fmlib/fmlib_git.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-07-23 16:02:25 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-07-28 23:26:59 -0300
commit6a868a671472d454b407a165fc31c5f7dfe783c6 (patch)
tree7bd2ab13a04d14215264cc992501970cacfb20ef /recipes-dpaa/fmlib/fmlib_git.bb
parent62e212fe4812a6c726df4ac8e77d4a77e0e54247 (diff)
downloadmeta-freescale-6a868a671472d454b407a165fc31c5f7dfe783c6.tar.gz
Move meta-fsl-ppc content to layer root
This commit is just a rename of all contents of meta-fsl-ppc subdirectory to this layer's root, merging the contents of common files, subsequent changes are based on top of that. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-dpaa/fmlib/fmlib_git.bb')
-rw-r--r--recipes-dpaa/fmlib/fmlib_git.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/recipes-dpaa/fmlib/fmlib_git.bb b/recipes-dpaa/fmlib/fmlib_git.bb
new file mode 100644
index 00000000..8993f848
--- /dev/null
+++ b/recipes-dpaa/fmlib/fmlib_git.bb
@@ -0,0 +1,45 @@
1DESCRIPTION = "Frame Manager User Space Library"
2SECTION = "fman"
3LICENSE = "BSD & GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=3f16fa8e677e45af3127c5c4bafc3c00"
5
6PR = "r1"
7
8DEPENDS += "virtual/kernel"
9DEPENDS_virtclass-native = ""
10
11SRC_URI = "git://git.freescale.com/ppc/sdk/fmlib.git;nobranch=1"
12SRCREV = "4938e099561d441c947d4ccdf2e601ab2966d8cc"
13
14S = "${WORKDIR}/git"
15
16TARGET_ARCH_FMLIB = "${DEFAULTTUNE}"
17TARGET_ARCH_FMLIB_e5500 = "ppc32e5500"
18TARGET_ARCH_FMLIB_e6500 = "ppc32e6500"
19COMPATIBLE_HOST_qoriq-ppc = ".*"
20COMPATIBLE_HOST ?= "(none)"
21
22EXTRA_OEMAKE = "DESTDIR=${D} PREFIX=${prefix} LIB_DEST_DIR=${libdir} \
23 CROSS_COMPILE=${TARGET_PREFIX} KERNEL_SRC=${STAGING_KERNEL_DIR}"
24
25FMLIB_TARGET = "libfm-${TARGET_ARCH_FMLIB}"
26FMLIB_TARGET_t1 = "libfm-${TARGET_ARCH_FMLIB}-fmv3l"
27do_compile () {
28 oe_runmake ${FMLIB_TARGET}.a
29}
30
31do_compile_virtclass-native () {
32}
33
34do_install () {
35 oe_runmake install-${FMLIB_TARGET}
36}
37
38do_install_virtclass-native () {
39 install -d ${D}/${includedir}
40 cp -rf ${S}/include/* ${D}/${includedir}
41}
42
43ALLOW_EMPTY_${PN} = "1"
44
45BBCLASSEXTEND = "native"