summaryrefslogtreecommitdiffstats
path: root/recipes-dpaa/fm-ucode
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-07-23 16:02:25 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-07-28 23:26:59 -0300
commit6a868a671472d454b407a165fc31c5f7dfe783c6 (patch)
tree7bd2ab13a04d14215264cc992501970cacfb20ef /recipes-dpaa/fm-ucode
parent62e212fe4812a6c726df4ac8e77d4a77e0e54247 (diff)
downloadmeta-freescale-6a868a671472d454b407a165fc31c5f7dfe783c6.tar.gz
Move meta-fsl-ppc content to layer root
This commit is just a rename of all contents of meta-fsl-ppc subdirectory to this layer's root, merging the contents of common files, subsequent changes are based on top of that. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-dpaa/fm-ucode')
-rw-r--r--recipes-dpaa/fm-ucode/fm-ucode_git.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes-dpaa/fm-ucode/fm-ucode_git.bb b/recipes-dpaa/fm-ucode/fm-ucode_git.bb
new file mode 100644
index 00000000..52c79db8
--- /dev/null
+++ b/recipes-dpaa/fm-ucode/fm-ucode_git.bb
@@ -0,0 +1,38 @@
1DESCRIPTION = "Fman microcode binary"
2SECTION = "fm-ucode"
3LICENSE = "Freescale-EULA"
4LIC_FILES_CHKSUM = "file://EULA;md5=60037ccba533a5995e8d1a838d85799c"
5
6PR = "r1"
7
8inherit deploy
9
10SRC_URI = "git://git.freescale.com/ppc/sdk/fm-ucode.git;nobranch=1"
11SRCREV = "2827f0054e125b634fb1701719ca31c7d068e335"
12
13S = "${WORKDIR}/git"
14
15REGLEX ?= "${MACHINE}"
16REGLEX_t1023 = "t1024"
17REGLEX_t1040 = "t1040"
18REGLEX_t1042 = "t1040"
19REGLEX_b4420 = "b4860"
20REGLEX_t4160 = "t4240"
21
22do_install () {
23 UCODE=`echo ${REGLEX} | sed -e 's,-.*$,,' -e 's,[a-zA-Z]*$,,'`
24 install -d ${D}/boot
25 install -m 644 fsl_fman_ucode_${UCODE}*.bin ${D}/boot/
26}
27
28do_deploy () {
29 UCODE=`echo ${REGLEX} | sed -e 's,-.*$,,' -e 's,[a-zA-Z]*$,,'`
30 install -d ${DEPLOYDIR}/
31 install -m 644 fsl_fman_ucode_${UCODE}*.bin ${DEPLOYDIR}/
32}
33addtask deploy before do_build after do_install
34
35PACKAGES += "${PN}-image"
36FILES_${PN}-image += "/boot"
37ALLOW_EMPTY_${PN} = "1"
38COMPATIBLE_MACHINE = "(p1023rdb|e500mc|e5500|e5500-64b|e6500|e6500-64b)"