diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-23 16:02:25 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-28 23:26:59 -0300 |
commit | 6a868a671472d454b407a165fc31c5f7dfe783c6 (patch) | |
tree | 7bd2ab13a04d14215264cc992501970cacfb20ef /recipes-dpaa/fm-ucode | |
parent | 62e212fe4812a6c726df4ac8e77d4a77e0e54247 (diff) | |
download | meta-freescale-6a868a671472d454b407a165fc31c5f7dfe783c6.tar.gz |
Move meta-fsl-ppc content to layer root
This commit is just a rename of all contents of meta-fsl-ppc
subdirectory to this layer's root, merging the contents of common
files, subsequent changes are based on top of that.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-dpaa/fm-ucode')
-rw-r--r-- | recipes-dpaa/fm-ucode/fm-ucode_git.bb | 38 |
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes-dpaa/fm-ucode/fm-ucode_git.bb b/recipes-dpaa/fm-ucode/fm-ucode_git.bb new file mode 100644 index 00000000..52c79db8 --- /dev/null +++ b/recipes-dpaa/fm-ucode/fm-ucode_git.bb | |||
@@ -0,0 +1,38 @@ | |||
1 | DESCRIPTION = "Fman microcode binary" | ||
2 | SECTION = "fm-ucode" | ||
3 | LICENSE = "Freescale-EULA" | ||
4 | LIC_FILES_CHKSUM = "file://EULA;md5=60037ccba533a5995e8d1a838d85799c" | ||
5 | |||
6 | PR = "r1" | ||
7 | |||
8 | inherit deploy | ||
9 | |||
10 | SRC_URI = "git://git.freescale.com/ppc/sdk/fm-ucode.git;nobranch=1" | ||
11 | SRCREV = "2827f0054e125b634fb1701719ca31c7d068e335" | ||
12 | |||
13 | S = "${WORKDIR}/git" | ||
14 | |||
15 | REGLEX ?= "${MACHINE}" | ||
16 | REGLEX_t1023 = "t1024" | ||
17 | REGLEX_t1040 = "t1040" | ||
18 | REGLEX_t1042 = "t1040" | ||
19 | REGLEX_b4420 = "b4860" | ||
20 | REGLEX_t4160 = "t4240" | ||
21 | |||
22 | do_install () { | ||
23 | UCODE=`echo ${REGLEX} | sed -e 's,-.*$,,' -e 's,[a-zA-Z]*$,,'` | ||
24 | install -d ${D}/boot | ||
25 | install -m 644 fsl_fman_ucode_${UCODE}*.bin ${D}/boot/ | ||
26 | } | ||
27 | |||
28 | do_deploy () { | ||
29 | UCODE=`echo ${REGLEX} | sed -e 's,-.*$,,' -e 's,[a-zA-Z]*$,,'` | ||
30 | install -d ${DEPLOYDIR}/ | ||
31 | install -m 644 fsl_fman_ucode_${UCODE}*.bin ${DEPLOYDIR}/ | ||
32 | } | ||
33 | addtask deploy before do_build after do_install | ||
34 | |||
35 | PACKAGES += "${PN}-image" | ||
36 | FILES_${PN}-image += "/boot" | ||
37 | ALLOW_EMPTY_${PN} = "1" | ||
38 | COMPATIBLE_MACHINE = "(p1023rdb|e500mc|e5500|e5500-64b|e6500|e6500-64b)" | ||