diff options
author | Pierre-Jean Texier <texier.pj2@gmail.com> | 2021-11-03 22:10:20 +0100 |
---|---|---|
committer | Pierre-Jean Texier <texier.pj2@gmail.com> | 2021-11-03 22:27:01 +0100 |
commit | bef00d6e4f25b4a9d3272e0d69db7545590ed204 (patch) | |
tree | 93ee6b4fb459a7719aae1f3010d8c5d65be3e2b2 /recipes-devtools | |
parent | 16e922408678425a492bd109350cd217a0841280 (diff) | |
download | meta-freescale-bef00d6e4f25b4a9d3272e0d69db7545590ed204.tar.gz |
recipes: use https protocol and add explicit branch parameter
Due to https://github.blog/2021-09-01-improving-git-protocol-security-github/#no-more-unauthenticated-git
it is required to use https protocol for github repo accessing.
Update created with oe-core/scripts/contrib/convert-srcuri.py (see [0])
Fixes:
WARNING: /work/meta-freescale/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2021.07.bb: URL: git://github.com/Freescale/u-boot-fslc.git;branch=2021.07+fslc uses git protocol which is no longer supported by github. Please change to ;protocol=https in the url.
[0] - https://git.openembedded.org/openembedded-core/tree/scripts/contrib/convert-srcuri.py
Signed-off-by: Pierre-Jean Texier <texier.pj2@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r-- | recipes-devtools/devregs/devregs_git.bb | 2 | ||||
-rw-r--r-- | recipes-devtools/imx-usb-loader/imx-usb-loader_git.bb | 2 | ||||
-rw-r--r-- | recipes-devtools/utp-com/utp-com_git.bb | 2 | ||||
-rw-r--r-- | recipes-devtools/uuu/uuu_git.bb | 2 |
4 files changed, 4 insertions, 4 deletions
diff --git a/recipes-devtools/devregs/devregs_git.bb b/recipes-devtools/devregs/devregs_git.bb index 7f158fd8..59328ab3 100644 --- a/recipes-devtools/devregs/devregs_git.bb +++ b/recipes-devtools/devregs/devregs_git.bb | |||
@@ -4,7 +4,7 @@ LICENSE = "GPL-1" | |||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=5003fa041d799dd5dd5f646b74e36924" | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=5003fa041d799dd5dd5f646b74e36924" |
5 | 5 | ||
6 | SRCREV = "d5f6223027f4d6ae71bd5d432f5611486e0e6074" | 6 | SRCREV = "d5f6223027f4d6ae71bd5d432f5611486e0e6074" |
7 | SRC_URI = "git://github.com/boundarydevices/devregs.git;protocol=http" | 7 | SRC_URI = "git://github.com/boundarydevices/devregs.git;protocol=https;branch=master" |
8 | 8 | ||
9 | PV = "1.0+${SRCPV}" | 9 | PV = "1.0+${SRCPV}" |
10 | 10 | ||
diff --git a/recipes-devtools/imx-usb-loader/imx-usb-loader_git.bb b/recipes-devtools/imx-usb-loader/imx-usb-loader_git.bb index c5f51983..1a1e1a9c 100644 --- a/recipes-devtools/imx-usb-loader/imx-usb-loader_git.bb +++ b/recipes-devtools/imx-usb-loader/imx-usb-loader_git.bb | |||
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" | |||
6 | DEPENDS = "libusb1" | 6 | DEPENDS = "libusb1" |
7 | 7 | ||
8 | SRCREV = "f009770d841468204ab104bf7d3b0c5bc8425dbb" | 8 | SRCREV = "f009770d841468204ab104bf7d3b0c5bc8425dbb" |
9 | SRC_URI = "git://github.com/boundarydevices/imx_usb_loader.git;protocol=http" | 9 | SRC_URI = "git://github.com/boundarydevices/imx_usb_loader.git;protocol=https;branch=master" |
10 | 10 | ||
11 | PV = "1.0+${SRCPV}" | 11 | PV = "1.0+${SRCPV}" |
12 | 12 | ||
diff --git a/recipes-devtools/utp-com/utp-com_git.bb b/recipes-devtools/utp-com/utp-com_git.bb index db2d7f08..0b0a6cf2 100644 --- a/recipes-devtools/utp-com/utp-com_git.bb +++ b/recipes-devtools/utp-com/utp-com_git.bb | |||
@@ -6,7 +6,7 @@ DEPENDS = "sg3-utils" | |||
6 | 6 | ||
7 | SRCREV = "dee512ced1e9367d223d22f10797fbf9aeacfab6" | 7 | SRCREV = "dee512ced1e9367d223d22f10797fbf9aeacfab6" |
8 | SRC_URI = " \ | 8 | SRC_URI = " \ |
9 | git://github.com/Freescale/utp_com;protocol=https \ | 9 | git://github.com/Freescale/utp_com;protocol=https;branch=master \ |
10 | " | 10 | " |
11 | 11 | ||
12 | PV = "1.0+git${SRCPV}" | 12 | PV = "1.0+git${SRCPV}" |
diff --git a/recipes-devtools/uuu/uuu_git.bb b/recipes-devtools/uuu/uuu_git.bb index 1726e990..dedcbe84 100644 --- a/recipes-devtools/uuu/uuu_git.bb +++ b/recipes-devtools/uuu/uuu_git.bb | |||
@@ -2,7 +2,7 @@ SUMMARY = "Universal Update Utility" | |||
2 | DESCRIPTION = "Image deploy tool for i.MX chips" | 2 | DESCRIPTION = "Image deploy tool for i.MX chips" |
3 | HOMEPAGE = "https://github.com/NXPmicro/mfgtools" | 3 | HOMEPAGE = "https://github.com/NXPmicro/mfgtools" |
4 | 4 | ||
5 | SRC_URI = "git://github.com/NXPmicro/mfgtools.git;protocol=https" | 5 | SRC_URI = "git://github.com/NXPmicro/mfgtools.git;protocol=https;branch=master" |
6 | SRCREV = "e10b0260076e0119c259f7f44447904f14109ba2" | 6 | SRCREV = "e10b0260076e0119c259f7f44447904f14109ba2" |
7 | PV = "1.4.165" | 7 | PV = "1.4.165" |
8 | 8 | ||