diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2022-07-23 12:50:00 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2022-07-25 18:01:47 -0300 |
commit | 2f26da887f04c639e0e0bb405dfb8f87c174e627 (patch) | |
tree | f3bc39e726bd8d6a9c366d54a80955d09bafdbfc /recipes-devtools/qoriq-cst | |
parent | 912908ce41427c6510b2b6464c83e12f6f11a0e4 (diff) | |
download | meta-freescale-2f26da887f04c639e0e0bb405dfb8f87c174e627.tar.gz |
qoriq-cst: rename cst to qoriq-cst
The QoriQ SoCs use a different cst tool for secure boot than i.MX SoCs
so we should name it with SoC family prefix to avoid confusion.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-devtools/qoriq-cst')
-rw-r--r-- | recipes-devtools/qoriq-cst/qoriq-cst/0001-tools-Mark-struct-input_field-file_field-extern.patch | 43 | ||||
-rw-r--r-- | recipes-devtools/qoriq-cst/qoriq-cst_git.bb | 43 |
2 files changed, 86 insertions, 0 deletions
diff --git a/recipes-devtools/qoriq-cst/qoriq-cst/0001-tools-Mark-struct-input_field-file_field-extern.patch b/recipes-devtools/qoriq-cst/qoriq-cst/0001-tools-Mark-struct-input_field-file_field-extern.patch new file mode 100644 index 00000000..d25675aa --- /dev/null +++ b/recipes-devtools/qoriq-cst/qoriq-cst/0001-tools-Mark-struct-input_field-file_field-extern.patch | |||
@@ -0,0 +1,43 @@ | |||
1 | From 81ec65e72f357fb2c395e40c5195434bbaddf7f7 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 16 May 2020 08:21:52 -0700 | ||
4 | Subject: [PATCH] tools: Mark struct input_field file_field extern | ||
5 | |||
6 | This struct is already defined in common/parse_utils.c | ||
7 | |||
8 | Upstream-Status: Pending | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | tools/header_generation/create_hdr_common.c | 2 +- | ||
12 | tools/pbi_creation/create_pbi_common.c | 2 +- | ||
13 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
14 | |||
15 | diff --git a/tools/header_generation/create_hdr_common.c b/tools/header_generation/create_hdr_common.c | ||
16 | index bfa90a3..edf632c 100644 | ||
17 | --- a/tools/header_generation/create_hdr_common.c | ||
18 | +++ b/tools/header_generation/create_hdr_common.c | ||
19 | @@ -39,7 +39,7 @@ | ||
20 | #include <crypto_utils.h> | ||
21 | |||
22 | extern struct g_data_t gd; | ||
23 | -struct input_field file_field; | ||
24 | +extern struct input_field file_field; | ||
25 | |||
26 | extern char line_data[]; | ||
27 | static struct option long_options[] = { | ||
28 | diff --git a/tools/pbi_creation/create_pbi_common.c b/tools/pbi_creation/create_pbi_common.c | ||
29 | index ff2ed84..bd976da 100644 | ||
30 | --- a/tools/pbi_creation/create_pbi_common.c | ||
31 | +++ b/tools/pbi_creation/create_pbi_common.c | ||
32 | @@ -57,7 +57,7 @@ static char *parse_list[] = { | ||
33 | |||
34 | extern struct g_data_t gd; | ||
35 | extern char line_data[]; | ||
36 | -struct input_field file_field; | ||
37 | +extern struct input_field file_field; | ||
38 | |||
39 | #define NUM_PARSE_LIST (sizeof(parse_list) / sizeof(char *)) | ||
40 | |||
41 | -- | ||
42 | 2.26.2 | ||
43 | |||
diff --git a/recipes-devtools/qoriq-cst/qoriq-cst_git.bb b/recipes-devtools/qoriq-cst/qoriq-cst_git.bb new file mode 100644 index 00000000..ca0f35fb --- /dev/null +++ b/recipes-devtools/qoriq-cst/qoriq-cst_git.bb | |||
@@ -0,0 +1,43 @@ | |||
1 | SUMMARY = "utility for security boot" | ||
2 | SECTION = "cst" | ||
3 | LICENSE = "BSD-3-Clause" | ||
4 | |||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=e959d5d617e33779d0e90ce1d9043eff" | ||
6 | |||
7 | DEPENDS += "openssl qoriq-cst-native" | ||
8 | RDEPENDS:${PN} = "bash" | ||
9 | |||
10 | GENKEYS ?= "${STAGING_BINDIR_NATIVE}/cst/gen_keys" | ||
11 | GENKEYS:class-native = "./gen_keys" | ||
12 | |||
13 | inherit kernel-arch | ||
14 | |||
15 | # specify the non default keys pair for secure boot if needed | ||
16 | #SECURE_PRI_KEY = "/path/srk.pri" | ||
17 | #SECURE_PUB_KEY = "/path/srk.pub" | ||
18 | |||
19 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/cst;nobranch=1 \ | ||
20 | file://0001-tools-Mark-struct-input_field-file_field-extern.patch \ | ||
21 | " | ||
22 | SRCREV = "dfe30d3f05cfe281896482839e57ed49c52f2088" | ||
23 | |||
24 | S = "${WORKDIR}/git" | ||
25 | |||
26 | EXTRA_OEMAKE = 'CC="${CC}" LD="${CC}"' | ||
27 | CFLAGS:append = ' -Wno-deprecated-declarations' | ||
28 | |||
29 | PARALLEL_MAKE = "" | ||
30 | |||
31 | do_install () { | ||
32 | oe_runmake install DESTDIR=${D} BIN_DEST_DIR=${bindir} | ||
33 | |||
34 | if [ -n "${SECURE_PRI_KEY}" ]; then | ||
35 | cp -f ${SECURE_PRI_KEY} ${D}/${bindir}/cst/srk.pri | ||
36 | cp -f ${SECURE_PUB_KEY} ${D}/${bindir}/cst/srk.pub | ||
37 | elif [ ! -f ${D}/${bindir}/cst/srk.pri -o ! ${D}/${bindir}/cst/srk.pub ]; then | ||
38 | cd ${D}/${bindir}/cst && ${GENKEYS} 1024 | ||
39 | fi | ||
40 | } | ||
41 | |||
42 | FILES:${PN}-dbg += "${bindir}/cst/.debug" | ||
43 | BBCLASSEXTEND = "native nativesdk" | ||