diff options
author | Chunrong Guo <chunrong.guo@nxp.com> | 2017-08-30 17:28:20 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2017-08-30 10:08:09 -0300 |
commit | 1f1d3596cae5617c697a859dd81696426c17e0bc (patch) | |
tree | 6f0871cfe93cb261be58140c42dda98d88e88c22 /recipes-devtools/qemu | |
parent | 477be61b278213bc536ccda149f0c97a83b8cc76 (diff) | |
download | meta-freescale-1f1d3596cae5617c697a859dd81696426c17e0bc.tar.gz |
qemu-qoriq: remove
This pkg will not be supported anymore.
Signed-off-by: Chunrong Guo <B40290@freescale.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-devtools/qemu')
-rw-r--r-- | recipes-devtools/qemu/qemu-qoriq/add-ptest-in-makefile.patch | 29 | ||||
-rw-r--r-- | recipes-devtools/qemu/qemu-qoriq/run-ptest | 8 | ||||
-rw-r--r-- | recipes-devtools/qemu/qemu-qoriq_git.bb | 84 |
3 files changed, 0 insertions, 121 deletions
diff --git a/recipes-devtools/qemu/qemu-qoriq/add-ptest-in-makefile.patch b/recipes-devtools/qemu/qemu-qoriq/add-ptest-in-makefile.patch deleted file mode 100644 index a99f7209..00000000 --- a/recipes-devtools/qemu/qemu-qoriq/add-ptest-in-makefile.patch +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | Upstream-Status: Pending | ||
2 | |||
3 | Add subpackage -ptest which runs all unit test cases for qemu. | ||
4 | |||
5 | Signed-off-by: Kai Kang <kai.kang@windriver.com> | ||
6 | --- | ||
7 | tests/Makefile | 10 ++++++++++ | ||
8 | 1 file changed, 10 insertions(+) | ||
9 | |||
10 | diff --git a/tests/Makefile b/tests/Makefile | ||
11 | index 88f7105..3f40b4b 100644 | ||
12 | --- a/tests/Makefile | ||
13 | +++ b/tests/Makefile | ||
14 | @@ -405,3 +405,12 @@ all: $(QEMU_IOTESTS_HELPERS-y) | ||
15 | |||
16 | -include $(wildcard tests/*.d) | ||
17 | -include $(wildcard tests/libqos/*.d) | ||
18 | + | ||
19 | +buildtest-TESTS: $(check-unit-y) | ||
20 | + | ||
21 | +runtest-TESTS: | ||
22 | + for f in $(check-unit-y); do \ | ||
23 | + nf=$$(echo $$f | sed 's/tests\//\.\//g'); \ | ||
24 | + $$nf; \ | ||
25 | + done | ||
26 | + | ||
27 | -- | ||
28 | 1.7.9.5 | ||
29 | |||
diff --git a/recipes-devtools/qemu/qemu-qoriq/run-ptest b/recipes-devtools/qemu/qemu-qoriq/run-ptest deleted file mode 100644 index f4b8e97e..00000000 --- a/recipes-devtools/qemu/qemu-qoriq/run-ptest +++ /dev/null | |||
@@ -1,8 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | # | ||
3 | #This script is used to run qemu test suites | ||
4 | ptestdir=$(pwd) | ||
5 | cd tests | ||
6 | |||
7 | export SRC_PATH=$ptestdir | ||
8 | make -k runtest-TESTS | sed '/: OK/ s/^/PASS: /g' | ||
diff --git a/recipes-devtools/qemu/qemu-qoriq_git.bb b/recipes-devtools/qemu/qemu-qoriq_git.bb deleted file mode 100644 index 87662e13..00000000 --- a/recipes-devtools/qemu/qemu-qoriq_git.bb +++ /dev/null | |||
@@ -1,84 +0,0 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
2 | |||
3 | require recipes-devtools/qemu/qemu.inc | ||
4 | |||
5 | PROVIDES = "qemu" | ||
6 | |||
7 | python() { | ||
8 | pkgs = d.getVar('PACKAGES', True).split() | ||
9 | for p in pkgs: | ||
10 | if 'qemu-qoriq' in p: | ||
11 | d.appendVar("RPROVIDES_%s" % p, p.replace('qemu-qoriq', 'qemu')) | ||
12 | d.appendVar("RCONFLICTS_%s" % p, p.replace('qemu-qoriq', 'qemu')) | ||
13 | d.appendVar("RREPLACES_%s" % p, p.replace('qemu-qoriq', 'qemu')) | ||
14 | } | ||
15 | |||
16 | DESCRIPTION = "This recipe requires poky's qemu.inc which includes the FSL \ | ||
17 | fixes of QorIQ ARM and QorIQ PPC targets. The recipe only works for FSL \ | ||
18 | QorIQ machines. The poky version should be used for native/nativesdk build." | ||
19 | |||
20 | LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \ | ||
21 | file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913" | ||
22 | |||
23 | SRC_URI = "git://git.freescale.com/ppc/sdk/qemu.git;nobranch=1" | ||
24 | SRCREV = "ef54fffcee4324c9a32bf6e260c8141b4e6c542e" | ||
25 | |||
26 | # add ptest patches | ||
27 | SRC_URI_append = "\ | ||
28 | file://add-ptest-in-makefile.patch \ | ||
29 | file://run-ptest \ | ||
30 | " | ||
31 | |||
32 | S = "${WORKDIR}/git" | ||
33 | |||
34 | QEMU_TARGETS_qoriq-ppc = "ppc" | ||
35 | QEMU_TARGETS_qoriq-arm = "arm" | ||
36 | QEMU_TARGETS_qoriq_arm64 = "aarch64" | ||
37 | QEMU_TARGETS_fsl-lsch2-32b = "arm" | ||
38 | PPC_OECONF = '${SDL} --cross-prefix=${TARGET_PREFIX} --disable-werror --disable-vnc --disable-bluez --disable-curl' | ||
39 | EXTRA_OECONF_e5500-64b = "--target-list=ppc64-softmmu ${PPC_OECONF}" | ||
40 | EXTRA_OECONF_e6500-64b = "--target-list=ppc64-softmmu ${PPC_OECONF}" | ||
41 | EXTRA_OECONF_e6500 = "--target-list=ppc64-softmmu ${PPC_OECONF}" | ||
42 | EXTRA_OECONF_e5500 = "--target-list=ppc64-softmmu ${PPC_OECONF}" | ||
43 | EXTRA_OECONF_e500v2 = "--target-list=ppc-softmmu ${PPC_OECONF}" | ||
44 | EXTRA_OECONF_e500mc = "--target-list=ppc-softmmu ${PPC_OECONF}" | ||
45 | PACKAGECONFIG_append = " aio libusb" | ||
46 | |||
47 | DISABLE_STATIC = "" | ||
48 | |||
49 | # Append build host pkg-config paths for native target since the host may provide sdl | ||
50 | do_configure_prepend() { | ||
51 | export PKG_CONFIG=${STAGING_DIR_NATIVE}${bindir_native}/pkg-config | ||
52 | } | ||
53 | |||
54 | do_configure_append () { | ||
55 | if ! grep 'CONFIG_FDT=y' config-host.mak; then | ||
56 | echo "CONFIG_RDMA=y" >> config_host_mak | ||
57 | fi | ||
58 | } | ||
59 | |||
60 | # gets around qemu.inc trying to install powerpc_rom.bin | ||
61 | do_install_prepend() { | ||
62 | touch ${WORKDIR}/powerpc_rom.bin | ||
63 | } | ||
64 | |||
65 | do_install_append() { | ||
66 | rm ${WORKDIR}/powerpc_rom.bin | ||
67 | # Prevent QA warnings about installed ${localstatedir}/run | ||
68 | if [ -d ${D}${localstatedir}/run ]; then rmdir ${D}${localstatedir}/run; fi | ||
69 | } | ||
70 | |||
71 | do_install_ptest() { | ||
72 | cp -rL ${B}/tests ${D}${PTEST_PATH} | ||
73 | find ${D}${PTEST_PATH}/tests -type f -name "*.[Sshcod]" | xargs -i rm -rf {} | ||
74 | |||
75 | cp ${S}/tests/Makefile ${D}${PTEST_PATH}/tests | ||
76 | } | ||
77 | |||
78 | FILES_${PN} += "${datadir}/qemu/" | ||
79 | INSANE_SKIP_${PN} += "dev-deps" | ||
80 | |||
81 | # FIXME: Avoid WARNING due missing patch for native/nativesdk | ||
82 | BBCLASSEXTEND = "" | ||
83 | |||
84 | COMPATIBLE_MACHINE = "(qoriq)" | ||