diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-15 17:14:27 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-16 15:01:29 -0300 |
commit | f8517afc7a5ada4538b3b7d397fa32586d57ffe5 (patch) | |
tree | 79349f091306d1760fd4687e62336ffa8fb8c721 /recipes-devtools/qemu | |
parent | c92b415d653afc55f33b6b93fb9248193bfd4fa0 (diff) | |
download | meta-freescale-f8517afc7a5ada4538b3b7d397fa32586d57ffe5.tar.gz |
Move meta-fsl-arm content to layer root
The meta-fsl-arm is going to be used as the base for this layer. It
contains a clean history and allowing a more granullar set of changes.
This commit is just a rename of all contents of meta-fsl-arm
subdirectory to this layer's root, subsequent changes are based on top
of that.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-devtools/qemu')
-rw-r--r-- | recipes-devtools/qemu/qemu-fsl_git.bb | 49 |
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes-devtools/qemu/qemu-fsl_git.bb b/recipes-devtools/qemu/qemu-fsl_git.bb new file mode 100644 index 00000000..94fb9b19 --- /dev/null +++ b/recipes-devtools/qemu/qemu-fsl_git.bb | |||
@@ -0,0 +1,49 @@ | |||
1 | require recipes-devtools/qemu/qemu.inc | ||
2 | |||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \ | ||
4 | file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913" | ||
5 | |||
6 | # This means QEMU v2.2.0 with FSL specific patches applied | ||
7 | PV = "2.2.0+${SRCPV}" | ||
8 | |||
9 | # NOTE: this recipe requires poky's qemu.inc which assumes version 2.3 | ||
10 | # where glx enable config option changed to --enable-opengl. For now we | ||
11 | # restore it, but we should remove the following lines when upgrading | ||
12 | # to qemu 2.3: | ||
13 | PACKAGECONFIG[glx] = "--enable-glx,--disable-glx,mesa" | ||
14 | |||
15 | SRC_URI = "git://git.freescale.com/ppc/sdk/qemu.git;branch=master" | ||
16 | SRCREV = "00ac004143e9fe46944a1885b04268fcd3a95a3a" | ||
17 | |||
18 | S = "${WORKDIR}/git" | ||
19 | |||
20 | QEMU_TARGETS = "arm" | ||
21 | |||
22 | inherit pkgconfig | ||
23 | |||
24 | # Append build host pkg-config paths for native target since the host may provide sdl | ||
25 | do_configure_prepend() { | ||
26 | export PKG_CONFIG=${STAGING_DIR_NATIVE}${bindir_native}/pkg-config | ||
27 | } | ||
28 | |||
29 | do_configure_append () { | ||
30 | if ! grep 'CONFIG_FDT=y' config-host.mak; then | ||
31 | echo "CONFIG_RDMA=y" >> config_host_mak | ||
32 | fi | ||
33 | } | ||
34 | |||
35 | # gets around qemu.inc trying to install powerpc_rom.bin | ||
36 | do_install_prepend() { | ||
37 | touch ${WORKDIR}/powerpc_rom.bin | ||
38 | } | ||
39 | |||
40 | do_install_append() { | ||
41 | rm ${WORKDIR}/powerpc_rom.bin | ||
42 | # Prevent QA warnings about installed ${localstatedir}/run | ||
43 | if [ -d ${D}${localstatedir}/run ]; then rmdir ${D}${localstatedir}/run; fi | ||
44 | } | ||
45 | |||
46 | FILES_${PN} += "/usr/share/qemu/" | ||
47 | |||
48 | # FIXME: Avoid WARNING due missing patch for native/nativesdk | ||
49 | BBCLASSEXTEND = "" | ||