summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/qemu/qemu-qoriq
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2016-01-09 14:43:33 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-04-19 15:03:23 -0300
commit695eaac89524a731f55594381497edd035c9139d (patch)
tree1c06cefed499c8254bd10af977ccd42b74db0210 /recipes-devtools/qemu/qemu-qoriq
parent25f3befd73c7a82b0e69503e67c1fa6613c5f798 (diff)
downloadmeta-freescale-695eaac89524a731f55594381497edd035c9139d.tar.gz
qemu_qoriq: import ptest patches from poky
Signed-off-by: Ting Liu <ting.liu@nxp.com> Signed-off-by: Zhenhua Luo <zhenhua.luo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-devtools/qemu/qemu-qoriq')
-rw-r--r--recipes-devtools/qemu/qemu-qoriq/add-ptest-in-makefile.patch29
-rw-r--r--recipes-devtools/qemu/qemu-qoriq/run-ptest8
2 files changed, 37 insertions, 0 deletions
diff --git a/recipes-devtools/qemu/qemu-qoriq/add-ptest-in-makefile.patch b/recipes-devtools/qemu/qemu-qoriq/add-ptest-in-makefile.patch
new file mode 100644
index 00000000..a99f7209
--- /dev/null
+++ b/recipes-devtools/qemu/qemu-qoriq/add-ptest-in-makefile.patch
@@ -0,0 +1,29 @@
1Upstream-Status: Pending
2
3Add subpackage -ptest which runs all unit test cases for qemu.
4
5Signed-off-by: Kai Kang <kai.kang@windriver.com>
6---
7 tests/Makefile | 10 ++++++++++
8 1 file changed, 10 insertions(+)
9
10diff --git a/tests/Makefile b/tests/Makefile
11index 88f7105..3f40b4b 100644
12--- a/tests/Makefile
13+++ b/tests/Makefile
14@@ -405,3 +405,12 @@ all: $(QEMU_IOTESTS_HELPERS-y)
15
16 -include $(wildcard tests/*.d)
17 -include $(wildcard tests/libqos/*.d)
18+
19+buildtest-TESTS: $(check-unit-y)
20+
21+runtest-TESTS:
22+ for f in $(check-unit-y); do \
23+ nf=$$(echo $$f | sed 's/tests\//\.\//g'); \
24+ $$nf; \
25+ done
26+
27--
281.7.9.5
29
diff --git a/recipes-devtools/qemu/qemu-qoriq/run-ptest b/recipes-devtools/qemu/qemu-qoriq/run-ptest
new file mode 100644
index 00000000..f4b8e97e
--- /dev/null
+++ b/recipes-devtools/qemu/qemu-qoriq/run-ptest
@@ -0,0 +1,8 @@
1#!/bin/sh
2#
3#This script is used to run qemu test suites
4ptestdir=$(pwd)
5cd tests
6
7export SRC_PATH=$ptestdir
8make -k runtest-TESTS | sed '/: OK/ s/^/PASS: /g'