diff options
author | André Draszik <andre.draszik@jci.com> | 2019-01-17 14:29:17 +0000 |
---|---|---|
committer | André Draszik <andre.draszik@jci.com> | 2019-01-17 14:29:17 +0000 |
commit | 74df05a7f0fd698cbbe65b9bf925f186891426ca (patch) | |
tree | 169665d86e12f2aa2d6df71a856c1893267972d7 /recipes-daemons/ptpd | |
parent | 9704df97f08cf5895e2f5bcfb33f1a53d10c7704 (diff) | |
download | meta-freescale-74df05a7f0fd698cbbe65b9bf925f186891426ca.tar.gz |
remove True option to getVar calls
getVar() has been defaulting to expanding by default for
a long time (2016), thus remove the True option from
getVar() calls with a regex search and replace.
Search & replace made using the following command:
sed -e 's|\(d\.getVar \?\)( \?\([^,()]*\), \?True)|\1(\2)|g' \
-i $(git grep -E 'getVar ?\( ?([^,()]*), ?True\)' \
| cut -d':' -f1 \
| sort -u)
Signed-off-by: André Draszik <andre.draszik@jci.com>
Diffstat (limited to 'recipes-daemons/ptpd')
-rw-r--r-- | recipes-daemons/ptpd/ptpd-qoriq.bb | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-daemons/ptpd/ptpd-qoriq.bb b/recipes-daemons/ptpd/ptpd-qoriq.bb index cb047fd2..569deed5 100644 --- a/recipes-daemons/ptpd/ptpd-qoriq.bb +++ b/recipes-daemons/ptpd/ptpd-qoriq.bb | |||
@@ -17,7 +17,7 @@ PROVIDES = "ptpd" | |||
17 | inherit autotools pkgconfig systemd | 17 | inherit autotools pkgconfig systemd |
18 | 18 | ||
19 | python() { | 19 | python() { |
20 | pkgs = d.getVar('PACKAGES', True).split() | 20 | pkgs = d.getVar('PACKAGES').split() |
21 | for p in pkgs: | 21 | for p in pkgs: |
22 | if 'ptpd-qoriq' in p: | 22 | if 'ptpd-qoriq' in p: |
23 | d.appendVar("RPROVIDES_%s" % p, p.replace('ptpd-qoriq', 'ptpd')) | 23 | d.appendVar("RPROVIDES_%s" % p, p.replace('ptpd-qoriq', 'ptpd')) |