summaryrefslogtreecommitdiffstats
path: root/recipes-core/udev/udev-rules-qoriq.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-07-23 16:02:25 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-07-28 23:26:59 -0300
commit6a868a671472d454b407a165fc31c5f7dfe783c6 (patch)
tree7bd2ab13a04d14215264cc992501970cacfb20ef /recipes-core/udev/udev-rules-qoriq.bb
parent62e212fe4812a6c726df4ac8e77d4a77e0e54247 (diff)
downloadmeta-freescale-6a868a671472d454b407a165fc31c5f7dfe783c6.tar.gz
Move meta-fsl-ppc content to layer root
This commit is just a rename of all contents of meta-fsl-ppc subdirectory to this layer's root, merging the contents of common files, subsequent changes are based on top of that. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-core/udev/udev-rules-qoriq.bb')
-rw-r--r--recipes-core/udev/udev-rules-qoriq.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-core/udev/udev-rules-qoriq.bb b/recipes-core/udev/udev-rules-qoriq.bb
new file mode 100644
index 00000000..541d88c4
--- /dev/null
+++ b/recipes-core/udev/udev-rules-qoriq.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "udev rules for Freescale QorIQ SOCs"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
4
5SRC_URI = "\
6 file://71-fsl-dpaa-persistent-networking.rules \
7 file://72-fsl-dpaa-persistent-networking.rules \
8"
9RULE ?= "71-fsl-dpaa-persistent-networking.rules"
10RULE_e6500 = "72-fsl-dpaa-persistent-networking.rules"
11RULE_e6500-64b = "72-fsl-dpaa-persistent-networking.rules"
12RULE_t1024 = "72-fsl-dpaa-persistent-networking.rules"
13RULE_t1023 = "72-fsl-dpaa-persistent-networking.rules"
14
15do_install () {
16 install -d ${D}${sysconfdir}/udev/rules.d/
17 install -m 0644 ${WORKDIR}/${RULE} ${D}${sysconfdir}/udev/rules.d/
18
19 # skip mmc rpmb partitions
20 echo "/dev/mmcblk.*rpmb" >>${D}${sysconfdir}/udev/mount.blacklist
21 # skip nbd (network block device)
22 echo "/dev/nbd*" >>${D}${sysconfdir}/udev/mount.blacklist
23}
24