summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity
diff options
context:
space:
mode:
authorAndré Draszik <andre.draszik@jci.com>2019-01-17 14:29:17 +0000
committerAndré Draszik <andre.draszik@jci.com>2019-01-17 14:29:17 +0000
commit74df05a7f0fd698cbbe65b9bf925f186891426ca (patch)
tree169665d86e12f2aa2d6df71a856c1893267972d7 /recipes-connectivity
parent9704df97f08cf5895e2f5bcfb33f1a53d10c7704 (diff)
downloadmeta-freescale-74df05a7f0fd698cbbe65b9bf925f186891426ca.tar.gz
remove True option to getVar calls
getVar() has been defaulting to expanding by default for a long time (2016), thus remove the True option from getVar() calls with a regex search and replace. Search & replace made using the following command: sed -e 's|\(d\.getVar \?\)( \?\([^,()]*\), \?True)|\1(\2)|g' \ -i $(git grep -E 'getVar ?\( ?([^,()]*), ?True\)' \ | cut -d':' -f1 \ | sort -u) Signed-off-by: André Draszik <andre.draszik@jci.com>
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/openssl/openssl-qoriq_1.1.0g.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-connectivity/openssl/openssl-qoriq_1.1.0g.bb b/recipes-connectivity/openssl/openssl-qoriq_1.1.0g.bb
index 7a4897fd..3df7c1a3 100644
--- a/recipes-connectivity/openssl/openssl-qoriq_1.1.0g.bb
+++ b/recipes-connectivity/openssl/openssl-qoriq_1.1.0g.bb
@@ -26,7 +26,7 @@ SRCREV = "c2300d1fdb30a439f555b07f228d3bce498238d5"
26PROVIDES = "openssl" 26PROVIDES = "openssl"
27 27
28python() { 28python() {
29 pkgs = d.getVar('PACKAGES', True).split() 29 pkgs = d.getVar('PACKAGES').split()
30 for p in pkgs: 30 for p in pkgs:
31 if 'openssl-qoriq' in p: 31 if 'openssl-qoriq' in p:
32 d.appendVar("RPROVIDES_%s" % p, p.replace('openssl-qoriq', 'openssl')) 32 d.appendVar("RPROVIDES_%s" % p, p.replace('openssl-qoriq', 'openssl'))