summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2017-07-28 15:44:17 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2017-08-07 11:42:29 -0300
commit1ea51e7d4ada188bcb1209456e0a65769cccd686 (patch)
treefaf7bc6c31aab14e34e2bc76bb7e27ddec090b9e /recipes-connectivity
parent6ff1ffbba08c415e121d1f91217aff131cfad46d (diff)
downloadmeta-freescale-1ea51e7d4ada188bcb1209456e0a65769cccd686.tar.gz
openssl-qoriq : update to v1.0.2l
Signed-off-by: Chunrong Guo <B40290@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/openssl/openssl-qoriq.inc3
-rw-r--r--recipes-connectivity/openssl/openssl-qoriq_1.0.2k.bb116
-rw-r--r--recipes-connectivity/openssl/openssl-qoriq_1.0.2l.bb69
3 files changed, 72 insertions, 116 deletions
diff --git a/recipes-connectivity/openssl/openssl-qoriq.inc b/recipes-connectivity/openssl/openssl-qoriq.inc
index 612ec096..306da3a5 100644
--- a/recipes-connectivity/openssl/openssl-qoriq.inc
+++ b/recipes-connectivity/openssl/openssl-qoriq.inc
@@ -175,6 +175,9 @@ do_compile () {
175 175
176do_compile_ptest () { 176do_compile_ptest () {
177 # build dependencies for test directory too 177 # build dependencies for test directory too
178 rm -rf test/ssltest_old
179 rm -rf test/x509aux
180 rm -rf test/v3ext
178 export DIRS="$DIRS test" 181 export DIRS="$DIRS test"
179 oe_runmake depend 182 oe_runmake depend
180 oe_runmake buildtest 183 oe_runmake buildtest
diff --git a/recipes-connectivity/openssl/openssl-qoriq_1.0.2k.bb b/recipes-connectivity/openssl/openssl-qoriq_1.0.2k.bb
deleted file mode 100644
index c7064977..00000000
--- a/recipes-connectivity/openssl/openssl-qoriq_1.0.2k.bb
+++ /dev/null
@@ -1,116 +0,0 @@
1require openssl-qoriq.inc
2
3DISABLE_STATIC = ""
4# For target side versions of openssl enable support for OCF Linux driver
5# if they are available.
6DEPENDS += "cryptodev-linux"
7
8CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS"
9
10LIC_FILES_CHKSUM = "file://LICENSE;md5=27ffa5d74bb5a337056c14b2ef93fbf6"
11
12export DIRS = "crypto ssl apps engines"
13export OE_LDFLAGS="${LDFLAGS}"
14
15SRC_URI += "file://find.pl;subdir=${BP}/util/ \
16 file://run-ptest \
17 file://openssl-c_rehash.sh \
18 file://configure-targets.patch \
19 file://shared-libs.patch \
20 file://oe-ldflags.patch \
21 file://engines-install-in-libdir-ssl.patch \
22 file://debian1.0.2/block_diginotar.patch \
23 file://debian1.0.2/block_digicert_malaysia.patch \
24 file://debian/ca.patch \
25 file://debian/c_rehash-compat.patch \
26 file://debian/debian-targets.patch \
27 file://debian/man-dir.patch \
28 file://debian/man-section.patch \
29 file://debian/no-rpath.patch \
30 file://debian/no-symbolic.patch \
31 file://debian/pic.patch \
32 file://debian1.0.2/version-script.patch \
33 file://debian1.0.2/soname.patch \
34 file://openssl_fix_for_x32.patch \
35 file://fix-cipher-des-ede3-cfb1.patch \
36 file://openssl-avoid-NULL-pointer-dereference-in-EVP_DigestInit_ex.patch \
37 file://openssl-fix-des.pod-error.patch \
38 file://Makefiles-ptest.patch \
39 file://ptest-deps.patch \
40 file://openssl-1.0.2a-x32-asm.patch \
41 file://ptest_makefile_deps.patch \
42 file://configure-musl-target.patch \
43 file://parallel.patch \
44 file://openssl-util-perlpath.pl-cwd.patch \
45 file://Use-SHA256-not-MD5-as-default-digest.patch \
46 file://0001-Fix-build-with-clang-using-external-assembler.patch \
47 "
48SRC_URI[md5sum] = "f965fc0bf01bf882b31314b61391ae65"
49SRC_URI[sha256sum] = "6b3977c61f2aedf0f96367dcfb5c6e578cf37e7b8d913b4ecb6643c3cb88d8c0"
50
51SRC_URI += " \
52 file://find.pl;subdir=openssl-${PV}/util/ \
53 file://0001-remove-double-initialization-of-cryptodev-engine.patch \
54 file://0002-eng_cryptodev-add-support-for-TLS-algorithms-offload.patch \
55 file://0003-cryptodev-fix-algorithm-registration.patch \
56 file://0004-ECC-Support-header-for-Cryptodev-Engine.patch \
57 file://0005-Initial-support-for-PKC-in-cryptodev-engine.patch \
58 file://0006-Added-hwrng-dev-file-as-source-of-RNG.patch \
59 file://0007-Asynchronous-interface-added-for-PKC-cryptodev-inter.patch \
60 file://0008-Add-RSA-keygen-operation-and-support-gendsa-command-.patch \
61 file://0009-RSA-Keygen-Fix.patch \
62 file://0010-Removed-local-copy-of-curve_t-type.patch \
63 file://0011-Modulus-parameter-is-not-populated-by-dhparams.patch \
64 file://0012-SW-Backoff-mechanism-for-dsa-keygen.patch \
65 file://0013-Fixed-DH-keygen-pair-generator.patch \
66 file://0014-cryptodev-add-support-for-aes-gcm-algorithm-offloadi.patch \
67 file://0015-eng_cryptodev-extend-TLS-offload-with-3des_cbc_hmac_.patch \
68 file://0016-eng_cryptodev-add-support-for-TLSv1.1-record-offload.patch \
69 file://0017-eng_cryptodev-add-support-for-TLSv1.2-record-offload.patch \
70 file://0018-cryptodev-drop-redundant-function.patch \
71 file://0019-cryptodev-do-not-zero-the-buffer-before-use.patch \
72 file://0020-cryptodev-clean-up-code-layout.patch \
73 file://0021-cryptodev-do-not-cache-file-descriptor-in-open.patch \
74 file://0022-cryptodev-put_dev_crypto-should-be-an-int.patch \
75 file://0023-cryptodev-simplify-cryptodev-pkc-support-code.patch \
76 file://0024-cryptodev-clarify-code-remove-assignments-from-condi.patch \
77 file://0025-cryptodev-clean-up-context-state-before-anything-els.patch \
78 file://0026-cryptodev-remove-code-duplication-in-digest-operatio.patch \
79 file://0027-cryptodev-put-all-digest-ioctls-into-a-single-functi.patch \
80 file://0028-cryptodev-fix-debug-print-messages.patch \
81 file://0029-cryptodev-use-CIOCHASH-ioctl-for-digest-operations.patch \
82 file://0030-cryptodev-reduce-duplicated-efforts-for-searching-in.patch \
83 file://0031-cryptodev-remove-not-used-local-variables.patch \
84 file://0032-cryptodev-hide-not-used-variable-behind-ifndef.patch \
85 file://0033-cryptodev-fix-function-declaration-typo.patch \
86 file://0034-cryptodev-fix-incorrect-function-signature.patch \
87 file://0035-cryptodev-fix-warnings-on-excess-elements-in-struct-.patch \
88 file://0036-cryptodev-fix-free-on-error-path.patch \
89 file://0037-cryptodev-fix-return-value-on-error.patch \
90 file://0038-cryptodev-match-types-with-cryptodev.h.patch \
91 file://0039-cryptodev-explicitly-discard-const-qualifier.patch \
92 file://0040-cryptodev-replace-caddr_t-with-void.patch \
93 file://0041-cryptodev-check-for-errors-inside-cryptodev_rsa_mod_.patch \
94 file://0042-cryptodev-check-for-errors-inside-cryptodev_rsa_mod_.patch \
95 file://0043-cryptodev-check-for-errors-inside-cryptodev_dh_compu.patch \
96 file://0044-cryptodev-check-for-errors-inside-cryptodev_dh_compu.patch \
97 file://0045-cryptodev-change-signature-for-conversion-functions.patch \
98 file://0046-cryptodev-add-explicit-cast-for-known-BIGNUM-values.patch \
99 file://0047-cryptodev-treat-all-build-warnings-as-errors.patch \
100 file://0048-fix-maclen-is-used-uninitialized-warning-on-some-com.patch \
101"
102
103PACKAGES =+ "${PN}-engines"
104FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines"
105
106# The crypto_use_bigint patch means that perl's bignum module needs to be
107# installed, but some distributions (for example Fedora 23) don't ship it by
108# default. As the resulting error is very misleading check for bignum before
109# building.
110do_configure_prepend() {
111 if ! perl -Mbigint -e true; then
112 bbfatal "The perl module 'bignum' was not found but this is required to build openssl. Please install this module (often packaged as perl-bignum) and re-run bitbake."
113 fi
114}
115
116COMPATIBLE_MACHINE = "(qoriq)"
diff --git a/recipes-connectivity/openssl/openssl-qoriq_1.0.2l.bb b/recipes-connectivity/openssl/openssl-qoriq_1.0.2l.bb
new file mode 100644
index 00000000..a2346ba1
--- /dev/null
+++ b/recipes-connectivity/openssl/openssl-qoriq_1.0.2l.bb
@@ -0,0 +1,69 @@
1require openssl-qoriq.inc
2
3DISABLE_STATIC = ""
4# For target side versions of openssl enable support for OCF Linux driver
5# if they are available.
6DEPENDS += "cryptodev-linux"
7
8CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS"
9
10LIC_FILES_CHKSUM = "file://LICENSE;md5=057d9218c6180e1d9ee407572b2dd225"
11
12export DIRS = "crypto ssl apps engines"
13export OE_LDFLAGS="${LDFLAGS}"
14
15SRC_URI += "file://find.pl;subdir=${BP}/util \
16 file://run-ptest \
17 file://openssl-c_rehash.sh \
18 file://configure-targets.patch \
19 file://shared-libs.patch \
20 file://oe-ldflags.patch \
21 file://engines-install-in-libdir-ssl.patch \
22 file://debian1.0.2/block_diginotar.patch \
23 file://debian1.0.2/block_digicert_malaysia.patch \
24 file://debian/ca.patch \
25 file://debian/c_rehash-compat.patch \
26 file://debian/debian-targets.patch \
27 file://debian/man-dir.patch \
28 file://debian/man-section.patch \
29 file://debian/no-rpath.patch \
30 file://debian/no-symbolic.patch \
31 file://debian/pic.patch \
32 file://debian1.0.2/version-script.patch \
33 file://debian1.0.2/soname.patch \
34 file://openssl_fix_for_x32.patch \
35 file://openssl-avoid-NULL-pointer-dereference-in-EVP_DigestInit_ex.patch \
36 file://openssl-fix-des.pod-error.patch \
37 file://Makefiles-ptest.patch \
38 file://ptest-deps.patch \
39 file://openssl-1.0.2a-x32-asm.patch \
40 file://ptest_makefile_deps.patch \
41 file://configure-musl-target.patch \
42 file://parallel.patch \
43 file://openssl-util-perlpath.pl-cwd.patch \
44 file://Use-SHA256-not-MD5-as-default-digest.patch \
45 file://0001-Fix-build-with-clang-using-external-assembler.patch \
46 "
47SRC_URI[md5sum] = "f85123cd390e864dfbe517e7616e6566"
48SRC_URI[sha256sum] = "ce07195b659e75f4e1db43552860070061f156a98bb37b672b101ba6e3ddf30c"
49
50SRC_URI += " \
51 file://find.pl;subdir=openssl-${PV}/util/ \
52 file://0001-remove-double-initialization-of-cryptodev-engine.patch \
53 file://0002-eng_cryptodev-add-support-for-TLS-algorithms-offload.patch \
54"
55
56PACKAGES =+ "${PN}-engines"
57FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines"
58
59# The crypto_use_bigint patch means that perl's bignum module needs to be
60# installed, but some distributions (for example Fedora 23) don't ship it by
61# default. As the resulting error is very misleading check for bignum before
62# building.
63do_configure_prepend() {
64 if ! perl -Mbigint -e true; then
65 bbfatal "The perl module 'bignum' was not found but this is required to build openssl. Please install this module (often packaged as perl-bignum) and re-run bitbake."
66 fi
67}
68
69COMPATIBLE_MACHINE = "(qoriq)"