diff options
author | Max Krummenacher <max.krummenacher@toradex.com> | 2021-10-30 17:41:14 +0200 |
---|---|---|
committer | Max Krummenacher <max.krummenacher@toradex.com> | 2021-11-02 19:30:13 +0100 |
commit | b030a791d31b209ac002a8afb50851f98b9b20d3 (patch) | |
tree | 807f675e29096de58261321fb05ed11cc873eb98 /recipes-bsp | |
parent | 2cda103796e567d6ce17874df37f9bcfed13a69f (diff) | |
download | meta-freescale-b030a791d31b209ac002a8afb50851f98b9b20d3.tar.gz |
isp-imx: refresh patch
Refresh patch after version bump.
Fixes commit ec31e767 ("isp-imx: upgrade to 4.2.2.15.0")
| ERROR: isp-imx-4.2.2.15.0-r0 do_patch: Applying patch '0001-isp-imx-drop-use-of-__TIME__-__DATE__.patch' on target directory '.../isp-imx/4.2.2.15.0-r0/isp-imx-4.2.2.15.0'
| CmdError('quilt --quiltrc .../isp-imx/4.2.2.15.0-r0/recipe-sysroot-native/etc/quiltrc push', 0, 'stdout: Applying patch 0001-isp-imx-drop-use-of-__TIME__-__DATE__.patch
| patching file mediacontrol/CMakeLists.txt
| patching file mediacontrol/daemon/main_v4l2.cpp
| Hunk #1 FAILED at 96.
| Hunk #2 FAILED at 105.
| Hunk #3 FAILED at 123.
| 3 out of 3 hunks FAILED -- rejects in file mediacontrol/daemon/main_v4l2.cpp
| Patch 0001-isp-imx-drop-use-of-__TIME__-__DATE__.patch does not apply (enforce with -f)
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/isp-imx/isp-imx/0001-isp-imx-drop-use-of-__TIME__-__DATE__.patch | 30 |
1 files changed, 15 insertions, 15 deletions
diff --git a/recipes-bsp/isp-imx/isp-imx/0001-isp-imx-drop-use-of-__TIME__-__DATE__.patch b/recipes-bsp/isp-imx/isp-imx/0001-isp-imx-drop-use-of-__TIME__-__DATE__.patch index d8d12267..c3ee088f 100644 --- a/recipes-bsp/isp-imx/isp-imx/0001-isp-imx-drop-use-of-__TIME__-__DATE__.patch +++ b/recipes-bsp/isp-imx/isp-imx/0001-isp-imx-drop-use-of-__TIME__-__DATE__.patch | |||
@@ -1,6 +1,6 @@ | |||
1 | From accaeb1ae77eb40b89e70df3efcb00d0dc2af758 Mon Sep 17 00:00:00 2001 | 1 | From ea5ce303fa5bc7b6a17c522b4caf49d349adb12b Mon Sep 17 00:00:00 2001 |
2 | From: Max Krummenacher <max.krummenacher@toradex.com> | 2 | From: Max Krummenacher <max.krummenacher@toradex.com> |
3 | Date: Mon, 14 Jun 2021 08:20:48 +0000 | 3 | Date: Sat, 30 Oct 2021 17:26:42 +0200 |
4 | Subject: [PATCH] isp-imx: drop use of __TIME__, __DATE__ | 4 | Subject: [PATCH] isp-imx: drop use of __TIME__, __DATE__ |
5 | 5 | ||
6 | With reproducible build enabled the compiler is configured to throw | 6 | With reproducible build enabled the compiler is configured to throw |
@@ -21,7 +21,7 @@ Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> | |||
21 | 2 files changed, 7 insertions(+), 4 deletions(-) | 21 | 2 files changed, 7 insertions(+), 4 deletions(-) |
22 | 22 | ||
23 | diff --git a/mediacontrol/CMakeLists.txt b/mediacontrol/CMakeLists.txt | 23 | diff --git a/mediacontrol/CMakeLists.txt b/mediacontrol/CMakeLists.txt |
24 | index 48cd7633e..f587758e0 100755 | 24 | index 5849c163e..8a8e1a4a0 100755 |
25 | --- a/mediacontrol/CMakeLists.txt | 25 | --- a/mediacontrol/CMakeLists.txt |
26 | +++ b/mediacontrol/CMakeLists.txt | 26 | +++ b/mediacontrol/CMakeLists.txt |
27 | @@ -2,6 +2,9 @@ cmake_minimum_required(VERSION 3.1.0) | 27 | @@ -2,6 +2,9 @@ cmake_minimum_required(VERSION 3.1.0) |
@@ -35,38 +35,38 @@ index 48cd7633e..f587758e0 100755 | |||
35 | if(DEFINED PLATFORM) | 35 | if(DEFINED PLATFORM) |
36 | if(${PLATFORM} STREQUAL ARM64) | 36 | if(${PLATFORM} STREQUAL ARM64) |
37 | diff --git a/mediacontrol/daemon/main_v4l2.cpp b/mediacontrol/daemon/main_v4l2.cpp | 37 | diff --git a/mediacontrol/daemon/main_v4l2.cpp b/mediacontrol/daemon/main_v4l2.cpp |
38 | index a3033cf83..d08dee127 100644 | 38 | index d3d1c2423..dd0514358 100644 |
39 | --- a/mediacontrol/daemon/main_v4l2.cpp | 39 | --- a/mediacontrol/daemon/main_v4l2.cpp |
40 | +++ b/mediacontrol/daemon/main_v4l2.cpp | 40 | +++ b/mediacontrol/daemon/main_v4l2.cpp |
41 | @@ -96,7 +96,7 @@ int main(int argc, char* argv[]) { | 41 | @@ -105,7 +105,7 @@ int main(int argc, char* argv[]) { |
42 | if (argc == 2){ | ||
43 | if(!(string2Version.find(argv[1])==string2Version.end())){ | 42 | if(!(string2Version.find(argv[1])==string2Version.end())){ |
44 | std::cout << "Version : "<<MEDIA_SERVER_VERSION<<std::endl; | 43 | std::cout << "Version : "<<MEDIA_SERVER_VERSION<<std::endl; |
44 | #ifndef ANDROID | ||
45 | - std::cout << "Build Time : "<<__DATE__<<", "<<__TIME__<<std::endl; | 45 | - std::cout << "Build Time : "<<__DATE__<<", "<<__TIME__<<std::endl; |
46 | + std::cout << "Build Time : "<<BUILD_DATE<<std::endl; | 46 | + std::cout << "Build Time : "<<BUILD_DATE<<std::endl; |
47 | #endif | ||
47 | return 0; | 48 | return 0; |
48 | } | 49 | } |
49 | } | 50 | @@ -116,8 +116,8 @@ int main(int argc, char* argv[]) { |
50 | @@ -105,8 +105,8 @@ int main(int argc, char* argv[]) { | ||
51 | if(fd_running >= 0) | ||
52 | { | 51 | { |
53 | ALOGI("******************************************************************"); | 52 | ALOGI("******************************************************************"); |
53 | #ifndef ANDROID | ||
54 | - ALOGI("VIV ISP Media Control Framework V%s (%s, %s)", | 54 | - ALOGI("VIV ISP Media Control Framework V%s (%s, %s)", |
55 | - MEDIA_SERVER_VERSION, __DATE__, __TIME__); | 55 | - MEDIA_SERVER_VERSION, __DATE__, __TIME__); |
56 | + ALOGI("VIV ISP Media Control Framework V%s (%s)", | 56 | + ALOGI("VIV ISP Media Control Framework V%s (%s)", |
57 | + MEDIA_SERVER_VERSION, BUILD_DATE); | 57 | + MEDIA_SERVER_VERSION, BUILD_DATE); |
58 | ALOGI("******************************************************************\n"); | 58 | #else |
59 | 59 | ALOGI("VIV ISP Media Control Framework V%s", MEDIA_SERVER_VERSION); | |
60 | if (argc < 2) { | 60 | #endif |
61 | @@ -123,7 +123,7 @@ int main(int argc, char* argv[]) { | 61 | @@ -138,7 +138,7 @@ int main(int argc, char* argv[]) { |
62 | while( i < argc ){ | ||
63 | if(!(string2Version.find(argv[i])==string2Version.end())){ | 62 | if(!(string2Version.find(argv[i])==string2Version.end())){ |
64 | std::cout << "Version : "<<MEDIA_SERVER_VERSION<<std::endl; | 63 | std::cout << "Version : "<<MEDIA_SERVER_VERSION<<std::endl; |
64 | #ifndef ANDROID | ||
65 | - std::cout << "Build Time : "<<__DATE__<<", "<<__TIME__<<std::endl; | 65 | - std::cout << "Build Time : "<<__DATE__<<", "<<__TIME__<<std::endl; |
66 | + std::cout << "Build Time : "<<BUILD_DATE<<std::endl; | 66 | + std::cout << "Build Time : "<<BUILD_DATE<<std::endl; |
67 | #endif | ||
67 | i++; | 68 | i++; |
68 | continue; | 69 | continue; |
69 | } | ||
70 | -- | 70 | -- |
71 | 2.20.1 | 71 | 2.20.1 |
72 | 72 | ||