diff options
author | Max Krummenacher <max.krummenacher@toradex.com> | 2021-11-01 14:20:02 +0100 |
---|---|---|
committer | Max Krummenacher <max.krummenacher@toradex.com> | 2021-11-02 19:30:14 +0100 |
commit | 454602452d7a3fe8b25bfccc038c32dd22380406 (patch) | |
tree | 858c6470ab5e60d2aeac9684e6352927245393dd /recipes-bsp | |
parent | 88511f48fc14f90cc70e504e3a09e32722c62c11 (diff) | |
download | meta-freescale-454602452d7a3fe8b25bfccc038c32dd22380406.tar.gz |
isp-imx: provide an libtinyxml2 8.0.0 recipe
isp-imx has precompiled binaries linked against that libtinyxml2 version.
Remove files which are also provided by the 'current' recipe version
of libtinyxml so that they don't clash during image/SDK creation.
Since the isp-imx does do a link step against libtinyxml2 create the
the unversioned symlink libtinyxml2.so in do_compile.
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/isp-imx/isp-imx_4.2.2.15.0.bb | 6 | ||||
-rw-r--r-- | recipes-bsp/isp-imx/libtinyxml2-8_8.0.0.bb | 22 |
2 files changed, 27 insertions, 1 deletions
diff --git a/recipes-bsp/isp-imx/isp-imx_4.2.2.15.0.bb b/recipes-bsp/isp-imx/isp-imx_4.2.2.15.0.bb index 89b0abd2..379536fd 100644 --- a/recipes-bsp/isp-imx/isp-imx_4.2.2.15.0.bb +++ b/recipes-bsp/isp-imx/isp-imx_4.2.2.15.0.bb | |||
@@ -3,7 +3,7 @@ | |||
3 | DESCRIPTION = "i.MX Verisilicon Software ISP" | 3 | DESCRIPTION = "i.MX Verisilicon Software ISP" |
4 | LICENSE = "Proprietary" | 4 | LICENSE = "Proprietary" |
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=e565271ec9a80ce47abbddc4bffe56fa" | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=e565271ec9a80ce47abbddc4bffe56fa" |
6 | DEPENDS = "python3 libdrm virtual/libg2d libtinyxml2" | 6 | DEPENDS = "python3 libdrm virtual/libg2d libtinyxml2-8" |
7 | 7 | ||
8 | SRC_URI = " \ | 8 | SRC_URI = " \ |
9 | ${FSL_MIRROR}/${BP}.bin;fsl-eula=true \ | 9 | ${FSL_MIRROR}/${BP}.bin;fsl-eula=true \ |
@@ -47,6 +47,10 @@ do_configure:prepend() { | |||
47 | export SDKTARGETSYSROOT=${STAGING_DIR_HOST} | 47 | export SDKTARGETSYSROOT=${STAGING_DIR_HOST} |
48 | } | 48 | } |
49 | 49 | ||
50 | do_compile:prepend() { | ||
51 | ln -sf ${RECIPE_SYSROOT}/${libdir}/libtinyxml2.so.?.?.? ${RECIPE_SYSROOT}/${libdir}/libtinyxml2.so | ||
52 | } | ||
53 | |||
50 | do_install() { | 54 | do_install() { |
51 | install -d ${D}/${libdir} | 55 | install -d ${D}/${libdir} |
52 | install -d ${D}/${includedir} | 56 | install -d ${D}/${includedir} |
diff --git a/recipes-bsp/isp-imx/libtinyxml2-8_8.0.0.bb b/recipes-bsp/isp-imx/libtinyxml2-8_8.0.0.bb new file mode 100644 index 00000000..363f7305 --- /dev/null +++ b/recipes-bsp/isp-imx/libtinyxml2-8_8.0.0.bb | |||
@@ -0,0 +1,22 @@ | |||
1 | SUMMARY = "TinyXML-2 is a simple, small, efficient, C++ XML parser that can be easily integrating into other programs" | ||
2 | HOMEPAGE = "http://www.grinninglizard.com/tinyxml2/" | ||
3 | SECTION = "libs" | ||
4 | LICENSE = "Zlib" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=135624eef03e1f1101b9ba9ac9b5fffd" | ||
6 | |||
7 | SRC_URI = "git://github.com/leethomason/tinyxml2.git" | ||
8 | |||
9 | SRCREV = "bf15233ad88390461f6ab0dbcf046cce643c5fcb" | ||
10 | |||
11 | S = "${WORKDIR}/git" | ||
12 | |||
13 | inherit cmake | ||
14 | |||
15 | # make sure we don't provide files which are also present in the | ||
16 | # current libtinyxml2 version's -dev package. | ||
17 | do_install:append() { | ||
18 | rm -rf ${D}/${includedir} | ||
19 | rm -rf ${D}/${libdir}/cmake | ||
20 | rm -rf ${D}/${libdir}/libtinyxml2.so | ||
21 | rm -rf ${D}/${libdir}/pkgconfig | ||
22 | } | ||