diff options
author | Andrey Zhizhikin <andrey.z@gmail.com> | 2021-12-03 09:54:30 +0000 |
---|---|---|
committer | Andrey Zhizhikin <andrey.z@gmail.com> | 2021-12-03 10:05:51 +0000 |
commit | ad889575ae02de982a47f642db9c9fbfc17c1873 (patch) | |
tree | 2462189b4a6766ef68f9e5a51c15cfbf5e5bd47c /recipes-bsp | |
parent | d70adb5df845c1adb35335a3fabebf54fcee43a0 (diff) | |
download | meta-freescale-ad889575ae02de982a47f642db9c9fbfc17c1873.tar.gz |
imx_atf: unexport variables instead of set in compile task
CFLAGS, LDFLAGS, AS and LD variables are defined in TF-A Makefile and
are dependent on the target build.
Unexport those flags from build so they can be picked up by TF-A in a
form it is defined in Makefile and not provided by OE build.
Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
Cc: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/imx-atf/imx-atf_2.4.bb | 9 |
1 files changed, 6 insertions, 3 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf_2.4.bb b/recipes-bsp/imx-atf/imx-atf_2.4.bb index 8360bfa8..965e0948 100644 --- a/recipes-bsp/imx-atf/imx-atf_2.4.bb +++ b/recipes-bsp/imx-atf/imx-atf_2.4.bb | |||
@@ -25,13 +25,16 @@ EXTRA_OEMAKE += " \ | |||
25 | PLAT=${ATF_PLATFORM} \ | 25 | PLAT=${ATF_PLATFORM} \ |
26 | " | 26 | " |
27 | 27 | ||
28 | BUILD_OPTEE = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'true', 'false', d)}" | 28 | # Let the Makefile handle setting up the CFLAGS and LDFLAGS as it is a standalone application |
29 | CFLAGS[unexport] = "1" | ||
30 | LDFLAGS[unexport] = "1" | ||
31 | AS[unexport] = "1" | ||
32 | LD[unexport] = "1" | ||
29 | 33 | ||
30 | CFLAGS:remove:mx8mq = "-O2" | 34 | BUILD_OPTEE = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'true', 'false', d)}" |
31 | 35 | ||
32 | do_compile() { | 36 | do_compile() { |
33 | # Clear LDFLAGS to avoid the option -Wl recognize issue | 37 | # Clear LDFLAGS to avoid the option -Wl recognize issue |
34 | unset LDFLAGS | ||
35 | oe_runmake bl31 | 38 | oe_runmake bl31 |
36 | if ${BUILD_OPTEE}; then | 39 | if ${BUILD_OPTEE}; then |
37 | oe_runmake clean BUILD_BASE=build-optee | 40 | oe_runmake clean BUILD_BASE=build-optee |