diff options
author | Zhenhua Luo <zhenhua.luo@nxp.com> | 2016-12-20 20:18:56 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2017-01-11 10:53:43 -0200 |
commit | 5841c4bc87a3d1bc1e5c9e500645c2da59cde5b7 (patch) | |
tree | 51eb4ea69b7669e82d2580a9fbe10944be81a938 /recipes-bsp | |
parent | c20ddce9af829f632ef4b31bbd9e3f7d1f2d87b0 (diff) | |
download | meta-freescale-5841c4bc87a3d1bc1e5c9e500645c2da59cde5b7.tar.gz |
ppa: migrate to generic ppa tree
* migrate to the generic git tree of ppc
* support ls1046a targets
Signed-off-by: Ting Liu <ting.liu@nxp.com>
Signed-off-by: Zhenhua Luo <zhenhua.luo@nxp.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/ppa/ppa_git.bb | 31 |
1 files changed, 15 insertions, 16 deletions
diff --git a/recipes-bsp/ppa/ppa_git.bb b/recipes-bsp/ppa/ppa_git.bb index 23327627..1e5084e6 100644 --- a/recipes-bsp/ppa/ppa_git.bb +++ b/recipes-bsp/ppa/ppa_git.bb | |||
@@ -1,43 +1,41 @@ | |||
1 | SUMMARY = "Primary Protected Application" | 1 | SUMMARY = "Primary Protected Application" |
2 | LICENSE = "Freescale-EULA" | 2 | LICENSE = "Freescale-EULA" |
3 | LIC_FILES_CHKSUM = "file://EULA;md5=c9ae442cf1f9dd6c13dfad64b0ffe73f" | 3 | LIC_FILES_CHKSUM = "file://ppa/EULA.txt;md5=60037ccba533a5995e8d1a838d85799c" |
4 | 4 | ||
5 | DEPENDS += "u-boot-mkimage-native" | 5 | DEPENDS += "u-boot-mkimage-native" |
6 | 6 | ||
7 | inherit deploy | 7 | inherit deploy |
8 | 8 | ||
9 | SRC_URI = "git://git.freescale.com/ppc/sdk/ls1043-ppa.git;branch=sdk-v2.0.x \ | 9 | SRC_URI = "git://git.freescale.com/ppc/sdk/ppa-generic.git;branch=sdk-v2.0.x" |
10 | file://ppa.its \ | 10 | SRCREV = "cb683b7cab76f2d685f54393d3b51dd1d02dac9d" |
11 | " | ||
12 | SRCREV = "ffda4e6c2cfb535636ac8d667b0d2351d557cc66" | ||
13 | 11 | ||
14 | S = "${WORKDIR}/git" | 12 | S = "${WORKDIR}/git" |
15 | 13 | ||
16 | EXTRA_OEMAKE = "CC64="${CC}" LD64="${LD}" OBJ64="${OBJCOPY}"" | 14 | EXTRA_OEMAKE = "CC64="${CC}" LD64="${LD}" OBJ64="${OBJCOPY}"" |
17 | 15 | ||
16 | PPA_PATH ?= "ppa/soc-ls1043/platform-rdb" | ||
17 | PPA_PATH_ls1046a = "ppa/soc-ls1046/platform-rdb" | ||
18 | PPA_NAME ?= "ppa-${MACHINE}-${DATETIME}" | 18 | PPA_NAME ?= "ppa-${MACHINE}-${DATETIME}" |
19 | PPA_NAME[vardepsexclude] = "DATETIME" | 19 | PPA_NAME[vardepsexclude] = "DATETIME" |
20 | 20 | ||
21 | do_compile() { | 21 | do_compile() { |
22 | if [ ! -e ${S}/ppa.its ]; then | ||
23 | cp ${WORKDIR}/ppa.its ${S} | ||
24 | fi | ||
25 | export ARMV8_TOOLS_DIR="${STAGING_BINDIR_TOOLCHAIN}" | 22 | export ARMV8_TOOLS_DIR="${STAGING_BINDIR_TOOLCHAIN}" |
26 | export ARMV8_TOOLS_PREFIX="${TARGET_PREFIX}" | 23 | export ARMV8_TOOLS_PREFIX="${TARGET_PREFIX}" |
27 | export FILE_NAMES_DIR="${S}/obj" | 24 | export CROSS_COMPILE="${WRAP_TARGET_PREFIX}" |
28 | oe_runmake all | 25 | cd ${S}/${PPA_PATH} |
29 | uboot-mkimage -f ppa.its ppa.itb | 26 | oe_runmake rdb-fit |
27 | cd ${S} | ||
30 | } | 28 | } |
31 | 29 | ||
32 | do_install() { | 30 | do_install() { |
33 | install -d ${D}/boot/ | 31 | install -d ${D}/boot/ |
34 | install ${S}/ppa.itb ${D}/boot/${PPA_NAME}.itb | 32 | install ${S}/${PPA_PATH}/build/obj/ppa.itb ${D}/boot/${PPA_NAME}.itb |
35 | ln -sfT ${PPA_NAME}.itb ${D}/boot/ppa.itb | 33 | ln -sfT ${PPA_NAME}.itb ${D}/boot/ppa.itb |
36 | } | 34 | } |
37 | 35 | ||
38 | do_deploy(){ | 36 | do_deploy(){ |
39 | install -d ${DEPLOYDIR} | 37 | install -d ${DEPLOYDIR} |
40 | install ${S}/ppa.itb ${DEPLOYDIR}/${PPA_NAME}.itb | 38 | install ${S}/${PPA_PATH}/build/obj/ppa.itb ${DEPLOYDIR}/${PPA_NAME}.itb |
41 | ln -sfT ${PPA_NAME}.itb ${DEPLOYDIR}/ppa.itb | 39 | ln -sfT ${PPA_NAME}.itb ${DEPLOYDIR}/ppa.itb |
42 | } | 40 | } |
43 | addtask deploy before do_build after do_install | 41 | addtask deploy before do_build after do_install |
@@ -45,6 +43,7 @@ addtask deploy before do_build after do_install | |||
45 | PACKAGES += "${PN}-image" | 43 | PACKAGES += "${PN}-image" |
46 | FILES_${PN}-image += "/boot" | 44 | FILES_${PN}-image += "/boot" |
47 | 45 | ||
48 | COMPATIBLE_MACHINE = "(ls1043ardb)" | 46 | CLEANBROKEN = "1" |
47 | PARALLEL_MAKE = "" | ||
48 | COMPATIBLE_MACHINE = "(ls1043a|ls1046a)" | ||
49 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 49 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
50 | |||