diff options
author | Alexandru Palalau <ioan-alexandru.palalau@nxp.com> | 2019-05-23 14:44:24 +0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2019-06-13 14:06:41 -0300 |
commit | f06d0e3c62f879c66292cde0fcd3f1de7ecca149 (patch) | |
tree | 94e67b3bd4777b152da9014696a0786c63eb26d0 /recipes-bsp | |
parent | 760897e9a0fc9d5a262d2f601396c82bd6cd70b1 (diff) | |
download | meta-freescale-f06d0e3c62f879c66292cde0fcd3f1de7ecca149.tar.gz |
imx-test: Switch to branch imx_4.14.98_2.0.0_ga
Signed-off-by: Alexandru Palalau <ioan-alexandru.palalau@nxp.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/imx-test/imx-test/0001-test-Makefile-Add-include-path-to-CC-command.patch | 27 | ||||
-rw-r--r-- | recipes-bsp/imx-test/imx-test_git.bb | 26 |
2 files changed, 11 insertions, 42 deletions
diff --git a/recipes-bsp/imx-test/imx-test/0001-test-Makefile-Add-include-path-to-CC-command.patch b/recipes-bsp/imx-test/imx-test/0001-test-Makefile-Add-include-path-to-CC-command.patch deleted file mode 100644 index 8387a17c..00000000 --- a/recipes-bsp/imx-test/imx-test/0001-test-Makefile-Add-include-path-to-CC-command.patch +++ /dev/null | |||
@@ -1,27 +0,0 @@ | |||
1 | From d289d905c64882c58e3b99f74f68e72f9100115e Mon Sep 17 00:00:00 2001 | ||
2 | From: Fabio Berton <fabio.berton@ossystems.com.br> | ||
3 | Date: Tue, 12 Jun 2018 14:58:40 -0300 | ||
4 | Subject: [PATCH] test/Makefile: Add include path to CC command | ||
5 | Organization: O.S. Systems Software LTDA. | ||
6 | |||
7 | Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> | ||
8 | --- | ||
9 | test/Makefile | 2 +- | ||
10 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
11 | |||
12 | diff --git a/test/Makefile b/test/Makefile | ||
13 | index f1cfa2a..4f14d2c 100644 | ||
14 | --- a/test/Makefile | ||
15 | +++ b/test/Makefile | ||
16 | @@ -12,7 +12,7 @@ ALL_OBJS := | ||
17 | |||
18 | %.o: %.c | ||
19 | @echo " CC $@" | ||
20 | - $(Q)$(CC) -c $(CFLAGS) $< -o $@ | ||
21 | + $(Q)$(CC) -c $(CFLAGS) $(INC) $< -o $@ | ||
22 | |||
23 | |||
24 | # This creates the build and copy rules for one executable. Because we | ||
25 | -- | ||
26 | 2.17.1 | ||
27 | |||
diff --git a/recipes-bsp/imx-test/imx-test_git.bb b/recipes-bsp/imx-test/imx-test_git.bb index bf55f7df..084a2b04 100644 --- a/recipes-bsp/imx-test/imx-test_git.bb +++ b/recipes-bsp/imx-test/imx-test_git.bb | |||
@@ -1,6 +1,6 @@ | |||
1 | # Copyright (C) 2012-2018 O.S. Systems Software LTDA. | 1 | # Copyright (C) 2012-2016 O.S. Systems Software LTDA. |
2 | # Copyright (C) 2013-2016 Freescale Semiconductor | 2 | # Copyright (C) 2013-2016 Freescale Semiconductor |
3 | # Copyright 2017-2018 NXP | 3 | # Copyright (C) 2017-2019 NXP |
4 | 4 | ||
5 | SUMMARY = "Test programs for i.MX BSP" | 5 | SUMMARY = "Test programs for i.MX BSP" |
6 | DESCRIPTION = "Unit tests for the i.MX BSP" | 6 | DESCRIPTION = "Unit tests for the i.MX BSP" |
@@ -16,13 +16,12 @@ DEPENDS_append_imxvpu = " virtual/imxvpu" | |||
16 | PE = "1" | 16 | PE = "1" |
17 | PV = "7.0+${SRCPV}" | 17 | PV = "7.0+${SRCPV}" |
18 | 18 | ||
19 | SRCBRANCH = "imx_4.9.123_imx8mm_ga" | 19 | SRCBRANCH = "imx_4.14.98_2.0.0_ga" |
20 | SRC_URI = " \ | 20 | SRC_URI = " \ |
21 | git://source.codeaurora.org/external/imx/imx-test.git;protocol=https;branch=${SRCBRANCH} \ | 21 | git://source.codeaurora.org/external/imx/imx-test.git;protocol=https;branch=${SRCBRANCH} \ |
22 | file://0001-test-Makefile-Add-include-path-to-CC-command.patch \ | ||
23 | file://memtool_profile \ | 22 | file://memtool_profile \ |
24 | " | 23 | " |
25 | SRCREV = "2cc785f94e5ee8782083d941e6aef24952cc2a38" | 24 | SRCREV = "d32727a9d7ef2543729c149a713db24b8f5c2aa8" |
26 | S = "${WORKDIR}/git" | 25 | S = "${WORKDIR}/git" |
27 | 26 | ||
28 | inherit module-base use-imx-headers | 27 | inherit module-base use-imx-headers |
@@ -30,15 +29,15 @@ inherit module-base use-imx-headers | |||
30 | INHIBIT_PACKAGE_STRIP = "1" | 29 | INHIBIT_PACKAGE_STRIP = "1" |
31 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | 30 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" |
32 | 31 | ||
33 | PLATFORM_mx6q = "IMX6Q" | 32 | PLATFORM_mx6q = "IMX6Q" |
34 | PLATFORM_mx6dl = "IMX6Q" | 33 | PLATFORM_mx6dl = "IMX6Q" |
35 | PLATFORM_mx6sl = "IMX6SL" | 34 | PLATFORM_mx6sl = "IMX6SL" |
36 | PLATFORM_mx6sll = "IMX6SL" | 35 | PLATFORM_mx6sll = "IMX6SL" |
37 | PLATFORM_mx6sx = "IMX6SX" | 36 | PLATFORM_mx6sx = "IMX6SX" |
38 | PLATFORM_mx6ul = "IMX6UL" | 37 | PLATFORM_mx6ul = "IMX6UL" |
39 | PLATFORM_mx7d = "IMX7D" | 38 | PLATFORM_mx7d = "IMX7D" |
40 | PLATFORM_mx7ulp = "IMX7D" | 39 | PLATFORM_mx7ulp = "IMX7D" |
41 | PLATFORM_mx8 = "IMX8" | 40 | PLATFORM_mx8 = "IMX8" |
42 | 41 | ||
43 | PARALLEL_MAKE = "-j 1" | 42 | PARALLEL_MAKE = "-j 1" |
44 | EXTRA_OEMAKE += "${PACKAGECONFIG_CONFARGS}" | 43 | EXTRA_OEMAKE += "${PACKAGECONFIG_CONFARGS}" |
@@ -49,9 +48,6 @@ PACKAGECONFIG_append_imxvpu = " vpu" | |||
49 | PACKAGECONFIG[x11] = ",,libx11 libxdamage libxrender libxrandr" | 48 | PACKAGECONFIG[x11] = ",,libx11 libxdamage libxrender libxrandr" |
50 | PACKAGECONFIG[vpu] = "HAS_VPU=true,HAS_VPU=false,virtual/imxvpu" | 49 | PACKAGECONFIG[vpu] = "HAS_VPU=true,HAS_VPU=false,virtual/imxvpu" |
51 | 50 | ||
52 | # FIXME: NXP should fix the possible string flaws from their code. | ||
53 | SECURITY_STRINGFORMAT = "" | ||
54 | |||
55 | do_compile() { | 51 | do_compile() { |
56 | CFLAGS="${TOOLCHAIN_OPTIONS}" | 52 | CFLAGS="${TOOLCHAIN_OPTIONS}" |
57 | oe_runmake V=1 VERBOSE='' \ | 53 | oe_runmake V=1 VERBOSE='' \ |