diff options
author | Trevor Woerner <twoerner@gmail.com> | 2020-02-12 18:57:46 -0500 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2020-02-12 23:50:58 -0300 |
commit | 8e887cfcd810631680f5618b33eb0916cf995551 (patch) | |
tree | 82d77ef36658b177b589f45e4e393165136fd9ee /recipes-bsp | |
parent | 7d3792f2e76ac4d0d4efad19729e09b284e8421d (diff) | |
download | meta-freescale-8e887cfcd810631680f5618b33eb0916cf995551.tar.gz |
u-boot-fslc-mxsboot-native: B!=S fix
MACHINEs such as the imx23evk and imx28evk (i.e. the mxs MACHINEs)
failed to build because the recipe for u-boot-fslc-mxsboot-native wasn't
instrumented to support ${B} != ${S}, which is used as a result of inheriting
u-boot-fslc-common. In other words, the inherit was setting up ${B} != ${S},
but then u-boot-fslc-mxsboot didn't know what to do in this scenario.
Signed-off-by: Trevor Woerner <twoerner@gmail.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/u-boot/u-boot-fslc-mxsboot_2019.07.bb | 4 |
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2019.07.bb b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2019.07.bb index 9123b331..2492f450 100644 --- a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2019.07.bb +++ b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2019.07.bb | |||
@@ -12,14 +12,14 @@ EXTRA_OEMAKE_class-native = 'CC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" H | |||
12 | EXTRA_OEMAKE_class-nativesdk = 'CROSS_COMPILE="${HOST_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1 CONFIG_MX28=y' | 12 | EXTRA_OEMAKE_class-nativesdk = 'CROSS_COMPILE="${HOST_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1 CONFIG_MX28=y' |
13 | 13 | ||
14 | do_compile () { | 14 | do_compile () { |
15 | oe_runmake sandbox_defconfig | 15 | oe_runmake -C ${S} O=${B} sandbox_defconfig |
16 | 16 | ||
17 | # Disable CONFIG_CMD_LICENSE, license.h is not used by tools and | 17 | # Disable CONFIG_CMD_LICENSE, license.h is not used by tools and |
18 | # generating it requires bin2header tool, which for target build | 18 | # generating it requires bin2header tool, which for target build |
19 | # is built with target tools and thus cannot be executed on host. | 19 | # is built with target tools and thus cannot be executed on host. |
20 | sed -i "s/CONFIG_CMD_LICENSE=.*/# CONFIG_CMD_LICENSE is not set/" .config | 20 | sed -i "s/CONFIG_CMD_LICENSE=.*/# CONFIG_CMD_LICENSE is not set/" .config |
21 | 21 | ||
22 | oe_runmake cross_tools NO_SDL=1 | 22 | oe_runmake -C ${S} O=${B} cross_tools NO_SDL=1 |
23 | } | 23 | } |
24 | 24 | ||
25 | do_install () { | 25 | do_install () { |