diff options
author | Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com> | 2020-08-18 20:37:12 +0000 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2020-08-26 19:29:28 -0300 |
commit | cc9b020bcb5ece255d4c09f3cefd12b1e511d7fd (patch) | |
tree | 034ad01dfe7c08bcda0510f20d85ef5aa2a78d66 /recipes-bsp | |
parent | f71c88541277413bbcf9c5b13990d39a82fdd19f (diff) | |
download | meta-freescale-cc9b020bcb5ece255d4c09f3cefd12b1e511d7fd.tar.gz |
imx-vpu-hantro: upgrade to 1.18.0
This version uses updated EULA and limits compatibility to mx8mq, mx8mm
and and mx8mp machines (mx8mn does not have video accelerator IP block).
Following commits are added in this release (including command):
$ git log --oneline --no-decorate 904a9ab..ee99dc1
ee99dc1 NVJM850-82 - [RV8] RV8 video can't be decoded
b2aa5a0 M865SW-147: [G1/G2]: enhancement for h264 error handing
cfffc5f MMIOT-418: Allow to configure CFG_SECURE_DATA_PATH on Linux
0a741cc NVJM850-81 - [G2]:hevc error handling
2f3f4fa M865SW-132: [G1G2]: HEVC decoder illegal memory access in
security mode
8182f16 MA-14108-1 Remove ION_FLAG_CACHED flag for hantro vpu buffer
65d5f3a MMFMWK-8595 Enable VC8000E encoder for 865
b434f22 M865SW-87:[G1/G2]: Integrate some code for VSI platform
4dc2d6f M865SW-82 - [G1/G2]: H264 conformance test failure caused by
change in 1.0.6 release
dd606d2 [G1/G2]: Integrate VSI 1.0.7_20191212 release
d62fd74 [G1/G2]: Coverity issues fix
6460a5f [G1/G2]: Refine Test Makefile
7805f7f [G1/G2]: Coverity issues fix
eca7409 [G1/G2]: Coverity issues fix
a210f04 [G1/G2]: Coverity issues fix
dd0e5f4 [G1/G2]: Coverity issues fix
c12e5a8 [G1/G2]: Coverity issues fix
7631926 [G1/G2]: Coverity issues fix
Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
Cc: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.18.0.bb (renamed from recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.16.0.bb) | 11 |
1 files changed, 6 insertions, 5 deletions
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.16.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.18.0.bb index 67dbc8da..93206263 100644 --- a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.16.0.bb +++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.18.0.bb | |||
@@ -1,16 +1,16 @@ | |||
1 | # Copyright 2017-2018 NXP | 1 | # Copyright (C) 2017-2020 NXP |
2 | 2 | ||
3 | DESCRIPTION = "i.MX Hantro VPU library" | 3 | DESCRIPTION = "i.MX Hantro VPU library" |
4 | LICENSE = "Proprietary" | 4 | LICENSE = "Proprietary" |
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=fd4b227530cd88a82af6a5982cfb724d" | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=228c72f2a91452b8a03c4cab30f30ef9" |
6 | 6 | ||
7 | PROVIDES = "virtual/imxvpu" | 7 | PROVIDES = "virtual/imxvpu" |
8 | 8 | ||
9 | SRC_URI = " \ | 9 | SRC_URI = " \ |
10 | ${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true \ | 10 | ${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true \ |
11 | " | 11 | " |
12 | SRC_URI[md5sum] = "79ca586c67ea9b007fa772df8959c852" | 12 | SRC_URI[md5sum] = "78034de7ed74363eb793d29894bba5e3" |
13 | SRC_URI[sha256sum] = "1f373f5d9a37754f7936f9bf4b134b65afe98459c0383b63c50c1f6ecba49e25" | 13 | SRC_URI[sha256sum] = "bebd82649d00d6dd8236b77b8677b1cc6ac46dc474200502df7797a75dc8f568" |
14 | 14 | ||
15 | inherit fsl-eula-unpack use-imx-headers | 15 | inherit fsl-eula-unpack use-imx-headers |
16 | 16 | ||
@@ -18,6 +18,7 @@ PARALLEL_MAKE="-j 1" | |||
18 | 18 | ||
19 | PLATFORM_mx8mm = "IMX8MM" | 19 | PLATFORM_mx8mm = "IMX8MM" |
20 | PLATFORM_mx8mq = "IMX8MQ" | 20 | PLATFORM_mx8mq = "IMX8MQ" |
21 | PLATFORM_mx8mp = "IMX8MP" | ||
21 | 22 | ||
22 | do_compile () { | 23 | do_compile () { |
23 | oe_runmake CROSS_COMPILE="${HOST_PREFIX}" \ | 24 | oe_runmake CROSS_COMPILE="${HOST_PREFIX}" \ |
@@ -31,4 +32,4 @@ do_install () { | |||
31 | 32 | ||
32 | FILES_${PN} += "/unit_tests" | 33 | FILES_${PN} += "/unit_tests" |
33 | 34 | ||
34 | COMPATIBLE_MACHINE = "(mx8m)" | 35 | COMPATIBLE_MACHINE = "(mx8mq|mx8mm|mx8mp)" |