diff options
author | Chunrong Guo <chunrong.guo@nxp.com> | 2019-10-14 17:13:03 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2019-10-21 09:07:06 -0300 |
commit | a1581156eb292b8939638878f23e5c49e3f903f8 (patch) | |
tree | ba40b078ef7ba47e30934b60b50e927d753cecfb /recipes-bsp | |
parent | 59266228ebc19fd58b58dd2dbf3844e158ee98dd (diff) | |
download | meta-freescale-a1581156eb292b8939638878f23e5c49e3f903f8.tar.gz |
atf: update to 85e98b9
*update to lsdk 1909 tag
include the following changes:
85e98b9 - nxp: errata: Enable workaround for Erratum A010539 with POLICY_OTA
8882a80 - ddr: phy: phy-gen2: optmial PHY settings
07d897c - plat: nxp: Add OTA support for Secure Boot
9fde61d - nand: fix for bad block management while nand read
c4cbfcd - plat: nxp: ls1028a: Fix RDB reset issue durwing lpm20 exit
3502a08 - plat/nxp/nand: Add missing ONFI Device flag
7497445 - plat: nxp: ls1012afrwy_512mb: Add NXP_SD_BLOCK_BUF_SIZE definition
7f9026a - plat: nxp: ota: show OTA status clearly
ccc6620 - LPM-20 support on ls1028ardb.
fb76032 - moved the PMU Core & cluster mask from lsch3.h
15f9e0e - plat: nxp: Add OTA support with POLICY_OTA option
51c6363 - nxp: drivers: wdt: Add SP805 Watchdog support
3776f41 - nxp: drivers: wdt: Add Watchdog support
761ece9 - plat: nxp: soc-ls1012: Add NXP_SD_BLOCK_BUF_SIZE definition
e77ebd1 - nxp/sd: Add write support for eSDHC
7132834 - plat/lx2: Add support for correct CCN configuration for LX2120
411ed2b - plat/lx2: Correct RNF node to cluster mapping
*Add OTA support
Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/atf/atf_git.bb | 23 |
1 files changed, 18 insertions, 5 deletions
diff --git a/recipes-bsp/atf/atf_git.bb b/recipes-bsp/atf/atf_git.bb index 58b1d8f7..d75e3eb2 100644 --- a/recipes-bsp/atf/atf_git.bb +++ b/recipes-bsp/atf/atf_git.bb | |||
@@ -12,7 +12,7 @@ do_compile[depends] += "u-boot:do_deploy rcw:do_deploy uefi:do_deploy" | |||
12 | S = "${WORKDIR}/git" | 12 | S = "${WORKDIR}/git" |
13 | 13 | ||
14 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/atf;nobranch=1" | 14 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/atf;nobranch=1" |
15 | SRCREV = "17f94e4315e81e3d1b22d863d9614d724e8273dc" | 15 | SRCREV = "85e98b945172118c55f0cea9c1f655b4307e6fab" |
16 | 16 | ||
17 | SRC_URI += "file://0001-fix-fiptool-build-error.patch \ | 17 | SRC_URI += "file://0001-fix-fiptool-build-error.patch \ |
18 | file://0001-Makefile-add-CC-gcc.patch \ | 18 | file://0001-Makefile-add-CC-gcc.patch \ |
@@ -33,9 +33,11 @@ LD[unexport] = "1" | |||
33 | EXTRA_OEMAKE += "HOSTCC='${BUILD_CC} ${BUILD_CPPFLAGS} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}'" | 33 | EXTRA_OEMAKE += "HOSTCC='${BUILD_CC} ${BUILD_CPPFLAGS} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}'" |
34 | 34 | ||
35 | BOOTTYPE ?= "nor nand qspi flexspi_nor sd emmc" | 35 | BOOTTYPE ?= "nor nand qspi flexspi_nor sd emmc" |
36 | OTABOOTTYPE ?= "nor qspi flexspi_nor" | ||
36 | BUILD_SECURE = "${@bb.utils.contains('DISTRO_FEATURES', 'secure', 'true', 'false', d)}" | 37 | BUILD_SECURE = "${@bb.utils.contains('DISTRO_FEATURES', 'secure', 'true', 'false', d)}" |
37 | BUILD_OPTEE = "${@bb.utils.contains('COMBINED_FEATURES', 'optee', 'true', 'false', d)}" | 38 | BUILD_OPTEE = "${@bb.utils.contains('COMBINED_FEATURES', 'optee', 'true', 'false', d)}" |
38 | BUILD_FUSE = "${@bb.utils.contains('DISTRO_FEATURES', 'fuse', 'true', 'false', d)}" | 39 | BUILD_FUSE = "${@bb.utils.contains('DISTRO_FEATURES', 'fuse', 'true', 'false', d)}" |
40 | BUILD_OTA = "${@bb.utils.contains('DISTRO_FEATURES', 'ota', 'true', 'false', d)}" | ||
39 | 41 | ||
40 | PACKAGECONFIG ??= " \ | 42 | PACKAGECONFIG ??= " \ |
41 | ${@bb.utils.filter('COMBINED_FEATURES', 'optee', d)} \ | 43 | ${@bb.utils.filter('COMBINED_FEATURES', 'optee', d)} \ |
@@ -95,11 +97,19 @@ do_compile() { | |||
95 | bl32opt="BL32=${bl32}" | 97 | bl32opt="BL32=${bl32}" |
96 | spdopt="SPD=opteed" | 98 | spdopt="SPD=opteed" |
97 | fi | 99 | fi |
100 | |||
101 | if [ "${BUILD_OTA}" = "true" ]; then | ||
102 | otaopt="POLICY_OTA=1" | ||
103 | btype="${OTABOOTTYPE}" | ||
104 | else | ||
105 | btype="${BOOTTYPE}" | ||
106 | fi | ||
107 | |||
98 | if [ -f ${DEPLOY_DIR_IMAGE}/ddr-phy/ddr4_pmu_train_dmem.bin ]; then | 108 | if [ -f ${DEPLOY_DIR_IMAGE}/ddr-phy/ddr4_pmu_train_dmem.bin ]; then |
99 | cp ${DEPLOY_DIR_IMAGE}/ddr-phy/*.bin ${S}/ | 109 | cp ${DEPLOY_DIR_IMAGE}/ddr-phy/*.bin ${S}/ |
100 | fi | 110 | fi |
101 | 111 | ||
102 | for d in ${BOOTTYPE}; do | 112 | for d in ${btype}; do |
103 | case $d in | 113 | case $d in |
104 | nor) | 114 | nor) |
105 | rcwimg="${RCWNOR}${rcwtemp}.bin" | 115 | rcwimg="${RCWNOR}${rcwtemp}.bin" |
@@ -118,6 +128,9 @@ do_compile() { | |||
118 | sd) | 128 | sd) |
119 | rcwimg="${RCWSD}${rcwtemp}.bin" | 129 | rcwimg="${RCWSD}${rcwtemp}.bin" |
120 | ;; | 130 | ;; |
131 | emmc) | ||
132 | rcwimg="${RCWEMMC}${rcwtemp}.bin" | ||
133 | ;; | ||
121 | flexspi_nor) | 134 | flexspi_nor) |
122 | rcwimg="${RCWXSPI}${rcwtemp}.bin" | 135 | rcwimg="${RCWXSPI}${rcwtemp}.bin" |
123 | uefiboot="${UEFI_XSPIBOOT}" | 136 | uefiboot="${UEFI_XSPIBOOT}" |
@@ -126,7 +139,7 @@ do_compile() { | |||
126 | 139 | ||
127 | if [ -f "${DEPLOY_DIR_IMAGE}/rcw/${PLATFORM}/${rcwimg}" ]; then | 140 | if [ -f "${DEPLOY_DIR_IMAGE}/rcw/${PLATFORM}/${rcwimg}" ]; then |
128 | oe_runmake V=1 -C ${S} realclean | 141 | oe_runmake V=1 -C ${S} realclean |
129 | oe_runmake V=1 -C ${S} all fip pbl PLAT=${PLATFORM} BOOT_MODE=${d} RCW=${DEPLOY_DIR_IMAGE}/rcw/${PLATFORM}/${rcwimg} BL33=${bl33} ${bl32opt} ${spdopt} ${secureopt} ${fuseopt} | 142 | oe_runmake V=1 -C ${S} all fip pbl PLAT=${PLATFORM} BOOT_MODE=${d} RCW=${DEPLOY_DIR_IMAGE}/rcw/${PLATFORM}/${rcwimg} BL33=${bl33} ${bl32opt} ${spdopt} ${secureopt} ${fuseopt} ${otaopt} |
130 | cp -r ${S}/build/${PLATFORM}/release/bl2_${d}*.pbl ${S} | 143 | cp -r ${S}/build/${PLATFORM}/release/bl2_${d}*.pbl ${S} |
131 | cp -r ${S}/build/${PLATFORM}/release/fip.bin ${S} | 144 | cp -r ${S}/build/${PLATFORM}/release/fip.bin ${S} |
132 | if [ "${BUILD_FUSE}" = "true" ]; then | 145 | if [ "${BUILD_FUSE}" = "true" ]; then |
@@ -135,7 +148,7 @@ do_compile() { | |||
135 | 148 | ||
136 | if [ ${MACHINE} = ls1012afrwy ]; then | 149 | if [ ${MACHINE} = ls1012afrwy ]; then |
137 | oe_runmake V=1 -C ${S} realclean | 150 | oe_runmake V=1 -C ${S} realclean |
138 | oe_runmake V=1 -C ${S} all fip pbl PLAT=ls1012afrwy_512mb BOOT_MODE=${d} RCW=${DEPLOY_DIR_IMAGE}/rcw/${PLATFORM}/${rcwimg} BL33=${bl33} ${bl32opt} ${spdopt} ${secureopt} ${fuseopt} | 151 | oe_runmake V=1 -C ${S} all fip pbl PLAT=ls1012afrwy_512mb BOOT_MODE=${d} RCW=${DEPLOY_DIR_IMAGE}/rcw/${PLATFORM}/${rcwimg} BL33=${bl33} ${bl32opt} ${spdopt} ${secureopt} ${fuseopt} ${otaopt} |
139 | cp -r ${S}/build/ls1012afrwy_512mb/release/bl2_qspi${secext}.pbl ${S}/bl2_${d}${secext}_512mb.pbl | 152 | cp -r ${S}/build/ls1012afrwy_512mb/release/bl2_qspi${secext}.pbl ${S}/bl2_${d}${secext}_512mb.pbl |
140 | cp -r ${S}/build/ls1012afrwy_512mb/release/fip.bin ${S}/fip_512mb.bin | 153 | cp -r ${S}/build/ls1012afrwy_512mb/release/fip.bin ${S}/fip_512mb.bin |
141 | if [ "${BUILD_FUSE}" = "true" ]; then | 154 | if [ "${BUILD_FUSE}" = "true" ]; then |
@@ -144,7 +157,7 @@ do_compile() { | |||
144 | fi | 157 | fi |
145 | if [ -n "${uefiboot}" -a -f "${DEPLOY_DIR_IMAGE}/uefi/${PLATFORM}/${uefiboot}" ]; then | 158 | if [ -n "${uefiboot}" -a -f "${DEPLOY_DIR_IMAGE}/uefi/${PLATFORM}/${uefiboot}" ]; then |
146 | oe_runmake V=1 -C ${S} realclean | 159 | oe_runmake V=1 -C ${S} realclean |
147 | oe_runmake V=1 -C ${S} all fip pbl PLAT=${PLATFORM} BOOT_MODE=${d} RCW=${DEPLOY_DIR_IMAGE}/rcw/${PLATFORM}/${rcwimg} BL33=${DEPLOY_DIR_IMAGE}/uefi/${PLATFORM}/${uefiboot} ${bl32opt} ${spdopt} ${secureopt} ${fuseopt} | 160 | oe_runmake V=1 -C ${S} all fip pbl PLAT=${PLATFORM} BOOT_MODE=${d} RCW=${DEPLOY_DIR_IMAGE}/rcw/${PLATFORM}/${rcwimg} BL33=${DEPLOY_DIR_IMAGE}/uefi/${PLATFORM}/${uefiboot} ${bl32opt} ${spdopt} ${secureopt} ${fuseopt} ${otaopt} |
148 | cp -r ${S}/build/${PLATFORM}/release/fip.bin ${S}/fip_uefi.bin | 161 | cp -r ${S}/build/${PLATFORM}/release/fip.bin ${S}/fip_uefi.bin |
149 | fi | 162 | fi |
150 | fi | 163 | fi |