diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2021-07-28 14:25:33 -0500 |
---|---|---|
committer | Tom Hochstein <tom.hochstein@nxp.com> | 2021-07-28 14:27:09 -0500 |
commit | b60b315af7a4438bdec2140e5132e1ed1b7a7cbc (patch) | |
tree | b3c28c7be327bf264e0fe2950173ed5f249ef6b6 /recipes-bsp | |
parent | 6adcab4f177fd132fd08d87cbe296ec21330b2c9 (diff) | |
download | meta-freescale-b60b315af7a4438bdec2140e5132e1ed1b7a7cbc.tar.gz |
isp-imx: Upgrade to 4.2.2.13.0
a52c0446d change version number to p13
800e0f8d8 Fix M865SW-753:copy sensor init txt just for native
a4210be47 remove unused VVCAM_PARAMS
ad8728441 add dual basler camera mode 4 for 1080p25hdr
eea1908b8 cleanup the build script
da5bd492b remove vvnative which is only for local test
c725c6266 Revert "cleanup for unused config file"
a399dbd70 cleanup for unused config file
1bd986e2d Remove basler binary driver from source build
98ef8c98a New partial build partial_release_20210430_4.2.2_p12
31d26c84d Update Release P12 from Verisilicon
c82e5b9bb limit basler camera resolution to 1080p when ov5640 is also used
8c9825a6d add a trailing '/' for file search in directory
f101a6a64 Update Release form Verisilicon
fbfe4fda0 add a blank line for good readability
91663d97c enlarge the StartLimitBurst
0c3dc6a6e add explanatory to the tunning example for video_test
365e7f8f5 BSLRM865-124: improve the running example for video_test
253818b3f Segment error caused by DTS modification
a8a906d4d M865SW-703 Use reversed memory only for tuning tool
7c40835b2 Remove basler binary driver from source build
9bf7ff1ba BSLRM865-131 fix crop seems scale
aee50d3d0 imx8-isp.service: do not prevent restart of service
3232149ac run.sh: fix bashism
5fbf584d2 Removing action for copying run-imx.sh as it's gone
860346a5d Update Release form Verisilicon
f5b3c8783 MLK-25354 add user description for dual basler cameras
85ab6c183 update run script to work with P10/P11
19fb6591b update run script to same as P6
daba60f02 update Release form Verisilicon
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/isp-imx/isp-imx/0001-start_isp.sh-fix-test-to-be-generic.patch | 14 | ||||
-rw-r--r-- | recipes-bsp/isp-imx/isp-imx_4.2.2.13.0.bb (renamed from recipes-bsp/isp-imx/isp-imx_4.2.2.11.0.bb) | 6 |
2 files changed, 10 insertions, 10 deletions
diff --git a/recipes-bsp/isp-imx/isp-imx/0001-start_isp.sh-fix-test-to-be-generic.patch b/recipes-bsp/isp-imx/isp-imx/0001-start_isp.sh-fix-test-to-be-generic.patch index 1b62afe5..be2e1c61 100644 --- a/recipes-bsp/isp-imx/isp-imx/0001-start_isp.sh-fix-test-to-be-generic.patch +++ b/recipes-bsp/isp-imx/isp-imx/0001-start_isp.sh-fix-test-to-be-generic.patch | |||
@@ -10,20 +10,20 @@ Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com> | |||
10 | imx/start_isp.sh | 13 +++++-------- | 10 | imx/start_isp.sh | 13 +++++-------- |
11 | 1 file changed, 5 insertions(+), 8 deletions(-) | 11 | 1 file changed, 5 insertions(+), 8 deletions(-) |
12 | 12 | ||
13 | Index: isp-imx-4.2.2.11.0/imx/start_isp.sh | 13 | Index: isp-imx-4.2.2.13.0/imx/start_isp.sh |
14 | =================================================================== | 14 | =================================================================== |
15 | --- isp-imx-4.2.2.11.0.orig/imx/start_isp.sh | 15 | --- isp-imx-4.2.2.13.0.orig/imx/start_isp.sh |
16 | +++ isp-imx-4.2.2.11.0/imx/start_isp.sh | 16 | +++ isp-imx-4.2.2.13.0/imx/start_isp.sh |
17 | @@ -8,6 +8,7 @@ | 17 | @@ -9,6 +9,7 @@ |
18 | |||
19 | RUNTIME_DIR="$( cd "$(dirname "$0")" >/dev/null 2>&1 ; pwd -P )" | 18 | RUNTIME_DIR="$( cd "$(dirname "$0")" >/dev/null 2>&1 ; pwd -P )" |
20 | NR_DEVICE_TREE_BASLER=$(grep basler-camera-vvcam /sys/firmware/devicetree/base/soc@0/*/i2c@*/*/compatible -l | wc -l 2> /dev/null) | 19 | NR_DEVICE_TREE_BASLER=$(grep basler-camera-vvcam /sys/firmware/devicetree/base/soc@0/*/i2c@*/*/compatible -l | wc -l 2> /dev/null) |
20 | NR_DEVICE_TREE_OV5640=$(grep ov5640 /sys/firmware/devicetree/base/soc@0/*/i2c@*/*/compatible -l | wc -l 2> /dev/null) | ||
21 | +DMESG_BASLER=`dmesg | grep Basler` | 21 | +DMESG_BASLER=`dmesg | grep Basler` |
22 | 22 | ||
23 | # check if the basler device has been enabled in the device tree | 23 | # check if the basler device has been enabled in the device tree |
24 | if [ $NR_DEVICE_TREE_BASLER -eq 1 ]; then | 24 | if [ $NR_DEVICE_TREE_BASLER -eq 1 ]; then |
25 | @@ -28,8 +29,15 @@ elif [ $NR_DEVICE_TREE_BASLER -eq 2 ]; t | 25 | @@ -40,8 +41,15 @@ elif [ $NR_DEVICE_TREE_BASLER -eq 2 ]; t |
26 | # Available configurations: dual_basler_1080p60, dual_basler_1080p60hdr | 26 | # Available configurations: dual_basler_1080p60, dual_basler_1080p60hdr, dual_basler_1080p25hdr |
27 | exec ./run.sh -c dual_basler_1080p60 -lm | 27 | exec ./run.sh -c dual_basler_1080p60 -lm |
28 | 28 | ||
29 | +elif [ ! -z "$DMESG_BASLER" ]; then | 29 | +elif [ ! -z "$DMESG_BASLER" ]; then |
diff --git a/recipes-bsp/isp-imx/isp-imx_4.2.2.11.0.bb b/recipes-bsp/isp-imx/isp-imx_4.2.2.13.0.bb index 3c717c8d..ad44065a 100644 --- a/recipes-bsp/isp-imx/isp-imx_4.2.2.11.0.bb +++ b/recipes-bsp/isp-imx/isp-imx_4.2.2.13.0.bb | |||
@@ -2,7 +2,7 @@ | |||
2 | 2 | ||
3 | DESCRIPTION = "i.MX Verisilicon Software ISP" | 3 | DESCRIPTION = "i.MX Verisilicon Software ISP" |
4 | LICENSE = "Proprietary" | 4 | LICENSE = "Proprietary" |
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=3c3fe2b904fd694f28d2f646ee16dddb" | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=417b82f17fc02b88125331ed312f6f1b" |
6 | DEPENDS = "python3 libdrm virtual/libg2d" | 6 | DEPENDS = "python3 libdrm virtual/libg2d" |
7 | 7 | ||
8 | SRC_URI = " \ | 8 | SRC_URI = " \ |
@@ -11,8 +11,8 @@ SRC_URI = " \ | |||
11 | file://0001-isp-imx-drop-use-of-__TIME__-__DATE__.patch \ | 11 | file://0001-isp-imx-drop-use-of-__TIME__-__DATE__.patch \ |
12 | " | 12 | " |
13 | 13 | ||
14 | SRC_URI[md5sum] = "75f79ba556c47172b9a0cbc3a877e604" | 14 | SRC_URI[md5sum] = "123feed48302fea2a1be8572e913ae47" |
15 | SRC_URI[sha256sum] = "28e2ee909f29a256c4eac87ef8336932d90a88a2a183389ac0868212954af42c" | 15 | SRC_URI[sha256sum] = "e775975684aab4211f0bf8c5e2c6604ba46b83c5586937000675e044a50d77b8" |
16 | 16 | ||
17 | inherit fsl-eula-unpack cmake systemd use-imx-headers | 17 | inherit fsl-eula-unpack cmake systemd use-imx-headers |
18 | 18 | ||