diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2021-04-27 14:59:18 -0500 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2021-04-27 17:07:29 -0300 |
commit | 83c582f3ae6803f46ef76074d8a19bd4a6c6fb17 (patch) | |
tree | 6c4b5208d975509e1a8b365d70d7e192dcb19980 /recipes-bsp | |
parent | 97e35e7f3fe3790cdddd1b8fb75c933af6ecf831 (diff) | |
download | meta-freescale-83c582f3ae6803f46ef76074d8a19bd4a6c6fb17.tar.gz |
u-boot-imx: Update for NXP release 5.4.70-2.3.2
Includes following commits:
185bdaaaf5 MA-18534 imx8mp: Enable trusty for powersave config
30549fb526 MA-18346-11 Android refine power on imx8mp board
42ed8fa287 MA-18422 Locate the misc partition by name
35ab562a3b LFU-15 Fix using uninitialized value
5b339f5614 MA-18352-6 Enable device IDs provision
c3acd3ca3a MA-18352-5 Support device IDs provision
970305d9f1 MA-18458 Sync configs for Android 11 release
933b8ef869 MA-18406 Fix panic when provision keys on boards without rpmb key
0fffe00758 MA-16954 set partition type to efi after flash gpt partition
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/u-boot/u-boot-imx-common.inc | 4 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-imx_2020.04.bb | 2 |
2 files changed, 3 insertions, 3 deletions
diff --git a/recipes-bsp/u-boot/u-boot-imx-common.inc b/recipes-bsp/u-boot/u-boot-imx-common.inc index 2a08aa8a..f1edc92c 100644 --- a/recipes-bsp/u-boot/u-boot-imx-common.inc +++ b/recipes-bsp/u-boot/u-boot-imx-common.inc | |||
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a | |||
5 | 5 | ||
6 | SRCBRANCH = "imx_v2020.04_5.4.70_2.3.0" | 6 | SRCBRANCH = "imx_v2020.04_5.4.70_2.3.0" |
7 | SRC_URI = "git://source.codeaurora.org/external/imx/uboot-imx.git;protocol=https;branch=${SRCBRANCH}" | 7 | SRC_URI = "git://source.codeaurora.org/external/imx/uboot-imx.git;protocol=https;branch=${SRCBRANCH}" |
8 | SRCREV = "e42dee801ec55bc40347cbb98f13bfb5899f0368" | 8 | SRCREV = "185bdaaaf5644319284566e5c340927d28954a1a" |
9 | 9 | ||
10 | DEPENDS += "flex-native bison-native bc-native dtc-native" | 10 | DEPENDS += "flex-native bison-native bc-native dtc-native" |
11 | 11 | ||
@@ -14,7 +14,7 @@ B = "${WORKDIR}/build" | |||
14 | 14 | ||
15 | inherit fsl-u-boot-localversion | 15 | inherit fsl-u-boot-localversion |
16 | 16 | ||
17 | LOCALVERSION ?= "-${SRCBRANCH}" | 17 | LOCALVERSION ?= "-imx_v2020.04_5.4.70_2.3.2" |
18 | 18 | ||
19 | BOOT_TOOLS = "imx-boot-tools" | 19 | BOOT_TOOLS = "imx-boot-tools" |
20 | 20 | ||
diff --git a/recipes-bsp/u-boot/u-boot-imx_2020.04.bb b/recipes-bsp/u-boot/u-boot-imx_2020.04.bb index 55d3e7c5..058229e2 100644 --- a/recipes-bsp/u-boot/u-boot-imx_2020.04.bb +++ b/recipes-bsp/u-boot/u-boot-imx_2020.04.bb | |||
@@ -1,6 +1,6 @@ | |||
1 | # Copyright (C) 2013-2016 Freescale Semiconductor | 1 | # Copyright (C) 2013-2016 Freescale Semiconductor |
2 | # Copyright 2018 (C) O.S. Systems Software LTDA. | 2 | # Copyright 2018 (C) O.S. Systems Software LTDA. |
3 | # Copyright (C) 2017-2020 NXP | 3 | # Copyright (C) 2017-2021 NXP |
4 | 4 | ||
5 | require recipes-bsp/u-boot/u-boot.inc | 5 | require recipes-bsp/u-boot/u-boot.inc |
6 | require u-boot-imx-common.inc | 6 | require u-boot-imx-common.inc |