diff options
author | Lauren Post <lauren.post@freescale.com> | 2015-07-16 14:22:47 -0500 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-28 23:26:59 -0300 |
commit | 46e5dba32244200ec5cde4832c19f3a532c5e078 (patch) | |
tree | 4cc0790972c98d2025681bbd126358e6be065c8d /recipes-bsp | |
parent | 997f8a5815935b221b208b0a1571d2981c825db4 (diff) | |
download | meta-freescale-46e5dba32244200ec5cde4832c19f3a532c5e078.tar.gz |
imx-test: Upgrade to 5.0 version
Released with 3.14.38-6QP_beta release.
This version change creates independence from BSP version.
This will avoid confusion on future BSP updates that don't include
imx-test changes.
- Include support for MX7
- Rework makefiles for legacy machines to avoid rework with new chips.
- DCIC fix for system hangs
- MMDC support for 6QP and revision checks and higher granularity with ms.
- EPDC deprecate old driver and add v2 unit test - remove patches for legacy.
- V4L2 fixes for v4l2_buffer user pointer
Create the mx7 SoC family to the COMPATIBLE_MACHINE in recipe.
Signed-off-by: Lauren Post <lauren.post@freescale.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/imx-test/imx-test.inc | 3 | ||||
-rw-r--r-- | recipes-bsp/imx-test/imx-test_3.14.28-1.0.0.bb | 13 | ||||
-rw-r--r-- | recipes-bsp/imx-test/imx-test_5.0.bb | 11 |
3 files changed, 14 insertions, 13 deletions
diff --git a/recipes-bsp/imx-test/imx-test.inc b/recipes-bsp/imx-test/imx-test.inc index cba72f58..12cf0e1d 100644 --- a/recipes-bsp/imx-test/imx-test.inc +++ b/recipes-bsp/imx-test/imx-test.inc | |||
@@ -9,6 +9,8 @@ DEPENDS_mx6dl = "virtual/kernel imx-lib imx-vpu" | |||
9 | DEPENDS_mx6sl = "virtual/kernel imx-lib" | 9 | DEPENDS_mx6sl = "virtual/kernel imx-lib" |
10 | DEPENDS_mx6sx = "virtual/kernel imx-lib" | 10 | DEPENDS_mx6sx = "virtual/kernel imx-lib" |
11 | DEPENDS_mxs = "virtual/kernel" | 11 | DEPENDS_mxs = "virtual/kernel" |
12 | DEPENDS_mx7 = "virtual/kernel imx-lib" | ||
13 | |||
12 | 14 | ||
13 | LICENSE = "GPLv2" | 15 | LICENSE = "GPLv2" |
14 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" | 16 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" |
@@ -27,6 +29,7 @@ PLATFORM_mx6sl = "IMX6SL" | |||
27 | PLATFORM_mx6sx = "IMX6SX" | 29 | PLATFORM_mx6sx = "IMX6SX" |
28 | PLATFORM_mx53 = "IMX53" | 30 | PLATFORM_mx53 = "IMX53" |
29 | PLATFORM_mx51 = "IMX51" | 31 | PLATFORM_mx51 = "IMX51" |
32 | PLATFORM_mx7 = "IMX7D" | ||
30 | 33 | ||
31 | # Required so the fixdep binary is generated | 34 | # Required so the fixdep binary is generated |
32 | addtask make_scripts after do_patch before do_compile | 35 | addtask make_scripts after do_patch before do_compile |
diff --git a/recipes-bsp/imx-test/imx-test_3.14.28-1.0.0.bb b/recipes-bsp/imx-test/imx-test_3.14.28-1.0.0.bb deleted file mode 100644 index fc2ad1d5..00000000 --- a/recipes-bsp/imx-test/imx-test_3.14.28-1.0.0.bb +++ /dev/null | |||
@@ -1,13 +0,0 @@ | |||
1 | # Copyright (C) 2013-2015 Freescale Semiconductor | ||
2 | |||
3 | include imx-test.inc | ||
4 | |||
5 | SRC_URI_append_mx5 = " file://revert_epdc_hdr_change.patch \ | ||
6 | file://clocks.sh" | ||
7 | SRC_URI_append_mxs = " file://revert_epdc_hdr_change.patch \ | ||
8 | file://clocks.sh" | ||
9 | |||
10 | SRC_URI[md5sum] = "f349aed49830a21cc75d305b06979205" | ||
11 | SRC_URI[sha256sum] = "ea3d572e82a374bcfc9acc654b66262cd97a246ffec9fb9fc458b19a02512723" | ||
12 | |||
13 | COMPATIBLE_MACHINE = "(mxs|mx5|mx6)" | ||
diff --git a/recipes-bsp/imx-test/imx-test_5.0.bb b/recipes-bsp/imx-test/imx-test_5.0.bb new file mode 100644 index 00000000..90e34d57 --- /dev/null +++ b/recipes-bsp/imx-test/imx-test_5.0.bb | |||
@@ -0,0 +1,11 @@ | |||
1 | # Copyright (C) 2013-2015 Freescale Semiconductor | ||
2 | |||
3 | include imx-test.inc | ||
4 | |||
5 | SRC_URI_append_mx5 = " file://clocks.sh" | ||
6 | SRC_URI_append_mxs = " file://clocks.sh" | ||
7 | |||
8 | SRC_URI[md5sum] = "9a44d97f9133cfb933351cf57fe68bb1" | ||
9 | SRC_URI[sha256sum] = "d78c3c0c5f4b74e4efb625b030cd2bb9499143358140e64d2f4f0bba10904a9c" | ||
10 | |||
11 | COMPATIBLE_MACHINE = "(mxs|mx5|mx6|mx7)" | ||