diff options
author | Ting Liu <ting.liu@nxp.com> | 2016-07-16 00:35:46 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-07-22 11:34:12 -0300 |
commit | c279b7647467cbc05e0375efed26c9fec453aee9 (patch) | |
tree | 5ae5fc7ad13bdd83d9875f9af2c5459440269dfb /recipes-bsp | |
parent | a51bae26b2e8cee1eba5b39fc83d360e5de1b55a (diff) | |
download | meta-freescale-c279b7647467cbc05e0375efed26c9fec453aee9.tar.gz |
u-boot-qoriq: set LOCALVERSION to +fsl
SDK_VERSION defaults to nodistro.0 which is not expected in
this recipe.
Also adjust the location of some settings, no code change.
Signed-off-by: Ting Liu <ting.liu@nxp.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb | 11 |
1 files changed, 5 insertions, 6 deletions
diff --git a/recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb b/recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb index 63b53904..002066d8 100644 --- a/recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb +++ b/recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb | |||
@@ -1,5 +1,4 @@ | |||
1 | require recipes-bsp/u-boot/u-boot.inc | 1 | require recipes-bsp/u-boot/u-boot.inc |
2 | inherit fsl-u-boot-localversion | ||
3 | 2 | ||
4 | DESCRIPTION = "U-Boot provided by Freescale with focus on QorIQ boards" | 3 | DESCRIPTION = "U-Boot provided by Freescale with focus on QorIQ boards" |
5 | PROVIDES += "u-boot" | 4 | PROVIDES += "u-boot" |
@@ -25,6 +24,8 @@ SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;branch=${SRCBRANCH} \ | |||
25 | " | 24 | " |
26 | SRCREV = "a9b437f50e2051f8d42ec9e1a6df52de4bc00e1e" | 25 | SRCREV = "a9b437f50e2051f8d42ec9e1a6df52de4bc00e1e" |
27 | 26 | ||
27 | S = "${WORKDIR}/git" | ||
28 | |||
28 | python () { | 29 | python () { |
29 | if d.getVar("TCMODE", True) == "external-fsl": | 30 | if d.getVar("TCMODE", True) == "external-fsl": |
30 | return | 31 | return |
@@ -43,13 +44,11 @@ python () { | |||
43 | } | 44 | } |
44 | 45 | ||
45 | WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}" | 46 | WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}" |
46 | |||
47 | LOCALVERSION = "${@d.getVar('SDK_VERSION', True).partition(' ')[0]}" | ||
48 | |||
49 | S = "${WORKDIR}/git" | ||
50 | |||
51 | EXTRA_OEMAKE = 'CROSS_COMPILE=${WRAP_TARGET_PREFIX} CC="${WRAP_TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"' | 47 | EXTRA_OEMAKE = 'CROSS_COMPILE=${WRAP_TARGET_PREFIX} CC="${WRAP_TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"' |
52 | 48 | ||
49 | inherit fsl-u-boot-localversion | ||
50 | LOCALVERSION = "+fsl" | ||
51 | |||
53 | do_compile_append_qoriq () { | 52 | do_compile_append_qoriq () { |
54 | unset i j | 53 | unset i j |
55 | if [ -n "${UBOOT_CONFIG}" ];then | 54 | if [ -n "${UBOOT_CONFIG}" ];then |