summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2023-08-21 11:48:06 -0700
committerTom Hochstein <tom.hochstein@nxp.com>2023-08-21 11:48:06 -0700
commit0688f79193e697b1bd7444358a7b46c22b83ca2b (patch)
tree16e399566e36c8d126dfc495270abba825115932 /recipes-bsp
parent6c130aaf3edd2cd454080175811fbd333b242f36 (diff)
downloadmeta-freescale-0688f79193e697b1bd7444358a7b46c22b83ca2b.tar.gz
imx-base.inc: Implement generic SOC revision design
Rework imx-boot and use-imx-security-controller-firmware.bbclass with a generic SOC revision design implemented in imx-base.inc. This does replace the machine feature design using `soc-rev*`, but maintains backwards compatibility by incorporating that design into the default settings. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/imx-mkimage/imx-boot_1.0.bb9
1 files changed, 1 insertions, 8 deletions
diff --git a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
index b41c3bf4..1d501ec1 100644
--- a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
+++ b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
@@ -68,14 +68,7 @@ SOC_FAMILY:mx8x-generic-bsp = "mx8x"
68SOC_FAMILY:mx8ulp-generic-bsp = "mx8ulp" 68SOC_FAMILY:mx8ulp-generic-bsp = "mx8ulp"
69SOC_FAMILY:mx93-generic-bsp = "mx93" 69SOC_FAMILY:mx93-generic-bsp = "mx93"
70 70
71REV_OPTION ?= "" 71REV_OPTION ?= "REV=${IMX_SOC_REV_UPPER}"
72REV_OPTION:mx8qxp-generic-bsp = \
73 "${@bb.utils.contains('MACHINE_FEATURES', 'soc-revb0', '', \
74 'REV=C0', d)}"
75REV_OPTION:mx8dx-generic-bsp = "REV=C0"
76REV_OPTION:mx8ulp-generic-bsp = \
77 "${@bb.utils.contains('MACHINE_FEATURES', 'soc-reva0', '', \
78 'REV=A1', d)}"
79 72
80do_uboot_assemble_fitimage:prepend:imx-generic-bsp() { 73do_uboot_assemble_fitimage:prepend:imx-generic-bsp() {
81 for config in ${UBOOT_MACHINE}; do 74 for config in ${UBOOT_MACHINE}; do