summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@nxp.com>2016-12-20 20:18:57 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2017-01-11 10:53:43 -0200
commit8eccdeb615fa7f5c186e942e196bfbf87d9c24dd (patch)
treea5d91bd8c9e43d7fb94dcc35493f083521d8ac9d /recipes-bsp
parent5841c4bc87a3d1bc1e5c9e500645c2da59cde5b7 (diff)
downloadmeta-freescale-8eccdeb615fa7f5c186e942e196bfbf87d9c24dd.tar.gz
u-boot: upgrade to 2016.09
* Upgrade the u-boot to 2016.09 * disable the qspi endianness switch Signed-off-by: Ting Liu <ting.liu@nxp.com> Signed-off-by: Zhenhua Luo <zhenhua.luo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot-qoriq_2016.09.bb (renamed from recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb)40
1 files changed, 24 insertions, 16 deletions
diff --git a/recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb b/recipes-bsp/u-boot/u-boot-qoriq_2016.09.bb
index 6214c467..0b392754 100644
--- a/recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb
+++ b/recipes-bsp/u-boot/u-boot-qoriq_2016.09.bb
@@ -21,7 +21,7 @@ DEPENDS_append_qoriq-ppc = " boot-format-native"
21SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;nobranch=1 \ 21SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;nobranch=1 \
22 file://fix-build-error-under-gcc6.patch \ 22 file://fix-build-error-under-gcc6.patch \
23" 23"
24SRCREV = "7b0fea8ada90cc8a0605bce012c2b0c82d3673d9" 24SRCREV = "199df35d12857a68d5c8ee999dbdd167c3888d62"
25 25
26S = "${WORKDIR}/git" 26S = "${WORKDIR}/git"
27 27
@@ -40,6 +40,14 @@ python () {
40 d.setVar('PATH_append', ':' + d.getVar('STAGING_BINDIR_NATIVE', False) + '/' + sys_multilib) 40 d.setVar('PATH_append', ':' + d.getVar('STAGING_BINDIR_NATIVE', False) + '/' + sys_multilib)
41 d.setVar('TOOLCHAIN_OPTIONS_append', '/../lib32-' + d.getVar("MACHINE", False)) 41 d.setVar('TOOLCHAIN_OPTIONS_append', '/../lib32-' + d.getVar("MACHINE", False))
42 d.setVar("WRAP_TARGET_PREFIX", sys_multilib + '-') 42 d.setVar("WRAP_TARGET_PREFIX", sys_multilib + '-')
43 elif "fsl-lsch2-32b:" in arch:
44 if not "lib64" in ml:
45 raise bb.parse.SkipPackage("Building the u-boot for this arch requires multilib to be enabled")
46 sys_multilib = 'aarch64' + d.getVar('TARGET_VENDOR') + 'mllib64-linux'
47 d.setVar('DEPENDS_append', ' lib64-gcc-cross-aarch64 lib64-libgcc')
48 d.setVar('PATH_append', ':' + d.getVar('STAGING_BINDIR_NATIVE') + '/' + sys_multilib)
49 d.setVar('TOOLCHAIN_OPTIONS_append', '/../lib64-' + d.getVar("MACHINE"))
50 d.setVar("WRAP_TARGET_PREFIX", sys_multilib + '-')
43} 51}
44 52
45WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}" 53WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}"
@@ -49,33 +57,33 @@ EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}"'
49inherit fsl-u-boot-localversion 57inherit fsl-u-boot-localversion
50LOCALVERSION = "+fsl" 58LOCALVERSION = "+fsl"
51 59
52do_compile_append_qoriq () { 60do_compile_append_qoriq() {
53 unset i j 61 unset i j k
54 if [ -n "${UBOOT_CONFIG}" ];then 62 for config in ${UBOOT_MACHINE}; do
55 for config in ${UBOOT_MACHINE}; do 63 i=`expr $i + 1`;
56 i=`expr $i + 1`; 64 for type in ${UBOOT_CONFIG}; do
57 for type in ${UBOOT_CONFIG}; do 65 j=`expr $j + 1`;
58 j=`expr $j + 1`; 66 for binary in ${UBOOT_BINARIES}; do
59 if [ $j -eq $i ]; then 67 k=`expr $k + 1`
68 if [ $j -eq $i ] && [ $k -eq $i ]; then
60 if [ -n "${BOOTFORMAT_CONFIG}" ] && echo "${type}" |grep -q spi;then 69 if [ -n "${BOOTFORMAT_CONFIG}" ] && echo "${type}" |grep -q spi;then
61 # regenerate spi binary if BOOTFORMAT_CONFIG is set 70 # regenerate spi binary if BOOTFORMAT_CONFIG is set
62 boot_format ${STAGING_DATADIR_NATIVE}/boot_format/${BOOTFORMAT_CONFIG} \ 71 boot_format ${STAGING_DATADIR_NATIVE}/boot_format/${BOOTFORMAT_CONFIG} \
63 ${config}/u-boot-${type}.${UBOOT_SUFFIX} -spi ${config}/u-boot.format.bin 72 ${config}/u-boot-${type}.${UBOOT_SUFFIX} -spi ${config}/u-boot.format.bin
64 cp ${config}/u-boot.format.bin ${config}/u-boot-${type}.${UBOOT_SUFFIX} 73 cp ${config}/u-boot.format.bin ${config}/u-boot-${type}.${UBOOT_SUFFIX}
65 elif [ "qspi" = "${type}" ];then 74 elif [ "qspi" = "${type}" ];then
66 # change qspi binary endianess 75 cp ${config}/${binary} ${config}/u-boot-${type}-${PV}-${PR}.${UBOOT_SUFFIX}
67 tclsh ${STAGING_BINDIR_NATIVE}/byte_swap.tcl \
68 ${config}/u-boot-${type}.${UBOOT_SUFFIX} ${config}/u-boot.swap.bin 8
69 cp ${config}/u-boot.swap.bin ${config}/u-boot-${type}.${UBOOT_SUFFIX}
70 fi 76 fi
71 fi 77 fi
72 done 78 done
73 unset j 79 unset k
74 done 80 done
75 unset i 81 unset j
76 fi 82 done
83 unset i
77} 84}
78 85
86
79PACKAGES += "${PN}-images" 87PACKAGES += "${PN}-images"
80FILES_${PN}-images += "/boot" 88FILES_${PN}-images += "/boot"
81COMPATIBLE_MACHINE = "(qoriq)" 89COMPATIBLE_MACHINE = "(qoriq)"