diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2018-07-27 13:37:04 -0500 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2018-08-30 21:57:09 -0300 |
commit | 6c1322dce3e5286cf49374cdec5f6750334e786d (patch) | |
tree | 89826e1ce464700f6e2666cf0c7417231e9fad97 /recipes-bsp | |
parent | d607c7a5ad97eb2d2730227ec6b5afb79e964724 (diff) | |
download | meta-freescale-6c1322dce3e5286cf49374cdec5f6750334e786d.tar.gz |
imx-vpu-hantro: Update to 1.7.0
- Vp9: rectify the consumed length for error return
- MJPEG: bug fixing in trickmode
- H264: bug fixing for special clip containing invalid syntax value
- RV: limit the HW read pointer in valid range
- Common: Export setinfo() API in codec.h
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Fix-ion.h-header-inclusion-to-be-standard.patch (renamed from recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-1.6.0/0001-Fix-ion.h-header-inclusion-to-be-standard.patch) | 37 | ||||
-rw-r--r-- | recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.6.0.bb | 33 | ||||
-rw-r--r-- | recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.7.0.bb | 35 |
3 files changed, 52 insertions, 53 deletions
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-1.6.0/0001-Fix-ion.h-header-inclusion-to-be-standard.patch b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Fix-ion.h-header-inclusion-to-be-standard.patch index 951ead98..e7b23f7e 100644 --- a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-1.6.0/0001-Fix-ion.h-header-inclusion-to-be-standard.patch +++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Fix-ion.h-header-inclusion-to-be-standard.patch | |||
@@ -13,23 +13,10 @@ Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com> | |||
13 | decoder_sw/software/linux/dwl/dwl_linux.c | 2 +- | 13 | decoder_sw/software/linux/dwl/dwl_linux.c | 2 +- |
14 | 2 files changed, 3 insertions(+), 1 deletion(-) | 14 | 2 files changed, 3 insertions(+), 1 deletion(-) |
15 | 15 | ||
16 | diff --git a/Makefile b/Makefile | 16 | Index: imx-vpu-hantro-1.7.0/decoder_sw/software/linux/dwl/dwl_linux.c |
17 | index b74e23a..a5ce22b 100755 | 17 | =================================================================== |
18 | --- a/Makefile | 18 | --- imx-vpu-hantro-1.7.0.orig/decoder_sw/software/linux/dwl/dwl_linux.c |
19 | +++ b/Makefile | 19 | +++ imx-vpu-hantro-1.7.0/decoder_sw/software/linux/dwl/dwl_linux.c |
20 | @@ -11,6 +11,8 @@ INCLUDE_HEADERS = -I./decoder_sw -I$(SOURCE_ROOT)/source/inc -I$(SOURCE_ROOT)/so | ||
21 | INCLUDE_HEADERS += -I$(SOURCE_ROOT)/linux/memalloc | ||
22 | #INCLUDE_HEADERS += -I$(SOURCE_ROOT)/linux/ldriver | ||
23 | INCLUDE_HEADERS += -I$(LINUX_KERNEL_ROOT)/include/uapi -I$(LINUX_KERNEL_ROOT)/include | ||
24 | +# ION header location | ||
25 | +INCLUDE_HEADERS += -I$(LINUX_KERNEL_ROOT)/drivers/staging/android/uapi | ||
26 | |||
27 | CFLAGS += -DDEC_MODULE_PATH=\"/dev/mxc_hantro\" -DUSE_FAKE_RFC_TABLE -DFIFO_DATATYPE=void* -DNDEBUG -DDOWN_SCALER \ | ||
28 | -DUSE_EXTERNAL_BUFFER -DUSE_FAST_EC -DUSE_VP9_EC -DGET_FREE_BUFFER_NON_BLOCK \ | ||
29 | diff --git a/decoder_sw/software/linux/dwl/dwl_linux.c b/decoder_sw/software/linux/dwl/dwl_linux.c | ||
30 | index 8183660..ed37d86 100644 | ||
31 | --- a/decoder_sw/software/linux/dwl/dwl_linux.c | ||
32 | +++ b/decoder_sw/software/linux/dwl/dwl_linux.c | ||
33 | @@ -41,7 +41,7 @@ | 20 | @@ -41,7 +41,7 @@ |
34 | #include "dwl.h" | 21 | #include "dwl.h" |
35 | #include <linux/hantrodec.h> | 22 | #include <linux/hantrodec.h> |
@@ -39,6 +26,16 @@ index 8183660..ed37d86 100644 | |||
39 | #ifdef ANDROID | 26 | #ifdef ANDROID |
40 | #include <linux/mxc_ion.h> | 27 | #include <linux/mxc_ion.h> |
41 | #endif | 28 | #endif |
42 | -- | 29 | Index: imx-vpu-hantro-1.7.0/Makefile_G1G2 |
43 | 2.18.0 | 30 | =================================================================== |
44 | 31 | --- imx-vpu-hantro-1.7.0.orig/Makefile_G1G2 | |
32 | +++ imx-vpu-hantro-1.7.0/Makefile_G1G2 | ||
33 | @@ -11,6 +11,8 @@ INCLUDE_HEADERS = -I./decoder_sw -I$(SOU | ||
34 | INCLUDE_HEADERS += -I$(SOURCE_ROOT)/linux/memalloc | ||
35 | #INCLUDE_HEADERS += -I$(SOURCE_ROOT)/linux/ldriver | ||
36 | INCLUDE_HEADERS += -I$(LINUX_KERNEL_ROOT)/include/uapi -I$(LINUX_KERNEL_ROOT)/include | ||
37 | +# ION header location | ||
38 | +INCLUDE_HEADERS += -I$(LINUX_KERNEL_ROOT)/drivers/staging/android/uapi | ||
39 | |||
40 | CFLAGS += -DDEC_MODULE_PATH=\"/dev/mxc_hantro\" -DUSE_FAKE_RFC_TABLE -DFIFO_DATATYPE=void* -DNDEBUG -DDOWN_SCALER \ | ||
41 | -DUSE_EXTERNAL_BUFFER -DUSE_FAST_EC -DUSE_VP9_EC -DGET_FREE_BUFFER_NON_BLOCK \ | ||
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.6.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.6.0.bb deleted file mode 100644 index 609d6928..00000000 --- a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.6.0.bb +++ /dev/null | |||
@@ -1,33 +0,0 @@ | |||
1 | # Copyright 2017 NXP | ||
2 | |||
3 | DESCRIPTION = "i.MX Hantro VPU library" | ||
4 | LICENSE = "Proprietary" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=08fd295cce89b0a9c74b9b83ed74f671" | ||
6 | |||
7 | DEPENDS = "virtual/kernel" | ||
8 | |||
9 | PROVIDES = "virtual/imxvpu" | ||
10 | |||
11 | SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true \ | ||
12 | file://0001-Fix-ion.h-header-inclusion-to-be-standard.patch \ | ||
13 | " | ||
14 | |||
15 | SRC_URI[md5sum] = "09ec833586afb5f194ce0202da925ed6" | ||
16 | SRC_URI[sha256sum] = "cbc648e41f005aad209f74c9e5dd346138dca12efeb7b27e471de7474c4da302" | ||
17 | |||
18 | inherit fsl-eula-unpack | ||
19 | |||
20 | PARALLEL_MAKE="-j 1" | ||
21 | |||
22 | do_compile () { | ||
23 | oe_runmake CROSS_COMPILE="${HOST_PREFIX}" LINUX_KERNEL_ROOT="${STAGING_KERNEL_DIR}" SDKTARGETSYSROOT="${STAGING_DIR_TARGET}" all | ||
24 | } | ||
25 | |||
26 | do_install () { | ||
27 | oe_runmake DEST_DIR="${D}" install | ||
28 | } | ||
29 | |||
30 | FILES_${PN} += "/unit_tests" | ||
31 | |||
32 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
33 | COMPATIBLE_MACHINE = "(mx8mq)" | ||
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.7.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.7.0.bb new file mode 100644 index 00000000..da2ac513 --- /dev/null +++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.7.0.bb | |||
@@ -0,0 +1,35 @@ | |||
1 | # Copyright 2017-2018 NXP | ||
2 | |||
3 | DESCRIPTION = "i.MX Hantro VPU library" | ||
4 | LICENSE = "Proprietary" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=ab61cab9599935bfe9f700405ef00f28" | ||
6 | |||
7 | DEPENDS = "virtual/kernel" | ||
8 | |||
9 | PROVIDES = "virtual/imxvpu" | ||
10 | |||
11 | SRC_URI = " \ | ||
12 | ${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true \ | ||
13 | file://0001-Fix-ion.h-header-inclusion-to-be-standard.patch \ | ||
14 | " | ||
15 | SRC_URI[md5sum] = "9a8ade25333e6ac3f7c345b71f3477a6" | ||
16 | SRC_URI[sha256sum] = "a3bbf2d8ac00ecae6d48b05cb94d9bdf68085d5bfc54eb176e3bf59670a87ad1" | ||
17 | |||
18 | inherit fsl-eula-unpack | ||
19 | |||
20 | PARALLEL_MAKE="-j 1" | ||
21 | |||
22 | PLATFORM_mx8mq = "IMX8MQ" | ||
23 | |||
24 | do_compile () { | ||
25 | oe_runmake CROSS_COMPILE="${HOST_PREFIX}" LINUX_KERNEL_ROOT="${STAGING_KERNEL_DIR}" SDKTARGETSYSROOT="${STAGING_DIR_TARGET}" PLATFORM="${PLATFORM}" all | ||
26 | } | ||
27 | |||
28 | do_install () { | ||
29 | oe_runmake DEST_DIR="${D}" PLATFORM="${PLATFORM}" install | ||
30 | } | ||
31 | |||
32 | FILES_${PN} += "/unit_tests" | ||
33 | |||
34 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
35 | COMPATIBLE_MACHINE = "(mx8mq)" | ||