diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2018-11-29 14:07:59 -0600 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2018-12-13 07:26:04 -0200 |
commit | 0e518077c9e08bc0269d52eadb3147e027573e5b (patch) | |
tree | aac5e249e527625e5c828e2fbcbd31856535244e /recipes-bsp | |
parent | e7e71e96d6a139d414fcbfae00e5a651a9d4a849 (diff) | |
download | meta-freescale-0e518077c9e08bc0269d52eadb3147e027573e5b.tar.gz |
firmware-imx: Add include file for re-use of archive
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/firmware-imx/firmware-imx-7.8.inc | 18 | ||||
-rw-r--r-- | recipes-bsp/firmware-imx/firmware-imx_7.8.bb | 18 |
2 files changed, 24 insertions, 12 deletions
diff --git a/recipes-bsp/firmware-imx/firmware-imx-7.8.inc b/recipes-bsp/firmware-imx/firmware-imx-7.8.inc new file mode 100644 index 00000000..6da6736c --- /dev/null +++ b/recipes-bsp/firmware-imx/firmware-imx-7.8.inc | |||
@@ -0,0 +1,18 @@ | |||
1 | # Copyright (C) 2012-2016 Freescale Semiconductor | ||
2 | # Copyright 2017-2018 NXP | ||
3 | # Copyright (C) 2018 O.S. Systems Software LTDA. | ||
4 | SECTION = "base" | ||
5 | LICENSE = "Proprietary" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=5ab1a30d0cd181e3408077727ea5a2db" | ||
7 | |||
8 | SRCBRANCH ?= "master" | ||
9 | SRC_URI = " \ | ||
10 | ${FSL_MIRROR}/firmware-imx-${PV}.bin;fsl-eula=true \ | ||
11 | " | ||
12 | |||
13 | SRC_URI[md5sum] = "0967aa59b3fd8d80fcb98146a9aac91b" | ||
14 | SRC_URI[sha256sum] = "910fbf866f61185adfd60c1704b2da41030cb175901d06e40402b49f9240bdee" | ||
15 | |||
16 | S = "${WORKDIR}/firmware-imx-${PV}" | ||
17 | |||
18 | inherit fsl-eula-unpack | ||
diff --git a/recipes-bsp/firmware-imx/firmware-imx_7.8.bb b/recipes-bsp/firmware-imx/firmware-imx_7.8.bb index d7060b06..0fb2d5dc 100644 --- a/recipes-bsp/firmware-imx/firmware-imx_7.8.bb +++ b/recipes-bsp/firmware-imx/firmware-imx_7.8.bb | |||
@@ -3,23 +3,17 @@ | |||
3 | # Copyright (C) 2018 O.S. Systems Software LTDA. | 3 | # Copyright (C) 2018 O.S. Systems Software LTDA. |
4 | SUMMARY = "Freescale i.MX firmware" | 4 | SUMMARY = "Freescale i.MX firmware" |
5 | DESCRIPTION = "Freescale i.MX firmware such as for the VPU" | 5 | DESCRIPTION = "Freescale i.MX firmware such as for the VPU" |
6 | SECTION = "base" | ||
7 | LICENSE = "Proprietary" | ||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=5ab1a30d0cd181e3408077727ea5a2db" | ||
9 | 6 | ||
10 | PE = "1" | 7 | require firmware-imx-${PV}.inc |
11 | 8 | ||
12 | SRCBRANCH ?= "master" | 9 | PE = "1" |
13 | SRC_URI = "${FSL_MIRROR}/firmware-imx-${PV}.bin;fsl-eula=true \ | ||
14 | git://github.com/NXP/imx-firmware.git;protocol=https;branch=${SRCBRANCH};destsuffix=${S}/git" | ||
15 | 10 | ||
16 | #BRCM firmware git | 11 | SRC_URI += " \ |
12 | git://github.com/NXP/imx-firmware.git;protocol=https;branch=${SRCBRANCH};destsuffix=${S}/git \ | ||
13 | " | ||
17 | SRCREV = "8ce9046f5058fdd2c5271f86ccfc61bc5a248ae3" | 14 | SRCREV = "8ce9046f5058fdd2c5271f86ccfc61bc5a248ae3" |
18 | 15 | ||
19 | SRC_URI[md5sum] = "0967aa59b3fd8d80fcb98146a9aac91b" | 16 | inherit allarch |
20 | SRC_URI[sha256sum] = "910fbf866f61185adfd60c1704b2da41030cb175901d06e40402b49f9240bdee" | ||
21 | |||
22 | inherit fsl-eula-unpack allarch | ||
23 | 17 | ||
24 | do_install() { | 18 | do_install() { |
25 | install -d ${D}${base_libdir}/firmware/imx | 19 | install -d ${D}${base_libdir}/firmware/imx |