diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2016-08-22 14:11:39 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-08-23 23:26:55 -0300 |
commit | 2d2ec411cd6e4c1afbca68e14336e2b017b8cb02 (patch) | |
tree | af06ced068a723b3b58f345d3980fc1ea42b4182 /recipes-bsp | |
parent | 960a7bea0fe737c1c581cb6e7e3b6e18ccf367b0 (diff) | |
download | meta-freescale-2d2ec411cd6e4c1afbca68e14336e2b017b8cb02.tar.gz |
imx-test: obey LDFLAGS settings
The gcc-cross default linker hash has been changed in OE-Core:fa436aeb,
due that the broken recipes (which were not respecting the set LDFLAGS
settings) are now exposed.
This fixes the error setting the need Make flags so the build system
obey the LDFLAGS setting.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/imx-test/imx-test.inc | 2 | ||||
-rw-r--r-- | recipes-bsp/imx-test/imx-test_5.4.1.bb | 2 |
2 files changed, 3 insertions, 1 deletions
diff --git a/recipes-bsp/imx-test/imx-test.inc b/recipes-bsp/imx-test/imx-test.inc index 10dbb4d2..f0b26a18 100644 --- a/recipes-bsp/imx-test/imx-test.inc +++ b/recipes-bsp/imx-test/imx-test.inc | |||
@@ -40,7 +40,6 @@ do_make_scripts[depends] += "virtual/kernel:do_install" | |||
40 | 40 | ||
41 | do_compile() { | 41 | do_compile() { |
42 | CFLAGS="${TOOLCHAIN_OPTIONS}" | 42 | CFLAGS="${TOOLCHAIN_OPTIONS}" |
43 | LDFLAGS="${TOOLCHAIN_OPTIONS} -L${STAGING_LIBDIR}" | ||
44 | oe_runmake V=1 VERBOSE='' \ | 43 | oe_runmake V=1 VERBOSE='' \ |
45 | CROSS_COMPILE=${TARGET_PREFIX} \ | 44 | CROSS_COMPILE=${TARGET_PREFIX} \ |
46 | INC="-I${STAGING_INCDIR} \ | 45 | INC="-I${STAGING_INCDIR} \ |
@@ -52,6 +51,7 @@ do_compile() { | |||
52 | -I${STAGING_KERNEL_DIR}/arch/arm/include \ | 51 | -I${STAGING_KERNEL_DIR}/arch/arm/include \ |
53 | -I${STAGING_KERNEL_DIR}/drivers/mxc/security/rng/include \ | 52 | -I${STAGING_KERNEL_DIR}/drivers/mxc/security/rng/include \ |
54 | -I${STAGING_KERNEL_DIR}/drivers/mxc/security/sahara2/include" \ | 53 | -I${STAGING_KERNEL_DIR}/drivers/mxc/security/sahara2/include" \ |
54 | CC="${CC} -L${STAGING_LIBDIR} ${LDFLAGS}" \ | ||
55 | LINUXPATH=${STAGING_KERNEL_DIR} \ | 55 | LINUXPATH=${STAGING_KERNEL_DIR} \ |
56 | KBUILD_OUTPUT=${STAGING_KERNEL_BUILDDIR} \ | 56 | KBUILD_OUTPUT=${STAGING_KERNEL_BUILDDIR} \ |
57 | PLATFORM=${PLATFORM} | 57 | PLATFORM=${PLATFORM} |
diff --git a/recipes-bsp/imx-test/imx-test_5.4.1.bb b/recipes-bsp/imx-test/imx-test_5.4.1.bb index 04aad145..e33cc8d3 100644 --- a/recipes-bsp/imx-test/imx-test_5.4.1.bb +++ b/recipes-bsp/imx-test/imx-test_5.4.1.bb | |||
@@ -5,4 +5,6 @@ include imx-test.inc | |||
5 | SRC_URI[md5sum] = "fa1a5cdcfbdd6a3fed0ab4a5fd1f97bc" | 5 | SRC_URI[md5sum] = "fa1a5cdcfbdd6a3fed0ab4a5fd1f97bc" |
6 | SRC_URI[sha256sum] = "997ec10bdc6991e9687a2c2fa5816bb50b08d73bcfe4093f988a7cac4bf0b06a" | 6 | SRC_URI[sha256sum] = "997ec10bdc6991e9687a2c2fa5816bb50b08d73bcfe4093f988a7cac4bf0b06a" |
7 | 7 | ||
8 | PR = "r1" | ||
9 | |||
8 | COMPATIBLE_MACHINE = "(mx6|mx6ul|mx7)" | 10 | COMPATIBLE_MACHINE = "(mx6|mx6ul|mx7)" |