diff options
author | Chunrong Guo <chunrong.guo@nxp.com> | 2019-01-11 03:15:11 +0000 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2019-01-14 16:23:38 -0200 |
commit | 140eb6a3ef58446a1256b3e8de0d5cee0fd3dcb4 (patch) | |
tree | c5c9f086b3602e39802d5b4d6ea60e064bde96de /recipes-bsp | |
parent | f2cbe432babcde8a235c919a3233f9511a316dd4 (diff) | |
download | meta-freescale-140eb6a3ef58446a1256b3e8de0d5cee0fd3dcb4.tar.gz |
u-boot-qoriq: update sysroot path
*fix the below error
|powerpc-fslmllib32-linux-ld: cannot find -lgcc
Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/u-boot/u-boot-qoriq_2018.09.bb | 4 |
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-bsp/u-boot/u-boot-qoriq_2018.09.bb b/recipes-bsp/u-boot/u-boot-qoriq_2018.09.bb index d01efdd5..8438134d 100644 --- a/recipes-bsp/u-boot/u-boot-qoriq_2018.09.bb +++ b/recipes-bsp/u-boot/u-boot-qoriq_2018.09.bb | |||
@@ -22,7 +22,7 @@ python () { | |||
22 | raise bb.parse.SkipPackage("Building the u-boot for this arch requires multilib to be enabled") | 22 | raise bb.parse.SkipPackage("Building the u-boot for this arch requires multilib to be enabled") |
23 | sys_multilib = d.getVar('TARGET_VENDOR') + 'mllib32-linux' | 23 | sys_multilib = d.getVar('TARGET_VENDOR') + 'mllib32-linux' |
24 | sys_original = d.getVar('TARGET_VENDOR') + '-' + d.getVar('TARGET_OS') | 24 | sys_original = d.getVar('TARGET_VENDOR') + '-' + d.getVar('TARGET_OS') |
25 | workdir = d.getVar('WORKDIR').replace(sys_original,sys_multilib) | 25 | workdir = d.getVar('WORKDIR') |
26 | d.setVar('DEPENDS_append', ' lib32-gcc-cross-powerpc lib32-libgcc') | 26 | d.setVar('DEPENDS_append', ' lib32-gcc-cross-powerpc lib32-libgcc') |
27 | d.setVar('PATH_append', ':' + d.getVar('STAGING_BINDIR_NATIVE') + '/powerpc' + sys_multilib) | 27 | d.setVar('PATH_append', ':' + d.getVar('STAGING_BINDIR_NATIVE') + '/powerpc' + sys_multilib) |
28 | d.setVar('TOOLCHAIN_OPTIONS', '--sysroot=' + workdir + '/lib32-recipe-sysroot') | 28 | d.setVar('TOOLCHAIN_OPTIONS', '--sysroot=' + workdir + '/lib32-recipe-sysroot') |
@@ -32,7 +32,7 @@ python () { | |||
32 | raise bb.parse.SkipRecipe("Building the u-boot for this arch requires multilib to be enabled") | 32 | raise bb.parse.SkipRecipe("Building the u-boot for this arch requires multilib to be enabled") |
33 | sys_multilib = d.getVar('TARGET_VENDOR') + 'mllib64-linux' | 33 | sys_multilib = d.getVar('TARGET_VENDOR') + 'mllib64-linux' |
34 | sys_original = d.getVar('TARGET_VENDOR') + '-' + d.getVar('TARGET_OS') | 34 | sys_original = d.getVar('TARGET_VENDOR') + '-' + d.getVar('TARGET_OS') |
35 | workdir = d.getVar('WORKDIR').replace(sys_original,sys_multilib) | 35 | workdir = d.getVar('WORKDIR') |
36 | d.setVar('DEPENDS_append', ' lib64-gcc-cross-aarch64 lib64-libgcc') | 36 | d.setVar('DEPENDS_append', ' lib64-gcc-cross-aarch64 lib64-libgcc') |
37 | d.setVar('PATH_append', ':' + d.getVar('STAGING_BINDIR_NATIVE') + '/aarch64' + sys_multilib) | 37 | d.setVar('PATH_append', ':' + d.getVar('STAGING_BINDIR_NATIVE') + '/aarch64' + sys_multilib) |
38 | d.setVar('TOOLCHAIN_OPTIONS', '--sysroot=' + workdir + '/lib64-recipe-sysroot') | 38 | d.setVar('TOOLCHAIN_OPTIONS', '--sysroot=' + workdir + '/lib64-recipe-sysroot') |