diff options
author | Fabio Berton <fabio.berton@ossystems.com.br> | 2017-10-04 10:31:47 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2017-10-04 14:36:00 -0300 |
commit | b94a63e25c6307711e4c118f77ec83a9b19a3a06 (patch) | |
tree | d13b91de3f08e30488c0e891ae73463a4d0a1c82 /recipes-bsp | |
parent | 2bb4bb7c936f2654a6348da90693ea3125fb3415 (diff) | |
download | meta-freescale-b94a63e25c6307711e4c118f77ec83a9b19a3a06.tar.gz |
u-boot-fslc-fw-utils: Add recipe for version 2017.09
Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/u-boot/u-boot-fslc-fw-utils_2017.09.bb | 45 |
1 files changed, 45 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2017.09.bb b/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2017.09.bb new file mode 100644 index 00000000..dd46bfec --- /dev/null +++ b/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2017.09.bb | |||
@@ -0,0 +1,45 @@ | |||
1 | require u-boot-fslc-common_${PV}.inc | ||
2 | |||
3 | SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities" | ||
4 | |||
5 | DEPENDS_append = " mtd-utils" | ||
6 | |||
7 | INSANE_SKIP_${PN} = "already-stripped" | ||
8 | EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1' | ||
9 | EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1' | ||
10 | |||
11 | inherit uboot-config | ||
12 | |||
13 | do_compile () { | ||
14 | oe_runmake ${UBOOT_MACHINE} | ||
15 | oe_runmake env | ||
16 | } | ||
17 | |||
18 | do_install () { | ||
19 | install -d ${D}${base_sbindir} | ||
20 | install -d ${D}${sysconfdir} | ||
21 | install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv | ||
22 | install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv | ||
23 | |||
24 | if [ -e ${WORKDIR}/fw_env.config ]; then | ||
25 | install -m 0644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config | ||
26 | else | ||
27 | install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config | ||
28 | fi | ||
29 | } | ||
30 | |||
31 | do_install_class-cross () { | ||
32 | install -d ${D}${bindir_cross} | ||
33 | install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv | ||
34 | install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv | ||
35 | } | ||
36 | |||
37 | SYSROOT_PREPROCESS_FUNCS_class-cross = "uboot_fw_utils_cross" | ||
38 | uboot_fw_utils_cross() { | ||
39 | sysroot_stage_dir ${D}${bindir_cross} ${SYSROOT_DESTDIR}${bindir_cross} | ||
40 | } | ||
41 | |||
42 | RPROVIDES_${PN} += "u-boot-fw-utils" | ||
43 | |||
44 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
45 | BBCLASSEXTEND = "cross" | ||