diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2021-07-16 12:20:05 -0500 |
---|---|---|
committer | Tom Hochstein <tom.hochstein@nxp.com> | 2021-07-16 12:20:09 -0500 |
commit | 6d463c7048ef95e56d4730d5636df4b8836a2059 (patch) | |
tree | c579ad67c6fac21f0e2a444f9299656642caeca5 /recipes-bsp | |
parent | ea3c8d90600c2ad3a0a8989d3965aa85f28bd6df (diff) | |
download | meta-freescale-6d463c7048ef95e56d4730d5636df4b8836a2059.tar.gz |
imx-mkimage: Drop dcd files from deploy folder
The dcd files are apparently not needed and can be dropped.
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/imx-mkimage/imx-mkimage_git.bb | 15 |
1 files changed, 1 insertions, 14 deletions
diff --git a/recipes-bsp/imx-mkimage/imx-mkimage_git.bb b/recipes-bsp/imx-mkimage/imx-mkimage_git.bb index 4e154f6d..f9943342 100644 --- a/recipes-bsp/imx-mkimage/imx-mkimage_git.bb +++ b/recipes-bsp/imx-mkimage/imx-mkimage_git.bb | |||
@@ -1,5 +1,5 @@ | |||
1 | # Copyright (C) 2016 Freescale Semiconductor | 1 | # Copyright (C) 2016 Freescale Semiconductor |
2 | # Copyright (C) 2017-2020 NXP | 2 | # Copyright (C) 2017-2021 NXP |
3 | 3 | ||
4 | require imx-mkimage_git.inc | 4 | require imx-mkimage_git.inc |
5 | 5 | ||
@@ -12,18 +12,11 @@ inherit deploy native | |||
12 | 12 | ||
13 | CFLAGS = "-O2 -Wall -std=c99 -I ${STAGING_INCDIR} -L ${STAGING_LIBDIR}" | 13 | CFLAGS = "-O2 -Wall -std=c99 -I ${STAGING_INCDIR} -L ${STAGING_LIBDIR}" |
14 | 14 | ||
15 | REV_CHIP ?= "B0" | ||
16 | REV_CHIP_mx8qxp = \ | ||
17 | "${@bb.utils.contains('MACHINE_FEATURES', 'soc-revb0', 'B0', \ | ||
18 | 'C0', d)}" | ||
19 | |||
20 | do_compile () { | 15 | do_compile () { |
21 | cd ${S} | 16 | cd ${S} |
22 | oe_runmake clean | 17 | oe_runmake clean |
23 | oe_runmake bin | 18 | oe_runmake bin |
24 | oe_runmake -C iMX8M -f soc.mak mkimage_imx8 | 19 | oe_runmake -C iMX8M -f soc.mak mkimage_imx8 |
25 | oe_runmake -C iMX8QM REV=${REV_CHIP} -f soc.mak imx8qm_dcd.cfg.tmp | ||
26 | oe_runmake -C iMX8QX REV=${REV_CHIP} -f soc.mak imx8qx_dcd.cfg.tmp | ||
27 | } | 20 | } |
28 | 21 | ||
29 | do_install () { | 22 | do_install () { |
@@ -32,9 +25,3 @@ do_install () { | |||
32 | install -m 0755 iMX8M/mkimage_imx8 ${D}${bindir}/mkimage_imx8m | 25 | install -m 0755 iMX8M/mkimage_imx8 ${D}${bindir}/mkimage_imx8m |
33 | install -m 0755 mkimage_imx8 ${D}${bindir}/mkimage_imx8 | 26 | install -m 0755 mkimage_imx8 ${D}${bindir}/mkimage_imx8 |
34 | } | 27 | } |
35 | |||
36 | do_deploy () { | ||
37 | install -m 0644 ${S}/iMX8QM/imx8qm_dcd.cfg.tmp ${DEPLOYDIR} | ||
38 | install -m 0644 ${S}/iMX8QX/imx8qx_dcd.cfg.tmp ${DEPLOYDIR} | ||
39 | } | ||
40 | addtask deploy before do_build after do_install | ||