summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2016-07-16 00:35:47 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-07-22 11:34:12 -0300
commitf5a070e6082e1837463e8ff2398e0b06c6b19ae8 (patch)
tree2fe3ebd12fc64c99d9ccce3c9e5355a525bc15c8 /recipes-bsp
parentc279b7647467cbc05e0375efed26c9fec453aee9 (diff)
downloadmeta-freescale-f5a070e6082e1837463e8ff2398e0b06c6b19ae8.tar.gz
u-boot-qoriq: Add host compiler flags
U-Boot will compile its own tools during the build, with specific configurations (aka when CONFIG_FIT_SIGNATURE is enabled) the host tools require openssl. This patch adds 'openssl' as a PACKAGECONFIG that enables the use of openssl-native as a dependency and also adds the HOSTCC flags that U-Boot uses when compiling the host tools. (From OE-Core rev: 7d0edf5d04fba0b642bfb08a1de28fbc8e480209) Signed-off-by: Ting Liu <ting.liu@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb b/recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb
index 002066d8..90e9677a 100644
--- a/recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb
+++ b/recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb
@@ -44,7 +44,8 @@ python () {
44} 44}
45 45
46WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}" 46WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}"
47EXTRA_OEMAKE = 'CROSS_COMPILE=${WRAP_TARGET_PREFIX} CC="${WRAP_TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"' 47EXTRA_OEMAKE = 'CROSS_COMPILE=${WRAP_TARGET_PREFIX} CC="${WRAP_TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}" V=1'
48EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}"'
48 49
49inherit fsl-u-boot-localversion 50inherit fsl-u-boot-localversion
50LOCALVERSION = "+fsl" 51LOCALVERSION = "+fsl"