diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2023-01-10 08:33:58 -0300 |
---|---|---|
committer | GitHub <noreply@github.com> | 2023-01-10 08:33:58 -0300 |
commit | bfc79d62e3048173f893b63f2a7b0484f3e670fb (patch) | |
tree | a8273ed5a9b9dc8c70245645e3b0447fe9c7a954 /recipes-bsp | |
parent | 8ef79121cc16a5ee3616d115abd809ac615dc187 (diff) | |
parent | 7ef6cf54bea75aa456b808226466797613443513 (diff) | |
download | meta-freescale-bfc79d62e3048173f893b63f2a7b0484f3e670fb.tar.gz |
Merge pull request #1370 from Freescale/backport-1363-to-kirkstone
[Backport kirkstone] imx-seco Update from lf-5.15.52-2.1.0 to lf-5.15.71-2.2.0
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/imx-seco/imx-seco-libs/0001-Fix-return-value-of-void-functions.patch | 57 | ||||
-rw-r--r-- | recipes-bsp/imx-seco/imx-seco-libs_git.bb | 9 | ||||
-rw-r--r-- | recipes-bsp/imx-seco/imx-seco_5.9.0.bb (renamed from recipes-bsp/imx-seco/imx-seco_5.8.7.1.bb) | 6 |
3 files changed, 65 insertions, 7 deletions
diff --git a/recipes-bsp/imx-seco/imx-seco-libs/0001-Fix-return-value-of-void-functions.patch b/recipes-bsp/imx-seco/imx-seco-libs/0001-Fix-return-value-of-void-functions.patch new file mode 100644 index 00000000..656469c2 --- /dev/null +++ b/recipes-bsp/imx-seco/imx-seco-libs/0001-Fix-return-value-of-void-functions.patch | |||
@@ -0,0 +1,57 @@ | |||
1 | From 2eff97fe2345d8255869224404322d23193f1115 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 7 Jan 2023 21:59:15 -0800 | ||
4 | Subject: [PATCH] Fix return value of void* functions | ||
5 | |||
6 | This is found with clang | ||
7 | |||
8 | Fixes | ||
9 | error: non-void function does not return a value [-Werror,-Wreturn-type] | ||
10 | |||
11 | Upstream-Status: Pending | ||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | --- | ||
14 | test/hsm/hsm_test.c | 1 + | ||
15 | test/she/src/she_test_storage_manager.c | 1 + | ||
16 | test/v2x/v2x_test.c | 1 + | ||
17 | 3 files changed, 3 insertions(+) | ||
18 | |||
19 | diff --git a/test/hsm/hsm_test.c b/test/hsm/hsm_test.c | ||
20 | index 9f29ca9..01820b8 100644 | ||
21 | --- a/test/hsm/hsm_test.c | ||
22 | +++ b/test/hsm/hsm_test.c | ||
23 | @@ -391,6 +391,7 @@ static uint32_t nvm_status; | ||
24 | static void *hsm_storage_thread(void *arg) | ||
25 | { | ||
26 | seco_nvm_manager(NVM_FLAGS_HSM, &nvm_status); | ||
27 | + return 0; | ||
28 | } | ||
29 | |||
30 | |||
31 | diff --git a/test/she/src/she_test_storage_manager.c b/test/she/src/she_test_storage_manager.c | ||
32 | index 32a4cb9..68cdba7 100644 | ||
33 | --- a/test/she/src/she_test_storage_manager.c | ||
34 | +++ b/test/she/src/she_test_storage_manager.c | ||
35 | @@ -28,6 +28,7 @@ static uint32_t nvm_status; | ||
36 | static void *she_storage_thread(void *arg) | ||
37 | { | ||
38 | seco_nvm_manager(NVM_FLAGS_SHE, &nvm_status); | ||
39 | + return 0; | ||
40 | } | ||
41 | |||
42 | |||
43 | diff --git a/test/v2x/v2x_test.c b/test/v2x/v2x_test.c | ||
44 | index aeb3d2a..5f02354 100644 | ||
45 | --- a/test/v2x/v2x_test.c | ||
46 | +++ b/test/v2x/v2x_test.c | ||
47 | @@ -181,6 +181,7 @@ static uint32_t nvm_status; | ||
48 | static void *v2x_hsm_storage_thread(void *arg) | ||
49 | { | ||
50 | seco_nvm_manager(NVM_FLAGS_V2X | NVM_FLAGS_HSM, &nvm_status); | ||
51 | + return 0; | ||
52 | } | ||
53 | |||
54 | |||
55 | -- | ||
56 | 2.39.0 | ||
57 | |||
diff --git a/recipes-bsp/imx-seco/imx-seco-libs_git.bb b/recipes-bsp/imx-seco/imx-seco-libs_git.bb index 625834b7..b0296e97 100644 --- a/recipes-bsp/imx-seco/imx-seco-libs_git.bb +++ b/recipes-bsp/imx-seco/imx-seco-libs_git.bb | |||
@@ -8,19 +8,20 @@ LIC_FILES_CHKSUM = "file://EULA.txt;md5=d3c315c6eaa43e07d8c130dc3a04a011" | |||
8 | 8 | ||
9 | DEPENDS = "zlib" | 9 | DEPENDS = "zlib" |
10 | 10 | ||
11 | SRCBRANCH = "imx_5.4.70_2.3.9" | 11 | SRCBRANCH = "imx_5.4.70_2.3.11" |
12 | SRC_URI = "git://github.com/NXP/imx-seco-libs.git;protocol=https;branch=${SRCBRANCH} \ | 12 | SRC_URI = "git://github.com/NXP/imx-seco-libs.git;protocol=https;branch=${SRCBRANCH} \ |
13 | file://0001-Makefile-Fix-LIBDIR-for-multilib.patch \ | 13 | file://0001-Makefile-Fix-LIBDIR-for-multilib.patch \ |
14 | file://0002-Makefile-Fix-install-to-clear-host-user-contaminated.patch \ | 14 | file://0002-Makefile-Fix-install-to-clear-host-user-contaminated.patch \ |
15 | file://0001-add-v2x_test-to-the-installed-binaries.patch" | 15 | file://0001-add-v2x_test-to-the-installed-binaries.patch \ |
16 | SRCREV = "b2550476388e1d1453bddbf356844301467c7bfa" | 16 | file://0001-Fix-return-value-of-void-functions.patch" |
17 | SRCREV = "aa8d62900c41cc779c11fe4e6f58b40c3c9f82f0" | ||
17 | 18 | ||
18 | S = "${WORKDIR}/git" | 19 | S = "${WORKDIR}/git" |
19 | 20 | ||
20 | TARGET_CC_ARCH += "${LDFLAGS}" | 21 | TARGET_CC_ARCH += "${LDFLAGS}" |
21 | 22 | ||
22 | do_install () { | 23 | do_install () { |
23 | oe_runmake DESTDIR=${D} install | 24 | oe_runmake DESTDIR=${D} BINDIR=${bindir} LIBDIR=${libdir} install |
24 | } | 25 | } |
25 | 26 | ||
26 | COMPATIBLE_MACHINE = "(mx8qm-nxp-bsp|mx8qxp-nxp-bsp|mx8dxl-nxp-bsp|mx8dx-nxp-bsp)" | 27 | COMPATIBLE_MACHINE = "(mx8qm-nxp-bsp|mx8qxp-nxp-bsp|mx8dxl-nxp-bsp|mx8dx-nxp-bsp)" |
diff --git a/recipes-bsp/imx-seco/imx-seco_5.8.7.1.bb b/recipes-bsp/imx-seco/imx-seco_5.9.0.bb index d37c1c98..712be23a 100644 --- a/recipes-bsp/imx-seco/imx-seco_5.8.7.1.bb +++ b/recipes-bsp/imx-seco/imx-seco_5.9.0.bb | |||
@@ -4,14 +4,14 @@ SUMMARY = "NXP i.MX SECO firmware" | |||
4 | DESCRIPTION = "Firmware for i.MX Security Controller Subsystem" | 4 | DESCRIPTION = "Firmware for i.MX Security Controller Subsystem" |
5 | SECTION = "base" | 5 | SECTION = "base" |
6 | LICENSE = "Proprietary" | 6 | LICENSE = "Proprietary" |
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=d3c315c6eaa43e07d8c130dc3a04a011" | 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=5a0bf11f745e68024f37b4724a5364fe" |
8 | 8 | ||
9 | inherit fsl-eula-unpack use-imx-security-controller-firmware deploy | 9 | inherit fsl-eula-unpack use-imx-security-controller-firmware deploy |
10 | 10 | ||
11 | SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true" | 11 | SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true" |
12 | 12 | ||
13 | SRC_URI[md5sum] = "f5c6737b42275e513d4e0cc2efa91d6a" | 13 | SRC_URI[md5sum] = "b722a534c4d3cc90270e05eaa812514d" |
14 | SRC_URI[sha256sum] = "03fa16ebc0633505bd02dae1c58602e278a8a28c8205c758fa3936477d51d0e0" | 14 | SRC_URI[sha256sum] = "c3bd761f457e939035b01a0ab36e79064a2a1bc6c3cdb3cd847f7f38df0964df" |
15 | 15 | ||
16 | 16 | ||
17 | do_compile[noexec] = "1" | 17 | do_compile[noexec] = "1" |