diff options
author | Andrey Zhizhikin <andrey.z@gmail.com> | 2020-12-11 16:16:03 +0000 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2020-12-11 19:37:54 -0300 |
commit | 64fe53c2f23bd802a3090f5c6c8b3b45326b40d6 (patch) | |
tree | 2569b80b8e4e71bb267d6ff2b5e01857122e576e /recipes-bsp | |
parent | b93dcbeb9cf7709f3593690cb25f87558347c239 (diff) | |
download | meta-freescale-64fe53c2f23bd802a3090f5c6c8b3b45326b40d6.tar.gz |
imx-atf: allow to be used with mainline bsp for mx8m machines
Since ATF is required for i.MX8M series to boot the SOC, allow it to be
built when use-mainline-bsp is set.
Move ATF build platform definition to target machine configuration
files, since MACHINEOVERRIDES extender filters out the override that is
used to identify it in the recipe. Therefore, for those mx8m machines
that are ready to be built with mainline BSP - ATF build platform is
explicitly defined in the machine config in order to be properly set for
ATF build.
Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/imx-atf/imx-atf_2.2.bb | 25 |
1 files changed, 11 insertions, 14 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf_2.2.bb b/recipes-bsp/imx-atf/imx-atf_2.2.bb index ca07dcad..e89822da 100644 --- a/recipes-bsp/imx-atf/imx-atf_2.2.bb +++ b/recipes-bsp/imx-atf/imx-atf_2.2.bb | |||
@@ -20,20 +20,17 @@ inherit deploy | |||
20 | 20 | ||
21 | BOOT_TOOLS = "imx-boot-tools" | 21 | BOOT_TOOLS = "imx-boot-tools" |
22 | 22 | ||
23 | PLATFORM ?= "INVALID" | 23 | ATF_PLATFORM ??= "INVALID" |
24 | PLATFORM_mx8qm = "imx8qm" | 24 | ATF_PLATFORM_mx8qm = "imx8qm" |
25 | PLATFORM_mx8x = "imx8qx" | 25 | ATF_PLATFORM_mx8x = "imx8qx" |
26 | PLATFORM_mx8mq = "imx8mq" | 26 | ATF_PLATFORM_mx8mq = "imx8mq" |
27 | PLATFORM_mx8mm = "imx8mm" | 27 | ATF_PLATFORM_mx8dx = "imx8dx" |
28 | PLATFORM_mx8mn = "imx8mn" | 28 | ATF_PLATFORM_imx8dxlevk = "imx8dxl" |
29 | PLATFORM_mx8mp = "imx8mp" | 29 | ATF_PLATFORM_mx8dxlevk-phantom = "imx8qx" |
30 | PLATFORM_mx8dx = "imx8dx" | ||
31 | PLATFORM_imx8dxlevk = "imx8dxl" | ||
32 | PLATFORM_mx8dxlevk-phantom = "imx8qx" | ||
33 | 30 | ||
34 | EXTRA_OEMAKE += " \ | 31 | EXTRA_OEMAKE += " \ |
35 | CROSS_COMPILE="${TARGET_PREFIX}" \ | 32 | CROSS_COMPILE="${TARGET_PREFIX}" \ |
36 | PLAT=${PLATFORM} \ | 33 | PLAT=${ATF_PLATFORM} \ |
37 | " | 34 | " |
38 | 35 | ||
39 | BUILD_OPTEE = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'true', 'false', d)}" | 36 | BUILD_OPTEE = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'true', 'false', d)}" |
@@ -51,12 +48,12 @@ do_compile() { | |||
51 | do_install[noexec] = "1" | 48 | do_install[noexec] = "1" |
52 | 49 | ||
53 | do_deploy() { | 50 | do_deploy() { |
54 | install -Dm 0644 ${S}/build/${PLATFORM}/release/bl31.bin ${DEPLOYDIR}/${BOOT_TOOLS}/bl31-${PLATFORM}.bin | 51 | install -Dm 0644 ${S}/build/${ATF_PLATFORM}/release/bl31.bin ${DEPLOYDIR}/${BOOT_TOOLS}/bl31-${ATF_PLATFORM}.bin |
55 | if ${BUILD_OPTEE}; then | 52 | if ${BUILD_OPTEE}; then |
56 | install -m 0644 ${S}/build-optee/${PLATFORM}/release/bl31.bin ${DEPLOYDIR}/${BOOT_TOOLS}/bl31-${PLATFORM}.bin-optee | 53 | install -m 0644 ${S}/build-optee/${ATF_PLATFORM}/release/bl31.bin ${DEPLOYDIR}/${BOOT_TOOLS}/bl31-${ATF_PLATFORM}.bin-optee |
57 | fi | 54 | fi |
58 | } | 55 | } |
59 | addtask deploy after do_compile | 56 | addtask deploy after do_compile |
60 | 57 | ||
61 | PACKAGE_ARCH = "${MACHINE_SOCARCH}" | 58 | PACKAGE_ARCH = "${MACHINE_SOCARCH}" |
62 | COMPATIBLE_MACHINE = "(mx8)" | 59 | COMPATIBLE_MACHINE = "(mx8|use-mainline-bsp)" |