diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2022-02-18 21:49:11 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2022-02-21 20:06:28 -0300 |
commit | dbd0f0ae908a6b287488707cfe9f2d464b9b02d5 (patch) | |
tree | 156a3e17bd827103a8584b5e7f346d8bf2afd943 /recipes-bsp | |
parent | 4cbbc15d937d2fbd487f10431c59cc1c21b791eb (diff) | |
download | meta-freescale-dbd0f0ae908a6b287488707cfe9f2d464b9b02d5.tar.gz |
Rework recipes to use imx-generic-bsp more extensively
This rework the recipes making use of new imx-generic-bsp override; it
has been applied to:
- alsa-state
- firmware-imx
- imx-kobs
- imx-test
- imx-uuc
- linux-fslc
- linux-fslc-lts
- packagegroup-fsl-mfgtool
- u-boot-fslc
- uuu
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/alsa-state/alsa-state.bbappend | 12 | ||||
-rw-r--r-- | recipes-bsp/alsa-state/alsa-state/imx-generic-bsp/asound.conf (renamed from recipes-bsp/alsa-state/alsa-state/imx-nxp-bsp/asound.conf) | 0 | ||||
-rwxr-xr-x | recipes-bsp/alsa-state/alsa-state/imx-generic-bsp/asound.state (renamed from recipes-bsp/alsa-state/alsa-state/imx-nxp-bsp/asound.state) | 0 | ||||
-rw-r--r-- | recipes-bsp/firmware-imx/firmware-imx_8.14.bb | 2 | ||||
-rw-r--r-- | recipes-bsp/imx-kobs/imx-kobs_git.bb | 2 | ||||
-rw-r--r-- | recipes-bsp/imx-test/imx-test_00.00.00.bb | 2 | ||||
-rw-r--r-- | recipes-bsp/imx-uuc/imx-uuc_git.bb | 2 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-fslc_2022.01.bb | 2 |
8 files changed, 8 insertions, 14 deletions
diff --git a/recipes-bsp/alsa-state/alsa-state.bbappend b/recipes-bsp/alsa-state/alsa-state.bbappend index 4d766139..b4b1eddf 100644 --- a/recipes-bsp/alsa-state/alsa-state.bbappend +++ b/recipes-bsp/alsa-state/alsa-state.bbappend | |||
@@ -1,10 +1,4 @@ | |||
1 | # Append path for freescale layer to include alsa-state asound.conf | 1 | FILESEXTRAPATHS:prepend:imx-generic-bsp := "${THISDIR}/${PN}/imx-generic-bsp:" |
2 | FILESEXTRAPATHS:prepend:mx6-nxp-bsp := "${THISDIR}/${PN}/imx-nxp-bsp" | ||
3 | FILESEXTRAPATHS:prepend:mx7-nxp-bsp := "${THISDIR}/${PN}/imx-nxp-bsp" | ||
4 | FILESEXTRAPATHS:prepend:mx8-nxp-bsp := "${THISDIR}/${PN}/imx-nxp-bsp" | ||
5 | FILESEXTRAPATHS:prepend:use-mainline-bsp := "${THISDIR}/${PN}/imx-nxp-bsp" | ||
6 | 2 | ||
7 | PACKAGE_ARCH:mx6-nxp-bsp = "${MACHINE_ARCH}" | 3 | # Append path for freescale layer |
8 | PACKAGE_ARCH:mx7-nxp-bsp = "${MACHINE_ARCH}" | 4 | PACKAGE_ARCH:imx-generic-bsp = "${MACHINE_ARCH}" |
9 | PACKAGE_ARCH:mx8-nxp-bsp = "${MACHINE_ARCH}" | ||
10 | PACKAGE_ARCH:use-mainline-bsp = "${MACHINE_ARCH}" | ||
diff --git a/recipes-bsp/alsa-state/alsa-state/imx-nxp-bsp/asound.conf b/recipes-bsp/alsa-state/alsa-state/imx-generic-bsp/asound.conf index c511018e..c511018e 100644 --- a/recipes-bsp/alsa-state/alsa-state/imx-nxp-bsp/asound.conf +++ b/recipes-bsp/alsa-state/alsa-state/imx-generic-bsp/asound.conf | |||
diff --git a/recipes-bsp/alsa-state/alsa-state/imx-nxp-bsp/asound.state b/recipes-bsp/alsa-state/alsa-state/imx-generic-bsp/asound.state index ace734df..ace734df 100755 --- a/recipes-bsp/alsa-state/alsa-state/imx-nxp-bsp/asound.state +++ b/recipes-bsp/alsa-state/alsa-state/imx-generic-bsp/asound.state | |||
diff --git a/recipes-bsp/firmware-imx/firmware-imx_8.14.bb b/recipes-bsp/firmware-imx/firmware-imx_8.14.bb index 5186a1a8..cfc98a73 100644 --- a/recipes-bsp/firmware-imx/firmware-imx_8.14.bb +++ b/recipes-bsp/firmware-imx/firmware-imx_8.14.bb | |||
@@ -129,4 +129,4 @@ FILES:${PN}-hdmi = " \ | |||
129 | ${nonarch_base_libdir}/firmware/dpfw.bin \ | 129 | ${nonarch_base_libdir}/firmware/dpfw.bin \ |
130 | " | 130 | " |
131 | 131 | ||
132 | COMPATIBLE_MACHINE = "(imx-nxp-bsp|use-mainline-bsp)" | 132 | COMPATIBLE_MACHINE = "(imx-generic-bsp)" |
diff --git a/recipes-bsp/imx-kobs/imx-kobs_git.bb b/recipes-bsp/imx-kobs/imx-kobs_git.bb index a14c314e..f13299d0 100644 --- a/recipes-bsp/imx-kobs/imx-kobs_git.bb +++ b/recipes-bsp/imx-kobs/imx-kobs_git.bb | |||
@@ -15,4 +15,4 @@ S = "${WORKDIR}/git" | |||
15 | 15 | ||
16 | inherit autotools pkgconfig | 16 | inherit autotools pkgconfig |
17 | 17 | ||
18 | COMPATIBLE_MACHINE = "(imx-nxp-bsp|use-mainline-bsp)" | 18 | COMPATIBLE_MACHINE = "(imx-generic-bsp)" |
diff --git a/recipes-bsp/imx-test/imx-test_00.00.00.bb b/recipes-bsp/imx-test/imx-test_00.00.00.bb index 2feb9b3a..1850a16a 100644 --- a/recipes-bsp/imx-test/imx-test_00.00.00.bb +++ b/recipes-bsp/imx-test/imx-test_00.00.00.bb | |||
@@ -7,4 +7,4 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/MIT;md5=0835ad | |||
7 | ALLOW_EMPTY:${PN} = "1" | 7 | ALLOW_EMPTY:${PN} = "1" |
8 | 8 | ||
9 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 9 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
10 | COMPATIBLE_MACHINE = "(mxs-generic-bsp|mx5-generic-bsp|mx6-nxp-bsp|vf50-generic-bsp|vf60-generic-bsp)" | 10 | COMPATIBLE_MACHINE = "(imx-generic-bsp)" |
diff --git a/recipes-bsp/imx-uuc/imx-uuc_git.bb b/recipes-bsp/imx-uuc/imx-uuc_git.bb index 3c66088b..6d7adf33 100644 --- a/recipes-bsp/imx-uuc/imx-uuc_git.bb +++ b/recipes-bsp/imx-uuc/imx-uuc_git.bb | |||
@@ -18,4 +18,4 @@ S = "${WORKDIR}/git" | |||
18 | 18 | ||
19 | FILES:${PN} += "/linuxrc /fat" | 19 | FILES:${PN} += "/linuxrc /fat" |
20 | 20 | ||
21 | COMPATIBLE_MACHINE = "(imx-nxp-bsp|use-mainline-bsp)" | 21 | COMPATIBLE_MACHINE = "(imx-generic-bsp)" |
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2022.01.bb b/recipes-bsp/u-boot/u-boot-fslc_2022.01.bb index 6f9a251b..ec5298b6 100644 --- a/recipes-bsp/u-boot/u-boot-fslc_2022.01.bb +++ b/recipes-bsp/u-boot/u-boot-fslc_2022.01.bb | |||
@@ -28,4 +28,4 @@ EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CPPFLAGS}" \ | |||
28 | HOSTSTRIP=true' | 28 | HOSTSTRIP=true' |
29 | 29 | ||
30 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 30 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
31 | COMPATIBLE_MACHINE = "(mxs-generic-bsp|mx5-generic-bsp|mx6-nxp-bsp|mx7-nxp-bsp|vf-generic-bsp|use-mainline-bsp)" | 31 | COMPATIBLE_MACHINE = "(imx-generic-bsp)" |