diff options
author | Ting Liu <ting.liu@nxp.com> | 2016-01-09 14:43:22 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-04-19 15:03:23 -0300 |
commit | 238deb34afc3326989d5efe104bdc8449ffa0968 (patch) | |
tree | 7208b1859442ba25e89569107f3f37bf17806caf /recipes-bsp | |
parent | 8b19b82e5422fbc924bc6e80034e9b1f665ce0fe (diff) | |
download | meta-freescale-238deb34afc3326989d5efe104bdc8449ffa0968.tar.gz |
rcw: swap qspi binary in do_install_append
Signed-off-by: Ting Liu <ting.liu@nxp.com>
Signed-off-by: Zhenhua Luo <zhenhua.luo@nxp.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/rcw/rcw/rcw-make-BOARDS-DESTDIR-overidable-in-Makefile.patch | 57 | ||||
-rw-r--r-- | recipes-bsp/rcw/rcw_git.bb | 10 |
2 files changed, 7 insertions, 60 deletions
diff --git a/recipes-bsp/rcw/rcw/rcw-make-BOARDS-DESTDIR-overidable-in-Makefile.patch b/recipes-bsp/rcw/rcw/rcw-make-BOARDS-DESTDIR-overidable-in-Makefile.patch deleted file mode 100644 index 49d99fc5..00000000 --- a/recipes-bsp/rcw/rcw/rcw-make-BOARDS-DESTDIR-overidable-in-Makefile.patch +++ /dev/null | |||
@@ -1,57 +0,0 @@ | |||
1 | From f2e796c903b2a3f81dbd38da3dc087cb7539d307 Mon Sep 17 00:00:00 2001 | ||
2 | From: Zhenhua Luo <zhenhua.luo@freescale.com> | ||
3 | Date: Wed, 3 Sep 2014 03:03:42 -0500 | ||
4 | Subject: [PATCH] Makefile: make BOARDS/DESTDIR overidable and add endian | ||
5 | switch | ||
6 | |||
7 | 1. For one specific board, no need to build the rcw for all supported | ||
8 | targets, make BOARDS and DESTDIR overridable to achieve this. | ||
9 | 2. Add the endian swap for qspiboot rcw | ||
10 | |||
11 | Upstream-Status: Pending | ||
12 | |||
13 | Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com> | ||
14 | --- | ||
15 | Makefile | 4 ++-- | ||
16 | Makefile.inc | 9 +++++++-- | ||
17 | 2 files changed, 9 insertions(+), 4 deletions(-) | ||
18 | |||
19 | diff --git a/Makefile b/Makefile | ||
20 | index 6ec1697..0f94293 100644 | ||
21 | --- a/Makefile | ||
22 | +++ b/Makefile | ||
23 | @@ -1,5 +1,5 @@ | ||
24 | -DESTDIR = . | ||
25 | -BOARDS = b4420qds b4860qds \ | ||
26 | +DESTDIR ?= . | ||
27 | +BOARDS ?= b4420qds b4860qds \ | ||
28 | ls1021aqds ls1021atwr \ | ||
29 | p2041rdb p3041ds p4080ds p5020ds p5040ds \ | ||
30 | t1024qds t1023rdb t1024rdb t1040rdb t1042rdb t1042rdb_pi t1040qds \ | ||
31 | diff --git a/Makefile.inc b/Makefile.inc | ||
32 | index 4cadb2e..6e8b78f 100644 | ||
33 | --- a/Makefile.inc | ||
34 | +++ b/Makefile.inc | ||
35 | @@ -1,4 +1,4 @@ | ||
36 | -DESTDIR = . | ||
37 | +DESTDIR ?= . | ||
38 | INSTALL = install | ||
39 | PYTHON ?= python2 | ||
40 | RCW = $(PYTHON) ../rcw.py | ||
41 | @@ -18,7 +18,12 @@ all: $(targets) | ||
42 | install: $(targets) | ||
43 | $(INSTALL) -d $(DESTDIR) | ||
44 | @for file in $^; do \ | ||
45 | - $(INSTALL) -m 644 -D $$file $(DESTDIR)/$$file; \ | ||
46 | + case $$file in \ | ||
47 | + *qspiboot*) file_swap="`echo $$file | sed -e 's/qspiboot/qspiboot_swap/'`"; \ | ||
48 | + tclsh byte_swap.tcl $$file $$file_swap 8 ; \ | ||
49 | + $(INSTALL) -m 644 -D $$file_swap $(DESTDIR)/$$file_swap ;; \ | ||
50 | + *) $(INSTALL) -m 644 -D $$file $(DESTDIR)/$$file; \ | ||
51 | + esac \ | ||
52 | done | ||
53 | $(INSTALL) -m 644 -D README $(DESTDIR) | ||
54 | |||
55 | -- | ||
56 | 1.7.9.7 | ||
57 | |||
diff --git a/recipes-bsp/rcw/rcw_git.bb b/recipes-bsp/rcw/rcw_git.bb index 016ef820..0647c2ce 100644 --- a/recipes-bsp/rcw/rcw_git.bb +++ b/recipes-bsp/rcw/rcw_git.bb | |||
@@ -9,9 +9,7 @@ inherit deploy | |||
9 | 9 | ||
10 | SRCBRANCH = "master" | 10 | SRCBRANCH = "master" |
11 | SRCREV = "426f7a6535d93dac76f5125035e0938a85e778d2" | 11 | SRCREV = "426f7a6535d93dac76f5125035e0938a85e778d2" |
12 | SRC_URI = "git://git.freescale.com/ppc/sdk/rcw.git;branch=${SRCBRANCH} \ | 12 | SRC_URI = "git://git.freescale.com/ppc/sdk/rcw.git;branch=${SRCBRANCH}" |
13 | file://rcw-make-BOARDS-DESTDIR-overidable-in-Makefile.patch \ | ||
14 | " | ||
15 | 13 | ||
16 | S = "${WORKDIR}/git" | 14 | S = "${WORKDIR}/git" |
17 | 15 | ||
@@ -20,6 +18,12 @@ EXTRA_OEMAKE = "BOARDS=${@d.getVar('MACHINE', True).replace('-64b','')} DESTDIR= | |||
20 | do_install () { | 18 | do_install () { |
21 | oe_runmake install | 19 | oe_runmake install |
22 | } | 20 | } |
21 | do_install_append_ls102xa () { | ||
22 | for f in `find ${D}/boot/rcw/ -name "*qspiboot*"`;do | ||
23 | f_swap=`echo $f |sed -e 's/qspiboot/qspiboot_swap/'` | ||
24 | tclsh ${STAGING_BINDIR_NATIVE}/byte_swap.tcl $f $f_swap 8 | ||
25 | done | ||
26 | } | ||
23 | 27 | ||
24 | do_deploy () { | 28 | do_deploy () { |
25 | install -d ${DEPLOYDIR}/rcw | 29 | install -d ${DEPLOYDIR}/rcw |