diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2022-03-31 17:39:35 -0500 |
---|---|---|
committer | Tom Hochstein <tom.hochstein@nxp.com> | 2022-03-31 19:37:58 -0500 |
commit | d93b387a8740bc5f6e61dac13888e9cc0f1cefa2 (patch) | |
tree | 5111741914b7fcb87aac225fa886c757e782456b /recipes-bsp | |
parent | 65398605b9f412ac851c945f4cbe36a81b899a8f (diff) | |
download | meta-freescale-d93b387a8740bc5f6e61dac13888e9cc0f1cefa2.tar.gz |
mx8dx: Normalize MACHINEOVERRIDES implementation
The imx8dx-mek machine is similar to imx8qxp-mek and so the mx8qxp override
was included in the MACHINEOVERRIDES hierarchy. This is non-standard, and
the rework of the SOC overrides didn't handle it properly, leading to a
build break:
```
Log data follows:
| DEBUG: Executing shell function do_compile
| NOTE: 8QX boot binary build
| cp: failed to access '/home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/git/iMX8DX/scfw_tcm.bin': Not a directory
| WARNING: /home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/temp/run.do_compile.1809636:179 exit 1 from 'cp /home/aquino/src/ossystems/oel-platform/build/tmp/deploy/images/imx8dx-mek/imx-boot$
tools/scfw_tcm.bin /home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/git/iMX8DX/scfw_tcm.bin'
| WARNING: Backtrace (BB generated script):
| #1: compile_mx8x, /home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/temp/run.do_compile.1809636, line 179
| #2: do_compile, /home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/temp/run.do_compile.1809636, line 151
| #3: main, /home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/temp/run.do_compile.1809636, line 189
ERROR: Task (/home/aquino/src/ossystems/oel-platform/sources/meta-freescale/recipes-bsp/imx-mkimage/imx-boot_1.0.bb:do_compile) failed with exit code '1'
```
Fix the problem by removing mx8qxp from the mx8dx hierarchy and adapting
existing mx8qxp overrides appropriately.
Fixes: #1027
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/imx-mkimage/imx-boot_1.0.bb | 1 |
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb index d5330897..88689ead 100644 --- a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb +++ b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb | |||
@@ -73,6 +73,7 @@ REV_OPTION ?= "" | |||
73 | REV_OPTION:mx8qxp-nxp-bsp = \ | 73 | REV_OPTION:mx8qxp-nxp-bsp = \ |
74 | "${@bb.utils.contains('MACHINE_FEATURES', 'soc-revb0', '', \ | 74 | "${@bb.utils.contains('MACHINE_FEATURES', 'soc-revb0', '', \ |
75 | 'REV=C0', d)}" | 75 | 'REV=C0', d)}" |
76 | REV_OPTION:mx8dx-nxp-bsp = "REV=C0" | ||
76 | 77 | ||
77 | compile_mx8m() { | 78 | compile_mx8m() { |
78 | bbnote 8MQ/8MM/8MN/8MP boot binary build | 79 | bbnote 8MQ/8MM/8MN/8MP boot binary build |