diff options
author | Chunrong Guo <chunrong.guo@nxp.com> | 2017-05-10 16:41:30 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2017-05-19 07:58:47 -0300 |
commit | fbe9c67f06a8114586c47bf28873af9433ae3c56 (patch) | |
tree | 3978e84a787e62e42e0f07cd73410fd4cdb0f35c /recipes-bsp | |
parent | fa9281613e2b3b669b06b085ffaf51d61e48a94b (diff) | |
download | meta-freescale-fbe9c67f06a8114586c47bf28873af9433ae3c56.tar.gz |
ppa: update to use Recipe Specific Sysroots
Signed-off-by: Chunrong Guo <B40290@freescale.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/ppa/ppa/ppa.its | 23 | ||||
-rw-r--r-- | recipes-bsp/ppa/ppa_git.bb | 18 |
2 files changed, 17 insertions, 24 deletions
diff --git a/recipes-bsp/ppa/ppa/ppa.its b/recipes-bsp/ppa/ppa/ppa.its deleted file mode 100644 index c157b6e5..00000000 --- a/recipes-bsp/ppa/ppa/ppa.its +++ /dev/null | |||
@@ -1,23 +0,0 @@ | |||
1 | /dts-v1/; | ||
2 | |||
3 | /{ | ||
4 | description = "PPA Firmware"; | ||
5 | #address-cells = <1>; | ||
6 | images { | ||
7 | firmware@1 { | ||
8 | description = "PPA Firmware: Version 0.1"; | ||
9 | data = /incbin/("obj/monitor.bin"); | ||
10 | type = "firmware"; | ||
11 | arch = "arm64"; | ||
12 | compression = "none"; | ||
13 | }; | ||
14 | }; | ||
15 | |||
16 | configurations { | ||
17 | default = "config@1"; | ||
18 | config@1 { | ||
19 | description = "Boot PPA firmware"; | ||
20 | firmware = "firmware@1"; | ||
21 | }; | ||
22 | }; | ||
23 | }; | ||
diff --git a/recipes-bsp/ppa/ppa_git.bb b/recipes-bsp/ppa/ppa_git.bb index 7f758fd6..98263bee 100644 --- a/recipes-bsp/ppa/ppa_git.bb +++ b/recipes-bsp/ppa/ppa_git.bb | |||
@@ -11,7 +11,23 @@ SRCREV = "9fcb080dd7415927aa3fbabfcba8982bcb1466d3" | |||
11 | 11 | ||
12 | S = "${WORKDIR}/git" | 12 | S = "${WORKDIR}/git" |
13 | 13 | ||
14 | EXTRA_OEMAKE = "CC64="${CC}" LD64="${LD}" OBJ64="${OBJCOPY}"" | 14 | python () { |
15 | ml = d.getVar("MULTILIB_VARIANTS", True) | ||
16 | arch = d.getVar("OVERRIDES", True) | ||
17 | if "fsl-lsch2-32b:" in arch: | ||
18 | if not "lib64" in ml: | ||
19 | raise bb.parse.SkipPackage("Building the u-boot for this arch requires multilib to be enabled") | ||
20 | sys_multilib = d.getVar('TARGET_VENDOR') + 'mllib64-linux' | ||
21 | sys_original = d.getVar('TARGET_VENDOR') + '-' + d.getVar('TARGET_OS') | ||
22 | workdir = d.getVar('WORKDIR').replace(sys_original,sys_multilib) | ||
23 | d.setVar('DEPENDS_append', ' lib64-gcc-cross-aarch64 lib64-libgcc') | ||
24 | d.setVar('PATH_append', ':' + d.getVar('STAGING_BINDIR_NATIVE') + '/aarch64' + sys_multilib) | ||
25 | d.setVar('TOOLCHAIN_OPTIONS', '--sysroot=' + workdir + '/lib64-recipe-sysroot') | ||
26 | d.setVar("WRAP_TARGET_PREFIX", 'aarch64' + sys_multilib + '-') | ||
27 | } | ||
28 | |||
29 | WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}" | ||
30 | EXTRA_OEMAKE = 'CC64="${WRAP_TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}" LD64="${WRAP_TARGET_PREFIX}ld ${TOOLCHAIN_OPTIONS}" OBJ64="${WRAP_TARGET_PREFIX}objcopy"' | ||
15 | 31 | ||
16 | PPA_PATH ?= "ppa/soc-ls1043/platform-rdb" | 32 | PPA_PATH ?= "ppa/soc-ls1043/platform-rdb" |
17 | PPA_PATH_ls1046a = "ppa/soc-ls1046/platform-rdb" | 33 | PPA_PATH_ls1046a = "ppa/soc-ls1046/platform-rdb" |