summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2016-01-09 14:42:56 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-04-19 15:03:22 -0300
commit3e9b83711ebe13548b3486b59327126a7865ecda (patch)
treefb5e35acd31c8aba0afdca95096dfb3a1c536a87 /recipes-bsp
parentfb6d5953fcb70c317c273a3f324c4523f613d16b (diff)
downloadmeta-freescale-3e9b83711ebe13548b3486b59327126a7865ecda.tar.gz
u-boot-qoriq: exit if UBOOT_CONFIG not supported
Signed-off-by: Ting Liu <ting.liu@nxp.com>> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot-qoriq_2015.01.bb15
1 files changed, 0 insertions, 15 deletions
diff --git a/recipes-bsp/u-boot/u-boot-qoriq_2015.01.bb b/recipes-bsp/u-boot/u-boot-qoriq_2015.01.bb
index 6df17206..e86bc7ce 100644
--- a/recipes-bsp/u-boot/u-boot-qoriq_2015.01.bb
+++ b/recipes-bsp/u-boot/u-boot-qoriq_2015.01.bb
@@ -57,14 +57,7 @@ S = "${WORKDIR}/git"
57EXTRA_OEMAKE = 'CROSS_COMPILE=${WRAP_TARGET_PREFIX} CC="${WRAP_TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"' 57EXTRA_OEMAKE = 'CROSS_COMPILE=${WRAP_TARGET_PREFIX} CC="${WRAP_TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"'
58 58
59do_compile_append_qoriq-ppc() { 59do_compile_append_qoriq-ppc() {
60 python ./tools/genboardscfg.py
61
62 for board in ${UBOOT_MACHINE}; do 60 for board in ${UBOOT_MACHINE}; do
63 if ! grep -wq $board ${S}/boards.cfg;then
64 echo "WARNING: $board not supported in boards.cfg"
65 continue
66 fi
67
68 case "${board}" in 61 case "${board}" in
69 *SDCARD*) UBOOT_TARGET="u-boot-sd";; 62 *SDCARD*) UBOOT_TARGET="u-boot-sd";;
70 *SPIFLASH*) UBOOT_TARGET="u-boot-spi";; 63 *SPIFLASH*) UBOOT_TARGET="u-boot-spi";;
@@ -124,10 +117,6 @@ unset i j
124 117
125do_install_append_qoriq-ppc() { 118do_install_append_qoriq-ppc() {
126 for board in ${UBOOT_MACHINE}; do 119 for board in ${UBOOT_MACHINE}; do
127 if ! grep -wq $board ${S}/boards.cfg;then
128 continue
129 fi
130
131 case "${board}" in 120 case "${board}" in
132 *SDCARD*) UBOOT_TARGET="u-boot-sd";; 121 *SDCARD*) UBOOT_TARGET="u-boot-sd";;
133 *SPIFLASH*) UBOOT_TARGET="u-boot-spi";; 122 *SPIFLASH*) UBOOT_TARGET="u-boot-spi";;
@@ -150,10 +139,6 @@ do_deploy_append_qoriq-ppc() {
150 fi 139 fi
151 140
152 for board in ${UBOOT_MACHINES}; do 141 for board in ${UBOOT_MACHINES}; do
153 if ! grep -wq $board ${S}/boards.cfg;then
154 continue
155 fi
156
157 case "${board}" in 142 case "${board}" in
158 *SDCARD*) UBOOT_TARGET="u-boot-sd";; 143 *SDCARD*) UBOOT_TARGET="u-boot-sd";;
159 *SPIFLASH*) UBOOT_TARGET="u-boot-spi";; 144 *SPIFLASH*) UBOOT_TARGET="u-boot-spi";;