diff options
author | Carlos Rafael Giani <crg7475@mailbox.org> | 2020-04-24 09:06:03 +0200 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2020-04-24 08:13:12 -0300 |
commit | 83fbc86016b68d6d84854af1762401c7e2eea729 (patch) | |
tree | ba5907e7bd489cc11b7fa2f4ea2421185e62c657 /recipes-bsp | |
parent | c3bdc608728223ac6d215da616196afea57168cd (diff) | |
download | meta-freescale-83fbc86016b68d6d84854af1762401c7e2eea729.tar.gz |
libimxdmabuffer: Fix ptest
Signed-off-by: Carlos Rafael Giani <crg7475@mailbox.org>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/libimxdmabuffer/files/run-ptest | 10 | ||||
-rw-r--r-- | recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb | 13 |
2 files changed, 19 insertions, 4 deletions
diff --git a/recipes-bsp/libimxdmabuffer/files/run-ptest b/recipes-bsp/libimxdmabuffer/files/run-ptest new file mode 100644 index 00000000..09f69a8d --- /dev/null +++ b/recipes-bsp/libimxdmabuffer/files/run-ptest | |||
@@ -0,0 +1,10 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | ./test-alloc >/dev/null 2>&1 | ||
4 | |||
5 | if [ $? -eq 0 ]; then | ||
6 | echo "PASS: test-alloc" | ||
7 | else | ||
8 | echo "FAIL: test-alloc" | ||
9 | fi | ||
10 | |||
diff --git a/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb index 346a3cf5..9b918f2c 100644 --- a/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb +++ b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb | |||
@@ -9,7 +9,10 @@ PV .= "+git${SRCPV}" | |||
9 | 9 | ||
10 | SRCBRANCH ?= "master" | 10 | SRCBRANCH ?= "master" |
11 | SRCREV = "d2058aa404ee1e8e8abd552c6a637787bcdcf514" | 11 | SRCREV = "d2058aa404ee1e8e8abd552c6a637787bcdcf514" |
12 | SRC_URI = "git://github.com/Freescale/libimxdmabuffer.git;branch=${SRCBRANCH}" | 12 | SRC_URI = "git://github.com/Freescale/libimxdmabuffer.git;branch=${SRCBRANCH} \ |
13 | file://run-ptest \ | ||
14 | " | ||
15 | |||
13 | 16 | ||
14 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |
15 | 18 | ||
@@ -33,9 +36,11 @@ PACKAGECONFIG[ipu] = "--with-ipu-allocator=yes, --with-ipu-allocat | |||
33 | PACKAGECONFIG[g2d] = "--with-g2d-allocator=yes, --with-g2d-allocator=no,virtual/libg2d" | 36 | PACKAGECONFIG[g2d] = "--with-g2d-allocator=yes, --with-g2d-allocator=no,virtual/libg2d" |
34 | PACKAGECONFIG[pxp] = "--with-pxp-allocator=yes, --with-pxp-allocator=no," | 37 | PACKAGECONFIG[pxp] = "--with-pxp-allocator=yes, --with-pxp-allocator=no," |
35 | 38 | ||
36 | do_install_ptest () { | 39 | # Using do_install_ptest_base instead of do_install_ptest, since |
37 | install -d ${D}${PTEST_PATH}/tests | 40 | # the default do_install_ptest_base is hardcoded to expect Makefiles. |
38 | install -m 0755 ${B}/test-alloc ${D}${PTEST_PATH}/tests | 41 | do_install_ptest_base() { |
42 | install -D ${WORKDIR}/run-ptest ${D}${PTEST_PATH}/run-ptest | ||
43 | install -m 0755 ${B}/test-alloc ${D}${PTEST_PATH} | ||
39 | } | 44 | } |
40 | 45 | ||
41 | COMPATIBLE_MACHINE = "(mx6|mx7|mx8)" | 46 | COMPATIBLE_MACHINE = "(mx6|mx7|mx8)" |