summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/uefi
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2017-08-09 16:54:38 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2017-08-21 17:04:36 -0300
commit0ec1f1ac37f51c5605612e2fecb430c8a05b45ce (patch)
tree53e0ced264096e19ba590ceb22206970b46b6b62 /recipes-bsp/uefi
parent86e2ed54cd60da4f9f427baf6dbefbc9911141e6 (diff)
downloadmeta-freescale-0ec1f1ac37f51c5605612e2fecb430c8a05b45ce.tar.gz
uefi: add recipes
Signed-off-by: Chunrong Guo <B40290@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/uefi')
-rw-r--r--recipes-bsp/uefi/uefi_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-bsp/uefi/uefi_git.bb b/recipes-bsp/uefi/uefi_git.bb
new file mode 100644
index 00000000..5b71047e
--- /dev/null
+++ b/recipes-bsp/uefi/uefi_git.bb
@@ -0,0 +1,30 @@
1DESCRIPTION = "Unified Extensible Firmware Interface"
2SECTION = "bootloaders"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
5
6inherit deploy
7
8SRC_URI = "git://github.com/qoriq-open-source/uefi-binary.git;nobranch=1"
9SRCREV= "d0974b734d0c50c99baebf54957ce32433905e40"
10
11S = "${WORKDIR}/git"
12
13do_install () {
14 install -d ${D}/uefi
15 cp -r ${B}/grub ${D}/uefi
16 cp -r ${B}/${MACHINE} ${D}/uefi
17}
18
19do_deploy () {
20 install -d ${DEPLOYDIR}/uefi
21 cp -r ${B}/grub ${DEPLOYDIR}/uefi
22 cp -r ${B}/${MACHINE} ${DEPLOYDIR}/uefi
23}
24addtask deploy before do_build after do_install
25
26PACKAGES += "${PN}-image"
27FILES_${PN}-image += "/uefi/*"
28
29PACKAGE_ARCH = "${MACHINE_SOCARCH}"
30