summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorJoris Offouga <offougajoris@gmail.com>2018-10-15 17:03:34 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2018-10-26 11:46:14 -0300
commit1925b1cce5efb6dce8bea68177b09a27a66acc83 (patch)
treeba6e212b742f9a3e259ed9d248ed12eb859e7d5d /recipes-bsp/u-boot
parent1b3f4326274b4a45d672e24fb1886cf811486cb1 (diff)
downloadmeta-freescale-1925b1cce5efb6dce8bea68177b09a27a66acc83.tar.gz
u-boot-qoriq: use a u-boot-qoriq-common include
Use a common file to make easier update, maintain and create others U-Boot recipes like U-Boot fw-utils. Signed-off-by: Joris Offouga <offougajoris@gmail.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot-qoriq-common_2018.03.inc19
-rw-r--r--recipes-bsp/u-boot/u-boot-qoriq_2018.03.bb19
2 files changed, 20 insertions, 18 deletions
diff --git a/recipes-bsp/u-boot/u-boot-qoriq-common_2018.03.inc b/recipes-bsp/u-boot/u-boot-qoriq-common_2018.03.inc
new file mode 100644
index 00000000..5be64e49
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-qoriq-common_2018.03.inc
@@ -0,0 +1,19 @@
1
2inherit fsl-u-boot-localversion
3
4LICENSE = "GPLv2 & BSD-3-Clause & BSD-2-Clause & LGPL-2.0 & LGPL-2.1"
5LIC_FILES_CHKSUM = " \
6 file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://Licenses/bsd-2-clause.txt;md5=6a31f076f5773aabd8ff86191ad6fdd5 \
8 file://Licenses/bsd-3-clause.txt;md5=4a1190eac56a9db675d58ebe86eaf50c \
9 file://Licenses/lgpl-2.0.txt;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
10 file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c \
11"
12
13SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/u-boot;nobranch=1 \
14"
15SRCREV = "1e96fd8f464dfe23eb692a11018c20d70546783b"
16
17S = "${WORKDIR}/git"
18PV_append = "+fslgit"
19LOCALVERSION = "+fsl" \ No newline at end of file
diff --git a/recipes-bsp/u-boot/u-boot-qoriq_2018.03.bb b/recipes-bsp/u-boot/u-boot-qoriq_2018.03.bb
index 48646c03..0ad754f7 100644
--- a/recipes-bsp/u-boot/u-boot-qoriq_2018.03.bb
+++ b/recipes-bsp/u-boot/u-boot-qoriq_2018.03.bb
@@ -1,29 +1,15 @@
1require recipes-bsp/u-boot/u-boot.inc 1require recipes-bsp/u-boot/u-boot.inc
2require u-boot-qoriq-common_${PV}.inc
2 3
3DESCRIPTION = "U-Boot provided by Freescale with focus on QorIQ boards" 4DESCRIPTION = "U-Boot provided by Freescale with focus on QorIQ boards"
4PROVIDES += "u-boot" 5PROVIDES += "u-boot"
5LICENSE = "GPLv2 & BSD-3-Clause & BSD-2-Clause & LGPL-2.0 & LGPL-2.1"
6LIC_FILES_CHKSUM = " \
7 file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://Licenses/bsd-2-clause.txt;md5=6a31f076f5773aabd8ff86191ad6fdd5 \
9 file://Licenses/bsd-3-clause.txt;md5=4a1190eac56a9db675d58ebe86eaf50c \
10 file://Licenses/lgpl-2.0.txt;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
11 file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c \
12"
13 6
14PV_append = "+fslgit"
15INHIBIT_DEFAULT_DEPS = "1" 7INHIBIT_DEFAULT_DEPS = "1"
16DEPENDS = "libgcc virtual/${TARGET_PREFIX}gcc" 8DEPENDS = "libgcc virtual/${TARGET_PREFIX}gcc"
17DEPENDS_append_qoriq-arm64 = " change-file-endianess-native dtc-native tcl-native" 9DEPENDS_append_qoriq-arm64 = " change-file-endianess-native dtc-native tcl-native"
18DEPENDS_append_qoriq-arm = " change-file-endianess-native dtc-native tcl-native" 10DEPENDS_append_qoriq-arm = " change-file-endianess-native dtc-native tcl-native"
19DEPENDS_append_qoriq-ppc = " boot-format-native" 11DEPENDS_append_qoriq-ppc = " boot-format-native"
20 12
21SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/u-boot;nobranch=1 \
22"
23SRCREV = "1e96fd8f464dfe23eb692a11018c20d70546783b"
24
25S = "${WORKDIR}/git"
26
27python () { 13python () {
28 if d.getVar("TCMODE", True) == "external-fsl": 14 if d.getVar("TCMODE", True) == "external-fsl":
29 return 15 return
@@ -61,9 +47,6 @@ WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}"
61EXTRA_OEMAKE = 'CROSS_COMPILE=${WRAP_TARGET_PREFIX} CC="${WRAP_TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS} ${ENDIANNESS_GCC}" LD="${WRAP_TARGET_PREFIX}ld ${ENDIANNESS_LD}" V=1' 47EXTRA_OEMAKE = 'CROSS_COMPILE=${WRAP_TARGET_PREFIX} CC="${WRAP_TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS} ${ENDIANNESS_GCC}" LD="${WRAP_TARGET_PREFIX}ld ${ENDIANNESS_LD}" V=1'
62EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}"' 48EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}"'
63 49
64inherit fsl-u-boot-localversion
65LOCALVERSION = "+fsl"
66
67do_compile_append_qoriq() { 50do_compile_append_qoriq() {
68 unset i j k 51 unset i j k
69 for config in ${UBOOT_MACHINE}; do 52 for config in ${UBOOT_MACHINE}; do