diff options
author | Andrey Zhizhikin <andrey.z@gmail.com> | 2020-12-28 22:44:55 +0000 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2021-03-17 10:53:42 -0300 |
commit | ad48c133fa19aad480a27b7d3000f5e6401c8db0 (patch) | |
tree | c3db1f696099a30f81cd0d103decc5a3b234f5f3 /recipes-bsp/u-boot | |
parent | 2bc347d473ec9545e761fa06205727a825b446d0 (diff) | |
download | meta-freescale-ad48c133fa19aad480a27b7d3000f5e6401c8db0.tar.gz |
u-boot-fslc: add support to build boot container for mx8m
U-Boot provides a possibility to build a boot container for i.MX8M
derivaties, this is done via invoking a make target "flash.bin".
Add this support to the recipe via inheriting the imx-boot-container
class which extends U-Boot build system to construct flash.bin boot
container.
Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r-- | recipes-bsp/u-boot/u-boot-fslc_2020.10.bb | 12 |
1 files changed, 11 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2020.10.bb b/recipes-bsp/u-boot/u-boot-fslc_2020.10.bb index 522bbbda..86620c44 100644 --- a/recipes-bsp/u-boot/u-boot-fslc_2020.10.bb +++ b/recipes-bsp/u-boot/u-boot-fslc_2020.10.bb | |||
@@ -6,7 +6,9 @@ order to provide support for some backported features and fixes, or because it \ | |||
6 | was submitted for revision and it takes some time to become part of a stable \ | 6 | was submitted for revision and it takes some time to become part of a stable \ |
7 | version, or because it is not applicable for upstreaming." | 7 | version, or because it is not applicable for upstreaming." |
8 | 8 | ||
9 | DEPENDS_append = " bc-native dtc-native lzop-native" | 9 | inherit ${@oe.utils.ifelse(d.getVar('UBOOT_PROVIDES_BOOT_CONTAINER') == '1', 'imx-boot-container', '')} |
10 | |||
11 | DEPENDS += "bc-native dtc-native lzop-native" | ||
10 | 12 | ||
11 | # Location known to imx-boot component, where U-Boot artifacts | 13 | # Location known to imx-boot component, where U-Boot artifacts |
12 | # should be additionally deployed. | 14 | # should be additionally deployed. |
@@ -38,6 +40,14 @@ EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CPPFLAGS}" \ | |||
38 | # it is required that the U-Boot dtb files are to be deployed into | 40 | # it is required that the U-Boot dtb files are to be deployed into |
39 | # a location known by imx-boot so they could be picked up and | 41 | # a location known by imx-boot so they could be picked up and |
40 | # inserted into the boot container. | 42 | # inserted into the boot container. |
43 | # | ||
44 | # NOTE: This is only applicable to those derivatives of mx8m family, | ||
45 | # which did not adopt the boot container mechanism provided by U-Boot | ||
46 | # build system itself. U-Boot is capable of producing a result binary, | ||
47 | # which includes all those deployed pieces below, hence once derivative | ||
48 | # starts to use it - below append would not be necessary. | ||
49 | # Once all mx8m derivatives are migrated to use the 'flash.bin' boot | ||
50 | # container - this append can be dropped completely. | ||
41 | do_deploy_append_mx8m() { | 51 | do_deploy_append_mx8m() { |
42 | # Deploy the mkimage, u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary | 52 | # Deploy the mkimage, u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary |
43 | if [ -n "${UBOOT_CONFIG}" ]; then | 53 | if [ -n "${UBOOT_CONFIG}" ]; then |