summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-07-15 17:14:27 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-07-16 15:01:29 -0300
commitf8517afc7a5ada4538b3b7d397fa32586d57ffe5 (patch)
tree79349f091306d1760fd4687e62336ffa8fb8c721 /recipes-bsp/u-boot
parentc92b415d653afc55f33b6b93fb9248193bfd4fa0 (diff)
downloadmeta-freescale-f8517afc7a5ada4538b3b7d397fa32586d57ffe5.tar.gz
Move meta-fsl-arm content to layer root
The meta-fsl-arm is going to be used as the base for this layer. It contains a clean history and allowing a more granullar set of changes. This commit is just a rename of all contents of meta-fsl-arm subdirectory to this layer's root, subsequent changes are based on top of that. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-mxsboot_2015.04.bb35
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc.inc33
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc_2015.04.bb6
-rw-r--r--recipes-bsp/u-boot/u-boot-imx-mfgtool_2014.04.bb4
-rw-r--r--recipes-bsp/u-boot/u-boot-imx/mx53_loco_bootenv.patch51
-rw-r--r--recipes-bsp/u-boot/u-boot-imx/mx6dl_sabresd-Change-default-environment-to-work-wit.patch67
-rw-r--r--recipes-bsp/u-boot/u-boot-imx/mx6q_sabreauto-Fix-the-patch-for-the-default-environ.patch66
-rw-r--r--recipes-bsp/u-boot/u-boot-imx/mx6q_sabresd-Change-default-environment-to-work-with.patch66
-rw-r--r--recipes-bsp/u-boot/u-boot-imx/mx6sl_evk-Fix-the-patch-for-the-default-environment-.patch67
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2014.04.bb22
-rw-r--r--recipes-bsp/u-boot/u-boot-ls1_2015.01.bb48
-rw-r--r--recipes-bsp/u-boot/u-boot-mfgtool.inc21
12 files changed, 486 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2015.04.bb b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2015.04.bb
new file mode 100644
index 00000000..3981b604
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2015.04.bb
@@ -0,0 +1,35 @@
1DESCRIPTION = "U-boot bootloader mxsboot tool"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
4SECTION = "bootloader"
5DEPENDS = "openssl"
6PROVIDES = "u-boot-mxsboot"
7
8PV = "v2015.04+git${SRCPV}"
9
10SRCREV = "10aced37cecf117e54e71bd700228f57dc34e579"
11SRCBRANCH = "patches-2015.04"
12
13SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH}"
14
15S = "${WORKDIR}/git"
16
17inherit fsl-u-boot-localversion
18
19EXTRA_OEMAKE = 'HOSTCC="${CC} ${CPPFLAGS}" HOSTLDFLAGS="-L${libdir} -L${base_libdir}" HOSTSTRIP=true CONFIG_MX28=y'
20
21do_configure () {
22 oe_runmake sandbox_defconfig
23}
24
25do_compile () {
26 oe_runmake tools-only
27}
28
29do_install () {
30 install -d ${D}${bindir}
31 install -m 0755 tools/mxsboot ${D}${bindir}/uboot-mxsboot
32 ln -sf uboot-mxsboot ${D}${bindir}/mxsboot
33}
34
35BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-bsp/u-boot/u-boot-fslc.inc b/recipes-bsp/u-boot/u-boot-fslc.inc
new file mode 100644
index 00000000..07fb5074
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-fslc.inc
@@ -0,0 +1,33 @@
1# Copyright (C) 2012-2014 O.S. Systems Software LTDA.
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4require recipes-bsp/u-boot/u-boot.inc
5
6inherit fsl-u-boot-localversion
7
8DESCRIPTION = "U-Boot based on mainline U-Boot used by FSL Community BSP in \
9order to provide support for some backported features and fixes, or because it \
10was submitted for revision and it takes some time to become part of a stable \
11version, or because it is not applicable for upstreaming."
12LICENSE = "GPLv2+"
13LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
14COMPATIBLE_MACHINE = "(mxs|mx3|mx5|mx6|vf)"
15
16DEPENDS_mxs += "elftosb-native openssl-native"
17
18PROVIDES += "u-boot"
19
20SRCBRANCH ??= "master"
21
22SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH}"
23
24S = "${WORKDIR}/git"
25
26# FIXME: Allow linking of 'tools' binaries with native libraries
27# used for generating the boot logo and other tools used
28# during the build process.
29EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CPPFLAGS}" \
30 HOSTLDFLAGS="${BUILD_LDFLAGS}" \
31 HOSTSTRIP=true'
32
33PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2015.04.bb b/recipes-bsp/u-boot/u-boot-fslc_2015.04.bb
new file mode 100644
index 00000000..aeefc5a9
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-fslc_2015.04.bb
@@ -0,0 +1,6 @@
1include u-boot-fslc.inc
2
3PV = "v2015.04+git${SRCPV}"
4
5SRCREV = "5d9ffd22149119c0acfd31efb8c4d40afca7ce6f"
6SRCBRANCH = "patches-2015.04"
diff --git a/recipes-bsp/u-boot/u-boot-imx-mfgtool_2014.04.bb b/recipes-bsp/u-boot/u-boot-imx-mfgtool_2014.04.bb
new file mode 100644
index 00000000..f66114c7
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-imx-mfgtool_2014.04.bb
@@ -0,0 +1,4 @@
1# Copyright (C) 2014 O.S. Systems Software LTDA.
2
3require u-boot-imx_${PV}.bb
4require u-boot-mfgtool.inc
diff --git a/recipes-bsp/u-boot/u-boot-imx/mx53_loco_bootenv.patch b/recipes-bsp/u-boot/u-boot-imx/mx53_loco_bootenv.patch
new file mode 100644
index 00000000..4b0ac9bf
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-imx/mx53_loco_bootenv.patch
@@ -0,0 +1,51 @@
1diff --git a/include/configs/mx53_loco.h b/include/configs/mx53_loco.h
2index 0f57f78..e8a6414 100644
3--- a/include/configs/mx53_loco.h
4+++ b/include/configs/mx53_loco.h
5@@ -114,22 +114,30 @@
6 #define CONFIG_RD_LOADADDR (CONFIG_LOADADDR + 0x300000)
7
8 #define CONFIG_EXTRA_ENV_SETTINGS \
9- "netdev=eth0\0" \
10- "ethprime=FEC0\0" \
11- "uboot=u-boot.bin\0" \
12- "kernel=uImage\0" \
13- "nfsroot=/opt/eldk/arm\0" \
14- "bootargs_base=setenv bootargs console=ttymxc0,115200\0"\
15- "bootargs_nfs=setenv bootargs ${bootargs} root=/dev/nfs "\
16- "ip=dhcp nfsroot=${serverip}:${nfsroot},v3,tcp\0"\
17- "bootcmd_net=run bootargs_base bootargs_nfs; " \
18- "tftpboot ${loadaddr} ${kernel}; bootm\0" \
19- "bootargs_mmc=setenv bootargs ${bootargs} ip=dhcp " \
20- "root=/dev/mmcblk0p1 rootwait rw\0" \
21- "bootcmd_mmc=run bootargs_base bootargs_mmc; " \
22- "mmc dev 0; " \
23- "mmc read ${loadaddr} 0x800 0x1800; bootm\0" \
24- "bootcmd=run bootcmd_mmc\0" \
25+ "script=boot.scr\0" \
26+ "uimage=uImage\0" \
27+ "mmcdev=0\0" \
28+ "mmcpart=1\0" \
29+ "mmcroot=/dev/mmcblk0p2 rw\0" \
30+ "mmcrootfstype=ext3 rootwait\0" \
31+ "mmcargs=setenv bootargs console=ttymxc0,${baudrate} " \
32+ "root=${mmcroot} " \
33+ "rootfstype=${mmcrootfstype}\0" \
34+ "loadbootscript=" \
35+ "fatload mmc ${mmcdev}:${mmcpart} ${loadaddr} ${script};\0" \
36+ "bootscript=echo Running bootscript from mmc ...; " \
37+ "source\0" \
38+ "loaduimage=fatload mmc ${mmcdev}:${mmcpart} ${loadaddr} ${uimage}\0" \
39+ "mmcboot=echo Booting from mmc ...; " \
40+ "run mmcargs; " \
41+ "bootm\0" \
42+ "netargs=setenv bootargs console=ttymxc0,${baudrate} " \
43+ "root=/dev/nfs " \
44+ "ip=dhcp nfsroot=${serverip}:${nfsroot},v3,tcp\0" \
45+ "netboot=echo Booting from net ...; " \
46+ "run netargs; " \
47+ "dhcp ${uimage}; bootm\0" \
48+ "bootcmd=run loaduimage; run mmcboot;\0" \
49 \
50
51
diff --git a/recipes-bsp/u-boot/u-boot-imx/mx6dl_sabresd-Change-default-environment-to-work-wit.patch b/recipes-bsp/u-boot/u-boot-imx/mx6dl_sabresd-Change-default-environment-to-work-wit.patch
new file mode 100644
index 00000000..da4a771e
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-imx/mx6dl_sabresd-Change-default-environment-to-work-wit.patch
@@ -0,0 +1,67 @@
1From 7ae3e4c665bd27111ee8ae2b801251b1d32f44cc Mon Sep 17 00:00:00 2001
2From: Daiane Angolini <daiane.angolini@freescale.com>
3Date: Wed, 20 Mar 2013 03:57:54 -0500
4Subject: [PATCH] mx6dl_sabresd: Change default environment to work with OE
5
6Upstream-Status: Inappropriate [configuration]
7
8Signed-off-by: Daiane Angolini <daiane.angolini@freescale.com>
9---
10 include/configs/mx6dl_sabresd.h | 41 ++++++++++++++++++++++----------------
11 1 files changed, 24 insertions(+), 17 deletions(-)
12
13diff --git a/include/configs/mx6dl_sabresd.h b/include/configs/mx6dl_sabresd.h
14index a496453..6499d25 100644
15--- a/include/configs/mx6dl_sabresd.h
16+++ b/include/configs/mx6dl_sabresd.h
17@@ -121,23 +121,30 @@
18 #define CONFIG_RD_LOADADDR (CONFIG_LOADADDR + 0x300000)
19
20 #define CONFIG_EXTRA_ENV_SETTINGS \
21- "netdev=eth0\0" \
22- "ethprime=FEC0\0" \
23- "uboot=u-boot.bin\0" \
24- "kernel=uImage\0" \
25- "nfsroot=/opt/eldk/arm\0" \
26- "bootargs_base=setenv bootargs console=ttymxc0,115200\0"\
27- "bootargs_nfs=setenv bootargs ${bootargs} root=/dev/nfs "\
28- "ip=dhcp nfsroot=${serverip}:${nfsroot},v3,tcp\0"\
29- "bootcmd_net=run bootargs_base bootargs_nfs; " \
30- "tftpboot ${loadaddr} ${kernel}; bootm\0" \
31- "bootargs_mmc=setenv bootargs ${bootargs} ip=dhcp " \
32- "root=/dev/mmcblk0p1 rootwait\0" \
33- "bootcmd_mmc=run bootargs_base bootargs_mmc; " \
34- "mmc dev 3; " \
35- "mmc read ${loadaddr} 0x800 0x2000; bootm\0" \
36- "bootcmd=run bootcmd_net\0" \
37-
38+ "script=boot.scr\0" \
39+ "uimage=uImage\0" \
40+ "mmcdev=2\0" \
41+ "mmcpart=1\0" \
42+ "mmcroot=/dev/mmcblk1p2 rw\0" \
43+ "mmcrootfstype=ext3 rootwait\0" \
44+ "mmcargs=setenv bootargs console=ttymxc0,${baudrate} " \
45+ "root=${mmcroot} " \
46+ "rootfstype=${mmcrootfstype}\0" \
47+ "loadbootscript=" \
48+ "fatload mmc ${mmcdev}:${mmcpart} ${loadaddr} ${script};\0" \
49+ "bootscript=echo Running bootscript from mmc ...; " \
50+ "source\0" \
51+ "loaduimage=fatload mmc ${mmcdev}:${mmcpart} ${loadaddr} ${uimage}\0" \
52+ "mmcboot=echo Booting from mmc ...; " \
53+ "run mmcargs; " \
54+ "bootm\0" \
55+ "netargs=setenv bootargs console=ttymxc0,${baudrate} " \
56+ "root=/dev/nfs " \
57+ "ip=dhcp nfsroot=${serverip}:${nfsroot},v3,tcp\0" \
58+ "netboot=echo Booting from net ...; " \
59+ "run netargs; " \
60+ "dhcp ${uimage}; bootm\0" \
61+ "bootcmd=run loaduimage; run mmcboot;\0" \
62
63 #define CONFIG_ARP_TIMEOUT 200UL
64
65--
661.7.5.4
67
diff --git a/recipes-bsp/u-boot/u-boot-imx/mx6q_sabreauto-Fix-the-patch-for-the-default-environ.patch b/recipes-bsp/u-boot/u-boot-imx/mx6q_sabreauto-Fix-the-patch-for-the-default-environ.patch
new file mode 100644
index 00000000..80ef444f
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-imx/mx6q_sabreauto-Fix-the-patch-for-the-default-environ.patch
@@ -0,0 +1,66 @@
1From a81c7686f8c0c4fc6e88228f215092c00d4714c1 Mon Sep 17 00:00:00 2001
2From: Daiane Angolini <daiane.angolini@freescale.com>
3Date: Tue, 30 Oct 2012 07:47:59 -0500
4Subject: [PATCH] mx6q_sabreauto: Fix the patch for the default environment
5 variable
6
7Signed-off-by: Daiane Angolini <daiane.angolini@freescale.com>
8---
9 include/configs/mx6q_sabreauto.h | 41 ++++++++++++++++++++++---------------
10 1 files changed, 24 insertions(+), 17 deletions(-)
11
12diff --git a/include/configs/mx6q_sabreauto.h b/include/configs/mx6q_sabreauto.h
13index 5f8f02c..5910eca 100644
14--- a/include/configs/mx6q_sabreauto.h
15+++ b/include/configs/mx6q_sabreauto.h
16@@ -121,23 +121,30 @@
17 #define CONFIG_RD_LOADADDR (CONFIG_LOADADDR + 0x300000)
18
19 #define CONFIG_EXTRA_ENV_SETTINGS \
20- "netdev=eth0\0" \
21- "ethprime=FEC0\0" \
22- "uboot=u-boot.bin\0" \
23- "kernel=uImage\0" \
24- "nfsroot=/opt/eldk/arm\0" \
25- "bootargs_base=setenv bootargs console=ttymxc3,115200\0"\
26- "bootargs_nfs=setenv bootargs ${bootargs} root=/dev/nfs "\
27- "ip=dhcp nfsroot=${serverip}:${nfsroot},v3,tcp\0"\
28- "bootcmd_net=run bootargs_base bootargs_nfs; " \
29- "tftpboot ${loadaddr} ${kernel}; bootm\0" \
30- "bootargs_mmc=setenv bootargs ${bootargs} " \
31- "root=/dev/mmcblk0p1 rootwait\0" \
32- "bootcmd_mmc=run bootargs_base bootargs_mmc; " \
33- "mmc dev 2; " \
34- "mmc read ${loadaddr} 0x800 0x2000; bootm\0" \
35- "bootcmd=run bootcmd_mmc\0" \
36-
37+ "script=boot.scr\0" \
38+ "uimage=uImage\0" \
39+ "mmcdev=2\0" \
40+ "mmcpart=1\0" \
41+ "mmcroot=/dev/mmcblk0p2 rw\0" \
42+ "mmcrootfstype=ext3 rootwait\0" \
43+ "mmcargs=setenv bootargs console=ttymxc3,${baudrate} " \
44+ "root=${mmcroot} " \
45+ "rootfstype=${mmcrootfstype}\0" \
46+ "loadbootscript=" \
47+ "fatload mmc ${mmcdev}:${mmcpart} ${loadaddr} ${script};\0" \
48+ "bootscript=echo Running bootscript from mmc ...; " \
49+ "source\0" \
50+ "loaduimage=fatload mmc ${mmcdev}:${mmcpart} ${loadaddr} ${uimage}\0" \
51+ "mmcboot=echo Booting from mmc ...; " \
52+ "run mmcargs; " \
53+ "bootm\0" \
54+ "netargs=setenv bootargs console=ttymxc3,${baudrate} " \
55+ "root=/dev/nfs " \
56+ "ip=dhcp nfsroot=${serverip}:${nfsroot},v3,tcp\0" \
57+ "netboot=echo Booting from net ...; " \
58+ "run netargs; " \
59+ "dhcp ${uimage}; bootm\0" \
60+ "bootcmd=run loaduimage; run mmcboot;\0" \
61
62 #define CONFIG_ARP_TIMEOUT 200UL
63
64--
651.7.5.4
66
diff --git a/recipes-bsp/u-boot/u-boot-imx/mx6q_sabresd-Change-default-environment-to-work-with.patch b/recipes-bsp/u-boot/u-boot-imx/mx6q_sabresd-Change-default-environment-to-work-with.patch
new file mode 100644
index 00000000..bf85800f
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-imx/mx6q_sabresd-Change-default-environment-to-work-with.patch
@@ -0,0 +1,66 @@
1From 970f04b228a60c805cce41ef8403ba2c8cb56d97 Mon Sep 17 00:00:00 2001
2From: Otavio Salvador <otavio@ossystems.com.br>
3Date: Wed, 13 Feb 2013 15:15:28 -0200
4Subject: [PATCH] mx6q_sabresd: Change default environment to work with OE
5
6Upstream-Status: Inappropriate [configuration]
7
8Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
9---
10 include/configs/mx6q_sabresd.h | 40 ++++++++++++++++++++++++----------------
11 1 file changed, 24 insertions(+), 16 deletions(-)
12
13diff --git a/include/configs/mx6q_sabresd.h b/include/configs/mx6q_sabresd.h
14index 6f07961..db31a34 100644
15--- a/include/configs/mx6q_sabresd.h
16+++ b/include/configs/mx6q_sabresd.h
17@@ -116,22 +116,30 @@
18 #define CONFIG_RD_LOADADDR (0x1300000)
19
20 #define CONFIG_EXTRA_ENV_SETTINGS \
21- "netdev=eth0\0" \
22- "ethprime=FEC0\0" \
23- "uboot=u-boot.bin\0" \
24- "kernel=uImage\0" \
25- "nfsroot=/opt/eldk/arm\0" \
26- "bootargs_base=setenv bootargs console=ttymxc0,115200\0"\
27- "bootargs_nfs=setenv bootargs ${bootargs} root=/dev/nfs "\
28- "ip=dhcp nfsroot=${serverip}:${nfsroot},v3,tcp\0"\
29- "bootcmd_net=run bootargs_base bootargs_nfs; " \
30- "tftpboot ${loadaddr} ${kernel}; bootm\0" \
31- "bootargs_mmc=setenv bootargs ${bootargs} ip=dhcp " \
32- "root=/dev/mmcblk0p1 rootwait\0" \
33- "bootcmd_mmc=run bootargs_base bootargs_mmc; " \
34- "mmc dev 3; " \
35- "mmc read ${loadaddr} 0x800 0x2000; bootm\0" \
36- "bootcmd=run bootcmd_net\0" \
37+ "script=boot.scr\0" \
38+ "uimage=uImage\0" \
39+ "mmcdev=2\0" \
40+ "mmcpart=1\0" \
41+ "mmcroot=/dev/mmcblk0p2 rw\0" \
42+ "mmcrootfstype=ext3 rootwait\0" \
43+ "mmcargs=setenv bootargs console=ttymxc3,${baudrate} " \
44+ "root=${mmcroot} " \
45+ "rootfstype=${mmcrootfstype}\0" \
46+ "loadbootscript=" \
47+ "fatload mmc ${mmcdev}:${mmcpart} ${loadaddr} ${script};\0" \
48+ "bootscript=echo Running bootscript from mmc ...; " \
49+ "source\0" \
50+ "loaduimage=fatload mmc ${mmcdev}:${mmcpart} ${loadaddr} ${uimage}\0" \
51+ "mmcboot=echo Booting from mmc ...; " \
52+ "run mmcargs; " \
53+ "bootm\0" \
54+ "netargs=setenv bootargs console=ttymxc3,${baudrate} " \
55+ "root=/dev/nfs " \
56+ "ip=dhcp nfsroot=${serverip}:${nfsroot},v3,tcp\0" \
57+ "netboot=echo Booting from net ...; " \
58+ "run netargs; " \
59+ "dhcp ${uimage}; bootm\0" \
60+ "bootcmd=run loaduimage; run mmcboot;\0" \
61
62
63 #define CONFIG_ARP_TIMEOUT 200UL
64--
651.8.1
66
diff --git a/recipes-bsp/u-boot/u-boot-imx/mx6sl_evk-Fix-the-patch-for-the-default-environment-.patch b/recipes-bsp/u-boot/u-boot-imx/mx6sl_evk-Fix-the-patch-for-the-default-environment-.patch
new file mode 100644
index 00000000..5d3f868d
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-imx/mx6sl_evk-Fix-the-patch-for-the-default-environment-.patch
@@ -0,0 +1,67 @@
1From bf99fdddbca321f7e74ed82febbe4b5539e3ac66 Mon Sep 17 00:00:00 2001
2From: Daiane Angolini <daiane.angolini@freescale.com>
3Date: Thu, 14 Mar 2013 16:35:35 -0300
4Subject: [PATCH] mx6sl_evk: Change the patch for the default environment
5 variable
6
7Upstream-Status: Pending
8
9Signed-off-by: Daiane Angolini <daiane.angolini@freescale.com>
10---
11 include/configs/mx6sl_evk.h | 40 ++++++++++++++++++++++++----------------
12 1 file changed, 24 insertions(+), 16 deletions(-)
13
14diff --git a/include/configs/mx6sl_evk.h b/include/configs/mx6sl_evk.h
15index 4c327bc..dfb6374 100644
16--- a/include/configs/mx6sl_evk.h
17+++ b/include/configs/mx6sl_evk.h
18@@ -122,22 +122,30 @@
19 #define CONFIG_RD_LOADADDR 0x81000000
20
21 #define CONFIG_EXTRA_ENV_SETTINGS \
22- "netdev=eth0\0" \
23- "ethprime=FEC0\0" \
24- "uboot=u-boot.bin\0" \
25- "kernel=uImage\0" \
26- "nfsroot=/opt/eldk/arm\0" \
27- "bootargs_base=setenv bootargs console=ttymxc0,115200\0"\
28- "bootargs_nfs=setenv bootargs ${bootargs} root=/dev/nfs "\
29- "ip=dhcp nfsroot=${serverip}:${nfsroot},v3,tcp\0"\
30- "bootcmd_net=run bootargs_base bootargs_nfs; " \
31- "tftpboot ${loadaddr} ${kernel}; bootm\0" \
32- "bootargs_mmc=setenv bootargs ${bootargs} " \
33- "root=/dev/mmcblk0p1 rootwait\0" \
34- "bootcmd_mmc=run bootargs_base bootargs_mmc; " \
35- "mmc dev 1; " \
36- "mmc read ${loadaddr} 0x800 0x2000; bootm\0" \
37- "bootcmd=run bootcmd_mmc\0" \
38+ "script=boot.scr\0" \
39+ "uimage=uImage\0" \
40+ "mmcdev=1\0" \
41+ "mmcpart=1\0" \
42+ "mmcroot=/dev/mmcblk0p2 rw\0" \
43+ "mmcrootfstype=ext3 rootwait\0" \
44+ "mmcargs=setenv bootargs console=ttymxc0,${baudrate} " \
45+ "root=${mmcroot} " \
46+ "rootfstype=${mmcrootfstype}\0" \
47+ "loadbootscript=" \
48+ "fatload mmc ${mmcdev}:${mmcpart} ${loadaddr} ${script};\0" \
49+ "bootscript=echo Running bootscript from mmc ...; " \
50+ "source\0" \
51+ "loaduimage=fatload mmc ${mmcdev}:${mmcpart} ${loadaddr} ${uimage}\0" \
52+ "mmcboot=echo Booting from mmc ...; " \
53+ "run mmcargs; " \
54+ "bootm\0" \
55+ "netargs=setenv bootargs console=ttymxc0,${baudrate} " \
56+ "root=/dev/nfs " \
57+ "ip=dhcp nfsroot=${serverip}:${nfsroot},v3,tcp\0" \
58+ "netboot=echo Booting from net ...; " \
59+ "run netargs; " \
60+ "dhcp ${uimage}; bootm\0" \
61+ "bootcmd=run loaduimage; run mmcboot;\0" \
62
63
64 #define CONFIG_ARP_TIMEOUT 200UL
65--
661.7.10.4
67
diff --git a/recipes-bsp/u-boot/u-boot-imx_2014.04.bb b/recipes-bsp/u-boot/u-boot-imx_2014.04.bb
new file mode 100644
index 00000000..ebae6922
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-imx_2014.04.bb
@@ -0,0 +1,22 @@
1# Copyright (C) 2013-2015 Freescale Semiconductor
2
3DESCRIPTION = "U-Boot provided by Freescale with focus on i.MX reference boards."
4require recipes-bsp/u-boot/u-boot.inc
5
6PROVIDES += "u-boot"
7
8LICENSE = "GPLv2+"
9LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263"
10
11SRCBRANCH = "imx_v2014.04_3.14.28_1.0.0_ga"
12SRC_URI = "git://git.freescale.com/imx/uboot-imx.git;protocol=git;branch=${SRCBRANCH}"
13SRCREV = "88123ea911e133724cbe738c2b0517fa470592c0"
14
15S = "${WORKDIR}/git"
16
17inherit fsl-u-boot-localversion
18
19LOCALVERSION ?= "-${SRCBRANCH}"
20
21PACKAGE_ARCH = "${MACHINE_ARCH}"
22COMPATIBLE_MACHINE = "(mx6)"
diff --git a/recipes-bsp/u-boot/u-boot-ls1_2015.01.bb b/recipes-bsp/u-boot/u-boot-ls1_2015.01.bb
new file mode 100644
index 00000000..716105f4
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-ls1_2015.01.bb
@@ -0,0 +1,48 @@
1require recipes-bsp/u-boot/u-boot.inc
2
3DESCRIPTION = "U-Boot provided by Freescale with focus on QorIQ Layerscape1 boards"
4LICENSE = "GPLv2 & BSD-3-Clause & BSD-2-Clause & LGPL-2.0 & LGPL-2.1"
5LIC_FILES_CHKSUM = " \
6 file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://Licenses/bsd-2-clause.txt;md5=6a31f076f5773aabd8ff86191ad6fdd5 \
8 file://Licenses/bsd-3-clause.txt;md5=4a1190eac56a9db675d58ebe86eaf50c \
9 file://Licenses/lgpl-2.0.txt;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
10 file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c \
11"
12
13SRCBRANCH = "master"
14SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;branch=${SRCBRANCH}"
15SRCREV = "6ba8eedbcdc4b063f59a63e6288b938af739e8ad"
16
17LOCALVERSION ?= "+ls1"
18
19S = "${WORKDIR}/git"
20
21inherit fsl-u-boot-localversion
22
23DEPENDS += "change-file-endianess-native dtc-native"
24PROVIDES += "u-boot"
25
26do_compile_append () {
27 if [ "x${UBOOT_CONFIG}" != "x" ]
28 then
29 for config in ${UBOOT_MACHINE}; do
30 case "${config}" in
31 *spi*) tclsh ${STAGING_BINDIR_NATIVE}/byte_swap.tcl ${S}/${config}/u-boot-dtb.bin ${S}/${config}/u-boot.swap.bin 8
32 mv ${S}/${config}/u-boot.swap.bin ${S}/u-boot-${type}.${UBOOT_SUFFIX};;
33 *sdcard*) mv ${S}/${config}/u-boot-with-spl-pbl.bin ${S}/${config}/u-boot.bin;;
34 *nand*) mv ${S}/u-boot-with-spl-pbl.bin ${S}/u-boot.bin;;
35 esac
36 done
37 fi
38
39}
40
41PACKAGES += "${PN}-images"
42FILES_${PN}-images += "/boot"
43
44ALLOW_EMPTY_${PN} = "1"
45
46PACKAGE_ARCH = "${MACHINE_ARCH}"
47COMPATIBLE_MACHINE = "(ls102xa)"
48
diff --git a/recipes-bsp/u-boot/u-boot-mfgtool.inc b/recipes-bsp/u-boot/u-boot-mfgtool.inc
new file mode 100644
index 00000000..91526ad7
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-mfgtool.inc
@@ -0,0 +1,21 @@
1# Produces a Manufacturing Tool compatible U-Boot
2#
3# This makes a separated binary set for Manufacturing Tool use
4# without clobbering the U-Boot used for normal use.
5#
6# This file must to be included after the original u-boot.inc file,
7# as it overrides the need values.
8#
9# Copyright (C) 2014 O.S. Systems Software LTDA.
10
11# Adjust provides
12PROVIDES = "u-boot-mfgtool"
13
14# Use 'mfgtool' config
15UBOOT_CONFIG = "mfgtool"
16
17# Add 'mfgtool' suffix
18UBOOT_IMAGE = "u-boot-${MACHINE}-mfgtool-${PV}-${PR}.${UBOOT_SUFFIX}"
19UBOOT_SYMLINK = "u-boot-${MACHINE}-mfgtool.${UBOOT_SUFFIX}"
20SPL_IMAGE = "${SPL_BINARY}-${MACHINE}-mfgtool-${PV}-${PR}"
21SPL_SYMLINK = "${SPL_BINARY}-mfgtool-${MACHINE}"